15:31:03 <lalatenduM> #startmeeting StorageSIG
15:31:03 <centbot> Meeting started Fri Jan  9 15:31:03 2015 UTC.  The chair is lalatenduM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:03 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:12 * hchiramm in
15:31:23 * kbsingh is here too
15:31:31 <lalatenduM> who we have here for the Storage sig meeting?
15:31:43 <bvanassche> Bart Van Assche
15:31:48 <scuttlemonkey> <-
15:31:54 <hchiramm> Humble Chirammmal :)
15:31:57 <lalatenduM> #chair billings scuttlemonkey bvanassche kbsingh hchiramm
15:31:57 <centbot> Current chairs: billings bvanassche hchiramm kbsingh lalatenduM scuttlemonkey
15:32:17 <lalatenduM> anyone I missed?
15:32:25 <lalatenduM> alphacc, ^^ :)
15:32:44 <lalatenduM> Happy new year folks :)
15:33:04 <lalatenduM> #topic Agenda
15:33:12 <lalatenduM> #info     Topic:        Status Updates
15:33:12 <lalatenduM> #info    Subtopic:   GlusterFS
15:33:12 <lalatenduM> #info    Subtopic:   OpenAFS
15:33:12 <lalatenduM> #info    Subtopic:   Ceph
15:33:12 <lalatenduM> #info    Subtopic:   SCST
15:33:13 <lalatenduM> #info    Open Floor
15:33:41 <lalatenduM> #topic Action items from last meetings
15:34:03 <lalatenduM> I missed to put this topic in the agenda :(
15:34:16 <lalatenduM> anyways lets go through the AIs
15:34:33 <lalatenduM> billings to build OpenAFS using koji
15:34:47 <billings> I just got my koji credentials this morning
15:34:50 <lalatenduM> billings, lets carry it forward to next meeting
15:34:51 <lalatenduM> yeah
15:35:02 <billings> thanks
15:35:10 <lalatenduM> billings deason alphacc kbsingh to to brainstorm on some infrastructure/automation to automatically build a new srpm every time a new kernel comes out
15:35:22 <billings> could you make that an action?
15:35:29 <lalatenduM> #action billings to build OpenAFS using koji
15:35:34 <lalatenduM> done
15:35:34 <billings> thanks
15:35:49 <kbsingh> from the reimzul side - where the distro components are built - we already have trigger support
15:36:00 <billings> excellent
15:36:05 <lalatenduM> awesome
15:36:13 <kbsingh> so how i see that working in this requirement is : srpm is imported, kernel does its thing, built and pushed into the bstore ( that is the justbuilt ) repos
15:36:14 <billings> there are some issues I have with the current storage7 targets
15:36:25 <kbsingh> that part is the easy bit
15:36:54 <kbsingh> the tricky bit is - how then do we make this bstore repo available to koji, immediately, then have the kmod's built against that repo
15:37:05 <kbsingh> once the kmod's are done - how do we test them to get some level of confidence
15:37:27 <kbsingh> finally, if all is good, we can release things in sync ( it will actually be kmod's first, then kernel )
15:37:30 <billings> is the bstore repo a regularly named repo?
15:37:40 <billings> could we have a custom target that always includes it?
15:37:58 <kbsingh> note: doing this entire proces, the kernel isnt released... so it cant take too long - also, when something fails, do we hold kernel till its fixed, or do we time out at say 4 hrs )
15:38:09 <kbsingh> bstore repos are internal to reimzul
15:38:18 <billings> an
15:38:20 <billings> ah
15:39:10 <lalatenduM> kbsingh, reimzul is CentOS core's build system, right?
15:39:30 <kbsingh> billings: http://buildlogs.centos.org/c7-updates/dracut/20141103134735/ is a bstore repo
15:39:39 <kbsingh> lalatenduM: yeah
15:39:42 <lalatenduM> #info reimzul is CentOS core's build system name
15:39:46 <billings> ah, so they're not staticly named
15:39:54 <kbsingh> so its not connected to koji itself, but it can run koji commands from the command line.
15:40:33 <kbsingh> billings: the datestamp bit is the UID for the build, it allows us to rebuild the same name-EVR repeatedly, the reimzul repo collector will only use the latest content ( by sorting on the UID )
15:41:05 <billings> well, the point is that we couldn't use it in koji since koji would never know about it.
15:41:45 <kbsingh> right, so we need to push that somewhere and trigger a koji repo update thing
15:41:45 <billings> unless reimzul had the ability to *create* a target that included that repo
15:42:13 <kbsingh> from my side of the fence, i think we can find a way technically to make this work
15:42:30 <kbsingh> however, the thing that is a bigger challenge is going to be the policy side of things
15:42:42 <kbsingh> what do we do with the distro kernel if say, the openafs kmod failed
15:42:43 * billings nods
15:43:11 <billings> I have no problem having the policy be "if it builds, use it, if it doesn't, report and move on"
15:43:28 <lalatenduM> kbsingh, from storage sig point of view we should not release the distro kernel till openafs kmod builds fine
15:43:55 <kbsingh> so, is it just the openafs kmod that needs this ? iirc, the scst guys are ok to not need a kmod initially right ?
15:44:16 <kbsingh> lalatenduM: there is a way to make that work as well
15:44:20 <kbsingh> its a big of a hack
15:44:25 <lalatenduM> kbsingh, yeah or we take discussion at that moment
15:44:34 <kbsingh> but the workaround there would be to include the kernel in the openafs repo itself
15:44:39 <kbsingh> hve it linked from the distro tree's
15:45:05 <kbsingh> and then have the centos-release-openafs implement a yum-priorities to ensure only the kernel from openafs repo is used
15:45:21 <lalatenduM> kbsingh, ok
15:45:26 <kbsingh> that way, even if a newer kernel makes it to the updates/ repo, it wont be used on the machine of people who have the centos-release-openafs installed
15:45:34 <kbsingh> but hey, this is a proper hack and a half
15:46:02 <lalatenduM> kbsingh, lokks fine at this moment :)
15:46:24 <billings> yeah
15:46:33 <lalatenduM> I think that something people will signup for when they use storage sig
15:47:12 <billings> I could also make it an openafs-specific priority
15:47:12 <lalatenduM> so who owns the action item to try this out?
15:47:20 <kbsingh> note that if we do the yum priorities thing, then we need all the kernels in the openafs repo
15:47:21 <lalatenduM> billings, yes
15:47:38 <lalatenduM> kbsingh, yes
15:48:09 <kbsingh> right, and then someone should try this out manually and make sure its going to do what we think its going to do ( i am fairly confident, but its still something worth testing )
15:48:43 <lalatenduM> billings, should I put the AI on you?
15:48:50 <billings> sre
15:48:51 <billings> sure
15:49:29 <billings> I'm concerned that the existing storage7 target I tested against seems to be missing any updates since c7 was released
15:49:45 <billings> so we're certainly going to have to fix that
15:49:54 <lalatenduM> #action billings to try out reimzul's way of kmod building and yum priorities stuff for openafs repo
15:49:58 <hughesjr> have we solved the openafs license issue (speaking of openafs)
15:50:12 <lalatenduM> kbsingh, ^^
15:50:19 <billings> there's a licensing issue?
15:50:26 <alphacc> billings: Let me have a look. It may be due to priorities.
15:51:23 <lalatenduM> billings, honestly I dont know
15:52:23 <billings> I think there was some concern with CentOS packaging OpenAFS, but I think its ok as long as it's labeled with the IBM license.
15:52:32 <lalatenduM> hughesjr, may be this something you and kbsingh can discuss offline and update us
15:53:00 <lalatenduM> billings, lets take that offline
15:53:06 <billings> ok
15:53:08 <lalatenduM> moving ahead
15:53:15 <lalatenduM> lalatenduM will help deason to get standard policy or guidance on packaging selinux rules
15:53:18 <kbsingh> ok, we can work through the licensing stuff - i think it was mostly around it being GPL compatible or not and if it tainted kernel
15:53:22 <lalatenduM> deason, around?
15:53:42 <kbsingh> #action alphacc to validate the storage7 koji targets and setup new tags as needed for openafs
15:53:50 <hughesjr> billings: yes ... it uses the IBM Public License .. that is not GPL Version 2 or 3 compliant .. makes kernel modules problematic
15:53:54 <lalatenduM> #action kbsingh to see if openafs is GPL compatible or not
15:54:03 <billings> hughesjr: indeed.
15:54:27 <alphacc> billings: ok, it's fixed...
15:54:48 <lalatenduM> #action lalatenduM will help deason to get standard policy or guidance on packaging selinux rules
15:55:02 <lalatenduM> It is not done , hence moved to next week
15:55:12 <lalatenduM> lalatenduM will help scuttlemonkey on 101 for building Ceph on cbs
15:55:21 <lalatenduM> scuttlemonkey, we have not done this
15:55:32 <scuttlemonkey> yeah
15:55:32 <lalatenduM> may be because of holidays :)
15:55:36 <scuttlemonkey> nod
15:55:43 <lalatenduM> lets carry it forward
15:55:47 <lalatenduM> #action lalatenduM will help scuttlemonkey on 101 for building Ceph on cbs
15:55:55 <alphacc> billings: you did launch it a bit fast repo were regenerating ;)
15:56:00 <billings> haha
15:56:04 <lalatenduM> :)
15:56:08 <lalatenduM> kbsingh will start a discussion on "the build system should build the kmod packages from a spec file rather than having the makefile specificall build the rpm" as openafs and scst will need the functionality
15:56:10 <scuttlemonkey> lalatenduM: lets shoot for next wed if that works?
15:56:12 <billings> All I did was hit ^p enter, so it was easy. :)
15:56:24 <alphacc> effective multitasking
15:56:24 <lalatenduM> scuttlemonkey, fine
15:56:40 <kbsingh> ack
15:56:59 <lalatenduM> kbsingh, billings I think it is covered in the previous action item , right?
15:57:14 <billings> yes
15:57:19 <alphacc> billings: ok please ^p
15:57:34 <lalatenduM> vlnb to sync with lalatenduM to get access of buildsys
15:57:38 <lalatenduM> this is done
15:57:42 <lalatenduM> thanks to alphacc
15:58:02 <lalatenduM> hchiramm and lalatenduM to think more how tos/wikis for gluster in storage SIG.
15:58:15 <lalatenduM> hchiramm, you want to add something here?
15:58:34 <lalatenduM> hchiramm, has got access to wiki
15:58:40 <hchiramm> Still need to finalize on articles
15:58:48 <lalatenduM> ok
15:58:53 <hchiramm> however I have the wiki setup and a title ready to start
15:59:06 <hchiramm> will add contents to that and will come up with other articles
15:59:09 <bvanassche> Small correction: Vlad asked me to request build system access.
15:59:16 <bvanassche> I received access keys a few hours ago.
15:59:19 <lalatenduM> hchiramm, should I put an ai on you?
15:59:32 <hchiramm> please feel free :)
15:59:49 <lalatenduM> #info Vlad asked bvanassche to request build system access.
16:00:03 <kbsingh> bvanassche: have you been able to test the info ? are you setup to start throwing srpms at the targets /
16:00:11 <lalatenduM> #info bvanassche has got the build system access
16:00:29 <bvanassche> koji login works, but I have not yet had the time to try sending an SRPM to the build server.
16:01:03 <kbsingh> ok, there are some wiki pages with details on howto do that ( if you havent used koji in the past )
16:01:19 <hchiramm> lalatenduM, please put an AI on GlusterFS articles
16:01:20 <lalatenduM> bvanassche, feel free ping me for this
16:01:23 <lalatenduM> #action hchiramm needs to finalize wiki articles for GlusterFS
16:01:27 <hchiramm> :)
16:01:27 <lalatenduM> hchiramm, done
16:01:28 <kbsingh> bvanassche: my understanding is that you are going to only build userland stuff and nothing for the kernel specifically.
16:01:35 <kbsingh> bvanassche: eventually we might need to build a kmod as well
16:01:47 <kbsingh> bvanassche: and all the code is GPLd
16:01:51 <kbsingh> bvanassche: is that an accurate summary ?
16:02:00 <bvanassche> kbsingh: currently SCST consists of two RPMS - one RPM with kernel modules and one RPM with user space software.
16:02:12 <bvanassche> The GPL license applies to the source code of both packages.
16:02:33 <alphacc> bvanassche: the kmod is a real kmod doesn't need a rebuild with each kernel ? (if kabi is not modified)
16:02:35 <bvanassche> The RPM with kernel modules will have to be rebuilt after each kernel update.
16:02:53 <kbsingh> bvanassche: ok, but are we going to try and build the kmod's now ? i seem to recall from the last meeting that it wasent needed perse, it added a few features only used in a minority of cases
16:02:56 <bvanassche> SCST uses several kernel symbols that are outside the kABI.
16:03:13 <alphacc> bvanassche: ok thanks for confirming
16:04:17 <lalatenduM> #chair alphacc
16:04:17 <centbot> Current chairs: alphacc billings bvanassche hchiramm kbsingh lalatenduM scuttlemonkey
16:04:28 <bvanassche> kbsingh: The kernel modules contain the core SCST functionality and hence are essential.
16:04:48 <bvanassche> What is not essential are the core kernel patches (scst_exec_req_fifo and put_page_callback).
16:05:28 <lalatenduM> hmm, we need to build kmods
16:06:17 <kbsingh> bvanassche: ok
16:06:25 <lalatenduM> bvanassche, as I remember we dont need rebuild the kernel though as of now
16:06:51 <kbsingh> so if billings is able to confirm that the priority thing is going to work - we might need to do something similar for the scst repos as well
16:07:00 <lalatenduM> #info SCST would need to build kmods
16:07:01 <kbsingh> the trigger to build kmod's is easy
16:07:25 <lalatenduM> ok, moving ahead
16:07:38 <lalatenduM> #topic GlusterFS status
16:07:55 <lalatenduM> We are waiting for pkg signing infra
16:07:57 <bvanassche> lalatenduM: indeed - we are not asking to rebuild the CentOS kernel. During previous meeting I promised that I would rework the scst_exec_req_fifo patch and that I would transform that patch into core SCST code. I made good progress with that work and will send it to Vlad for review soon.
16:08:25 <lalatenduM> bvanassche, nice!
16:08:59 <lalatenduM> bvanassche, thanks for the efforts :)
16:09:24 <lalatenduM> kbsingh, alphacc , do you guys have any update on pkg signing infrastructure?
16:09:46 <kbsingh> lalatenduM: not yet, it came up in the cbs meeting on Monday - and its been worked out. i believ we should have something in the next week or two
16:10:27 <lalatenduM> kbsingh, ok. Should I publish the unsigned repos to mailing lists ?
16:10:51 <alphacc> kbsingh, lalatenduM : I am testing sigul. More news next week.
16:11:09 <lalatenduM> alphacc, cool
16:11:33 <kbsingh> lalatenduM: we should do what we did for openstack, lets get the repos on buildlogs.centos.org- make sure thr eis some docs on the wiki - and then we can announce it to the devel list for further testing etc
16:11:35 <alphacc> (the yum plugin we use at work for kernel/openafs matching http://linuxsoft.cern.ch/cern/slc6X/x86_64/SRPMS/yum-kernel-module-1-5.slc6.cern.src.rpm)
16:12:17 <lalatenduM> kbsingh, ok lets do that than as we have initial docs ready
16:12:40 <lalatenduM> #info Pkg signing infra might be available in next two weeks
16:13:02 <lalatenduM> hchiramm, you have anything for Gluster
16:13:21 <hchiramm> no for now
16:13:45 <lalatenduM> #action lalatenduM to publish the unsigned repos to mailing lists.
16:13:56 <lalatenduM> ok moving to next item
16:14:05 <lalatenduM> #topic openafs status
16:14:12 <lalatenduM> billings, any thing to add here
16:14:22 <billings> one moment
16:14:34 <billings> I think that deason had some patches he was working on
16:14:53 <billings> but I haven't heard any more about them, so I'm moving forward.
16:15:05 <lalatenduM> billings, cool
16:15:16 <lalatenduM> #topic Ceph status
16:15:24 <scuttlemonkey> lalatenduM: not much to say on this one
16:15:39 <lalatenduM> scuttlemonkey, yeah lets work on the action item
16:15:43 <scuttlemonkey> yeah
16:15:54 <lalatenduM> #topic SCST status
16:16:11 <lalatenduM> bvanassche, anything else you want to add?
16:16:34 <bvanassche> I think all I wanted to share has already been mentioned ...
16:16:45 <lalatenduM> bvanassche, yup. lets move ahead
16:16:53 <lalatenduM> #topic openfloor
16:17:01 <bvanassche> BTW, would it help if I would attend the CentOS meeting during FOSDEM ?
16:17:13 <bvanassche> I'm living in Belgium so that makes it easy for me to attend FOSDEM.
16:17:40 <lalatenduM> bvanassche, me and kbsingh , alphacc are coming to Fosdem and to the Dojo too
16:18:02 <lalatenduM> anyone else coming to Fosdem?
16:18:20 <lalatenduM> bvanassche, I think it will help
16:18:24 <lalatenduM> if you come
16:18:43 <bvanassche> OK, I will do my best to attend the CentOS meeting.
16:18:51 <lalatenduM> scuttlemonkey, are you coming for Fosdem?
16:18:55 <lalatenduM> billings, ^^
16:19:02 <scuttlemonkey> lalatenduM: no, I'll be out for that one unfortunately
16:19:02 <lalatenduM> hchiramm, ^^
16:19:09 <lalatenduM> scuttlemonkey, ok
16:19:33 <lalatenduM> ok. moving ahead
16:19:42 <kbsingh> bvanassche: come to the Dojo on friday
16:19:51 <bvanassche> OK
16:19:52 <billings> I am not going to fosdem.
16:19:53 <kbsingh> also, i think Loic is doing something on Ceph at the dojo
16:20:06 <billings> Brussels is a bit of a hike from here.
16:21:10 <scuttlemonkey> yeah, Loic is planning a demo/walkthrough type presentation
16:21:12 <lalatenduM> billings, where do you stay?
16:21:28 <lalatenduM> scuttlemonkey, thats in Dojo or Fosdem?
16:21:40 <lalatenduM> ah, dojo
16:21:42 <scuttlemonkey> it's part of the dojo
16:21:43 <scuttlemonkey> yeah
16:21:44 <lalatenduM> got it
16:21:50 <lalatenduM> ok moving on
16:21:54 <lalatenduM> Planning to have the next sig meeting after 2 weeks i.e. on 23rd Jan. Does it work for all?
16:22:21 <scuttlemonkey> yep
16:22:32 <kbsingh> yeah
16:22:42 <kbsingh> we can all syncup on the maillist in the mean time
16:22:58 <billings> fine.
16:23:03 <lalatenduM> #info The next sig meeting is after 2 weeks i.e. on 23rd Jan
16:23:03 <scuttlemonkey> cool beans
16:23:11 <lalatenduM> yes
16:23:45 <lalatenduM> anything to discuss? else time to close the meeting :0)
16:24:09 <lalatenduM> 1
16:24:11 <lalatenduM> 2
16:24:13 <lalatenduM> 3
16:24:18 <scuttlemonkey> sold!
16:24:18 <lalatenduM> #endmeeting