15:02:20 <kushal> #startmeeting CentOS Cloud SIG
15:02:20 <centbot> Meeting started Thu Jan 15 15:02:20 2015 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:20 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:26 <kushal> #Roll call
15:02:30 <kushal> Kushal is here.
15:02:39 <rbowen> Rich is here
15:03:31 <kushal> rtnpro, jmelis ?
15:03:34 <kushal> number80, ?
15:03:48 <kushal> apevec, ?
15:04:14 <kushal> I think rtnpro is traveling to his home town.
15:05:15 <kushal> #topic Last meeting's action items.
15:05:19 <kushal> * kushal to send in bug example for cbs access to jfontan
15:05:19 <kushal> * Kushal will drop an email to the centos-devel list about the blocker
15:05:19 <kushal> on Euca build dependencies.
15:05:19 <kushal> * number80 will help to setup a meeting to chat about ci.centos.org use
15:05:19 <kushal> for openstack in cloud sig
15:05:20 <kushal> * jfontan and jmelis will ask for CBS access for building rpms
15:05:22 <kushal> * rtnpro will organise a chat around mesos and packaging options for
15:05:24 <kushal> centos
15:05:28 <kushal> * apevec to start and run conversation around cloud component delivery
15:05:30 <kushal> repos and build tags
15:05:41 <kushal> I have send that email to jfontan but missed the euca email.
15:05:50 <kushal> I will do that today.
15:07:10 <kushal> I was also asking around for Euca on el7, I guess it will take at least 6-8 months more.
15:07:32 <kbsingh> w.r.t mesos - there was a conversation with tstclair and he feels that epel is a better place for mesos for now, so if they go down that route - we should drop it from the cloud sig
15:07:33 <kushal> kbsingh, rbowen Do you have anything to update?
15:07:53 <kushal> kbsingh, Okay.
15:08:19 <kushal> #info tstclair thinks mesos may be a better fit for EPEL.
15:08:37 <kushal> kbsingh, I will inform rtnpro about this.
15:08:40 <rbowen> No, I don't have any particular updates at this time.
15:09:04 <kbsingh> so, at the rdo meeting yesterday - CI came up
15:09:20 <kbsingh> and during the next few days, I am going to get some machines access to a few rdo folks to 'play with'
15:09:45 <kushal> Nice :)
15:09:45 <kbsingh> if we all feel things can work in that infra, then we will move to get some RDO CI at ci.centos.org -eventually replacing the present setup
15:10:17 <kushal> kbsingh, what is the current setup?
15:10:48 <kbsingh> we have a few controller bits to sort out, bu the hardware is documented at wiki.centos.org/QaWiki/PubHardware
15:10:50 <rbowen> The minutes from that meeting are at http://meetbot.fedoraproject.org/rdo/2015-01-14/rdo.2015-01-14-15.00.html
15:11:16 <kbsingh> presently, there is a public jenkins instance, that uses vm's hosted at trystack.org to run the workers and tempest
15:11:34 <kushal> Okay
15:12:00 <kbsingh> then, there was a conversation on the rdo-list about RDO on EL6
15:12:24 <kushal> kbsingh, rbowen may be off-topic, but I have started working on a simple CI system, which will run the tests on a fresh vm or a bare-metal box or on containers.
15:12:42 <kbsingh> and there is some interest in building Juno there, since people have invested on el6 - however, there is also a school of thought that the next version of openstack, due in 5 months, is going to be very hard to port back to el6
15:12:44 <kushal> Under heavy development though.
15:13:05 <kbsingh> but based on the conversation, it looked as if cloud sig might be a place for folks at large to experiment with this : juno on el6
15:13:08 <kushal> kbsingh, Which is a genuine concern I think.
15:13:51 <kbsingh> the question then is : given that alphacc wants this as well, do we form the cloud sig ramp up to offer folks the ability to come do this here ?
15:14:58 <kushal> kbsingh, I think having few more selected people with build power is not bad.
15:15:17 <kushal> Because there are many smaller packages to be maintained.
15:16:01 <rbowen> _1
15:16:03 <rbowen> +1, rather
15:16:20 <rbowen> Having more people with build power is a very good goal.
15:16:56 * number80 waves
15:17:05 <number80> +1
15:17:22 <kbsingh> the intention isnt to take up the task of doing juno or even kilo on el6 ourselves, but to make it possible for other people to come along and do it
15:17:24 <number80> more builders means less work for me which is something I could live with :)
15:18:14 <rbowen> Whether it's hard to backport to el6 doesn't strike me as a concern. That is, if there are people that are willing/able to do that work, we shouldn't stand in their way.
15:18:15 <kbsingh> number80: always a good goal
15:18:22 <kbsingh> rbowen: +1
15:18:40 <number80> rbowen: I totally agree
15:18:43 <rbowen> As the old saying goes, people who say it's impossible shouldn't get in the way of the people who are doing it. :-)
15:19:13 <number80> I may sound pessimistic about it but I just want to warn people that this is not an easy task
15:19:21 <kushal> rbowen, +1
15:19:21 <number80> easy or not, they will get my help anyway
15:19:29 <rbowen> Awesome.
15:20:00 <kbsingh> so one of us should take up the task of writing something up - a sort of 'welcome, come make this happen here with us '
15:20:01 <kushal> So who is going to identify these RDO devels? number80 rbowen kbsingh ?
15:20:06 <kbsingh> and we can then all socialise that
15:20:20 <kbsingh> kushal: i think its going to be RDO users who come together
15:20:47 <number80> kushal: Thomas volunteered but he already has access to the build system :)
15:21:01 <rbowen> Some of them have already identified themselves on either rdo-list or centos-devel - I forget where that conversation happened.
15:21:08 <kushal> number80, cool.
15:21:09 <kbsingh> cool :)
15:21:15 <kbsingh> lets get them together and kick this off
15:21:22 <number80> ok
15:21:27 <kushal> kbsingh, I guess rbowen is the best person to write that for RDO community.
15:21:48 <kbsingh> rbowen: that good for you ?
15:21:52 <rbowen> Yes
15:22:24 <kushal> #action rbowen will write to the RDO community about helping us on Juno on EL6 and for future releases.
15:22:26 <rbowen> https://www.redhat.com/archives/rdo-list/2015-January/msg00066.html <-- there it is.
15:22:32 <kushal> haha
15:22:41 <rbowen> So that conversation is ongoing.
15:23:05 <kbsingh> cool
15:23:21 <rbowen> The trouble right now is that the conversation is happening (at least) three different places, and we need to get everyone "in the same room"
15:23:36 <rbowen> That's been a slow process so far, but we're working on getting there.
15:23:37 <kbsingh> there is one more thing i want to bring to the meting today.. after this topic
15:24:08 <kbsingh> rbowen: totally. given that its about rdo - lets try and get this conversation on the rdo list
15:25:00 <rbowen> So if you're not already on rdo-list - https://www.redhat.com/mailman/listinfo/rdo-list - please consider getting on there. It's pretty low traffic.
15:25:42 <kushal> rbowen, thanks :)
15:25:49 <kushal> #link https://www.redhat.com/mailman/listinfo/rdo-list
15:26:06 <kbsingh> cool
15:27:09 <kushal> kbsingh, you wanted to say something after this one.
15:27:44 <kbsingh> yeah, so  we have rdo in the repos - what would be good to get, if we can, is to run a RDO instance and then use that to validate the centos cloud images
15:28:23 <kbsingh> the images are being built fairly regularly, and at the moment i only validate them at AWS and in local KVM - it would be good if we can get a RDO install up and use that as well
15:28:40 <rbowen> Is trystack.org a possible place for that?
15:28:54 <kushal> yup, number80 can help us to get an setup ready :)
15:29:07 <rbowen> Or we need something more rigorous like ci.centos.org?
15:29:23 <kbsingh> rbowen: i guess the thing is also about dogfooding, so the rdo build we run should be the latest rdo that is in cloud sig
15:29:42 <rbowen> Ah, right, while trystack aims to be more stable.
15:30:13 <number80> kushal: yes
15:30:27 <kbsingh> cool, so if i was to find us some machines, number80 can own that process ?
15:30:42 <kbsingh> i guess even a single machine, all in one install might be ok
15:31:00 <number80> kbsingh: I can own the process but it will be better to check with our RDO CI folks
15:31:51 <number80> CI is probably another place to contibute effectively to the cloud SIG
15:32:01 <kushal> #action kbsingh will find some box for number80 for a RDO install
15:32:22 <number80> #action number80 will do the RDO install on that box
15:32:41 <kbsingh> number80: right i agree - the bit i am also nt clear about at the moment is if we want to have rdo ci do cloud image ci - or we have a static rdo install, that we use to do ci for the cloud images against
15:32:48 <kbsingh> we can talk about this on the list and thrash it out
15:33:33 <kushal> kbsingh, I would want a static rdo doing cloud image ci
15:33:44 <number80> kbsingh: I got it, two different CI for me
15:33:54 <kushal> that way we will know that it is not the cloud's fault :)
15:33:59 <number80> yay
15:34:20 <kushal> number80, :)
15:34:25 <kbsingh> thats all my stuff for this meeting
15:34:49 <number80> :)
15:35:28 <kushal> I guess we can end the meeting now.
15:35:30 <kbsingh> looking forward to the dojo and rdo demo/tutorial  we have 68 people registerd for that so far - we might have a few more, i suspect atleat 40 of them will be in the rdo session
15:35:39 <kushal> kbsingh, nice
15:35:46 <rbowen> And I'll continue to try to cross-polinate all of the places that this conversation is happening, and hopefully converge a little.
15:35:57 <rbowen> 68. Wow. That's awesome.
15:36:24 <kbsingh> rbowen: pollination, across the nation!
15:37:06 <kbsingh> so, one thing that we should certainly do is - writeup the process we want to tell people about on the day, and then reherse it a few times
15:37:23 <kbsingh> dont think we will have time at the venue on the day itself
15:38:01 <kushal> kbsingh, that is a good idea for such large number of people attending.
15:38:40 <rbowen> If we can write a one-page step-by-step, and want to get it printed to hand out, let me know, and we'll figure something out.
15:38:47 <rbowen> even if we have to run down to a print shop in the morning.
15:39:31 <kushal> rbowen, will you be there in devconf?
15:40:04 <kushal> kbsingh, rbowen I have received the visa, will collect the passport tomorrow.
15:40:36 <rbowen> I won't be at devconf. I will be at FOSDEM and the Dojo.
15:40:44 <rbowen> But I need to come back home Monday morning.
15:41:02 <kushal> rbowen, Okay.
15:41:23 <kbsingh> rbowen: that might be the best thing to do - get a step by step written up and han out -
15:41:42 <kbsingh> number80: can you can i sync up early next week and trial / demo this a few times ? maybe 2 hrs or so we can run through it
15:42:08 <kbsingh> i will be at fosdem/dojo and then head home sunday night, but fly out to devconf the following weekend
15:42:20 <kushal> I guess I can end the meeting.
15:42:23 <number80> kbsingh: next week is doable
15:42:26 <kushal> #endmeeting