15:33:28 <lalatenduM_> #startmeeting StorageSIG
15:33:28 <centbot> Meeting started Fri Mar 27 15:33:28 2015 UTC.  The chair is lalatenduM_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:28 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:33:31 <walters> kbsingh, good morning, can we put together a quick doc on where the atomic bits are built...maybe in  https://github.com/CentOS/sig-atomic-buildscripts/blob/master/README ? Basically what I'm wondering at the moment is I built an new ostree package http://cbs.centos.org/koji/buildinfo?buildID=886 ~44 hours ago, but no new tree AFAICS yet
15:33:47 <lalatenduM_> #topic rollcall
15:33:58 <lalatenduM_> #chair lalatenduM_ bvanassche
15:33:58 <centbot> Current chairs: bvanassche lalatenduM_
15:34:04 <lalatenduM_> anyone else
15:34:05 <lalatenduM_> ?
15:34:46 <lalatenduM_> bvanassche, looks like its you and me :)
15:35:00 <bvanassche> That's a small audience ...
15:35:09 <bvanassche> At least, smaller than what I had expected.
15:35:23 <lalatenduM_> bvanassche, JustinClift was around too
15:35:32 <lalatenduM_> I think kbsingh is in a different time zone
15:35:46 <lalatenduM_> scuttlemonkey, has a conflicting meeting
15:36:00 <bvanassche> This week I'm in California; tomorrow I will travel back to Belgium.
15:36:04 <lalatenduM_> not sure about others
15:36:23 <lalatenduM_> bvanassche, lets discuss abt SCST
15:36:38 <lalatenduM_> #topic old action items
15:36:59 <lalatenduM_> #info I and kbsingh have made no process in GlusterFS
15:37:24 <lalatenduM_> #info Ceph also has not made progress
15:37:45 <lalatenduM_> #info OpenAFS kind of blocked as of now
15:38:00 <lalatenduM_> bvanassche, did u have any action items?
15:38:39 <bvanassche> My latest action item was to convert the SCST dpkg RPM into a regular kernel module RPM that works for one specific kernel version.
15:38:52 <bvanassche> I have done that.
15:39:26 <bvanassche> But what's not clear to me is whether the koji build infrastructure allows to build a kernel module against a kernel update ?
15:39:31 <lalatenduM_> bvanassche, is it available in public domain?
15:39:45 <bvanassche> Yes - in the SourceForge SCST repository.
15:39:46 <lalatenduM_> I mean the spec files
15:39:50 <bvanassche> Yes.
15:40:04 <bvanassche> I can look up the URL if you want such that you can have a look.
15:40:05 <lalatenduM_> bvanassche, can you plz point me to those
15:40:17 <lalatenduM_> yeah URL would be helpful
15:40:30 <bvanassche> One second please ...
15:40:44 <lalatenduM_> sure
15:41:02 <bvanassche> http://sourceforge.net/p/scst/svn/HEAD/tree/trunk/scst.spec.in
15:41:05 <JustinClift> lalatenduM_: Gah, just got back from making lunch
15:41:10 <JustinClift> Sorry, here :)
15:41:18 <lalatenduM_> #chair JustinClift
15:41:18 <centbot> Current chairs: JustinClift bvanassche lalatenduM_
15:41:21 <lalatenduM_> JustinClift, :)
15:42:45 <lalatenduM_> #info SCST pkg RPM into a regular kernel module RPM that works for one specific kernel version. http://sourceforge.net/p/scst/svn/HEAD/tree/trunk/scst.spec.in
15:43:10 <lalatenduM_> bvanassche, regarding "koji build infrastructure allows to build a kernel module against a kernel update ?"
15:43:18 <JustinClift> bvanassche: When we've got an initial CentOS Storage SIG build with SCST ready for testing, I'll write up an article on how to use it for the Mellanox Community, and the Serve at Home forums
15:43:38 <JustinClift> That should get a decent # of people testing it
15:43:39 <lalatenduM_> bvanassche, we have a GSoC idea to fix this http://wiki.centos.org/GSoC/2015/Ideas
15:44:18 <lalatenduM_> I think this is the idea http://wiki.centos.org/GSoC/2015/Ideas#host-triggers-buildsystem
15:44:37 <bvanassche> That would help but I'm not sure that would be sufficient.
15:44:54 <bvanassche> If such a trigger would be available, how to build against the updated kernel headers ?
15:45:06 <lalatenduM_> bvanassche, i think so
15:45:26 <bvanassche> I haven't found any way to make koji download and install a kernel update before the build process starts.
15:45:33 <bvanassche> Maybe this means that I overlooked something ?
15:45:54 <JustinClift> We should be able to ask on centos-devel mailing list for help with that
15:46:20 <lalatenduM_> bvanassche, the thing is kernel update will be availbe from centos core
15:47:14 <lalatenduM_> and sigs  should be able get auto trigger builds when that happens
15:47:53 <lalatenduM_> also JustinClift mentioned centos-devel would help too
15:48:00 <lalatenduM_> In diff context here is another idea that will help SCST http://wiki.centos.org/GSoC/2015/Ideas#package-mgmt-confidence
15:48:50 <lalatenduM_> Also will it help too http://wiki.centos.org/GSoC/2015/Ideas#kpatch
15:49:41 <JustinClift> bvanassche: Do you reckon it might be useful to ask on centos-devel if there are any Koji experts around, willing to help us get SCST up and running in the Centos Koji system?
15:50:02 <lalatenduM_> yup
15:50:42 <bvanassche> That definitely would be helpful ...
15:50:43 <lalatenduM_> I think kbsingh have more info, but he is not around, so a mail will help
15:51:05 <bvanassche> but hadn't I already sent an e-mail a few weeks ago in which I asked for help with building against kernel updates ?
15:51:33 <JustinClift> Oops, I don't remember seeing it
15:51:38 * JustinClift looks in his Inbox
15:51:41 <bvanassche> I will try to find it ...
15:51:48 <JustinClift> Do you remember the title?
15:51:48 <JustinClift> Tx
15:51:59 <lalatenduM_> bvanassche, yeah i have seen that
15:52:22 <bvanassche> Here it is: http://lists.centos.org/pipermail/centos-devel/2015-February/012878.html
15:52:24 <lalatenduM_> subject was "No Storage SIG Meeting 6-March-2015 15:30 UTC (Moving it to next week)"
15:52:42 <JustinClift> "Building kernel modules via the CBS ?" ?
15:53:19 <JustinClift> Ahhh gotcha
15:53:28 <lalatenduM_> bvanassche, yeah u r right
15:53:39 <lalatenduM_> may be the subject line did not help
15:53:54 <JustinClift> bvanassche: Yeah, probably only a small subset of people on centos-devel mailing list would read the Storage SIG email
15:54:32 <JustinClift> When I send an email needing help, I generally try to pick an attention getting subject line
15:54:37 <JustinClift> Even if it's cheesy ;)
15:55:23 <JustinClift> bvanassche: If you send an email with the subject line of "Who's up for a challenge?"
15:55:38 <JustinClift> That'd at least get 90% of centos-devel people to at least click on it ;)
15:55:45 <bvanassche> I really appreciate all the help and the pointers to GSoC ideas but I'm afraid if I have to wait with continuing to work on an SCST RPM until these GSoC items are complete that it could take a long time before an SCST RPM becomes available.
15:55:57 * JustinClift agrees
15:56:05 <bvanassche> How about modifying the current spec file such that it is based on weak-updates ?
15:56:25 <bvanassche> At least Mellanox uses this approach when generating RPMs for RHEL / CentOS.
15:56:25 <lalatenduM_> yup works
15:57:02 <lalatenduM_> bvanassche, you mean manual builds in koji by you right?
15:58:10 <bvanassche> Yes.
15:58:23 <lalatenduM_> bvanassche, lets do that
15:58:40 <bvanassche> Thanks.
15:58:54 <bvanassche> Will try to find some time early in April to work on this.
15:58:58 <lalatenduM_> bvanassche, also we can use yum priority plugin, so that kernel update from centos core does not break stuff
16:00:04 <bvanassche> We have learned that SCST users find the scst-devel mailing list easily and usually report any issues they run into on that mailing list.
16:00:29 <JustinClift> Cool
16:01:07 <lalatenduM_> bvanassche, once we build the rpms and yum repos available you can use scst-devel and centos-devel both
16:01:17 <lalatenduM_> bvanassche, are u familiar with yum priority plugin?
16:01:22 <bvanassche> Not yet ...
16:01:45 <lalatenduM_> np,  I can help you with that
16:02:11 <lalatenduM_> bvanassche, do you want to put an action item on you for the builds?
16:02:23 <bvanassche> Sure, that's fine with me.
16:02:49 <JustinClift> bvanassche: How does this sound? http://fpaste.org/203856/14274721/
16:03:08 <JustinClift> ^ Draft email to centos-devel
16:03:15 <JustinClift> Does it describe the problem ok?
16:03:21 <lalatenduM_> #action bvanassche to modify the current spec file such that it is based on weak-updates for SCST
16:03:29 <bvanassche> @JustinClift: sounds great to me.
16:03:34 <JustinClift> k, sending it now
16:03:43 <bvanassche> Thanks for the help.
16:03:59 <JustinClift> np
16:04:10 <lalatenduM_> #info SCST would try yum priority plugin , so that kernel update from centos core does not break SCST stuff
16:05:26 <lalatenduM_> I dont think we have anything else to discuss
16:06:01 <lalatenduM_> I am planning to make some good progress on Gluster font in next two weeks
16:06:16 <hchiramm__> thanks :)
16:06:29 <lalatenduM_> #chair hchiramm__
16:06:29 <centbot> Current chairs: JustinClift bvanassche hchiramm__ lalatenduM_
16:06:48 <lalatenduM_> hchiramm__, do you have any topics to discuss?
16:07:05 <hchiramm__> lalatenduM_, I wil pushing centos gluster docker image to public repo.
16:07:11 <hchiramm__> if it matters here
16:07:20 <lalatenduM_> hchiramm, cool,
16:07:47 <hchiramm__> the documentation side we have good progress
16:07:47 <lalatenduM_> hchiramm__, is it part of centos docker files github repo?
16:07:49 <hchiramm__> so make be we can make some clone of it in CentOS wiki
16:08:03 <hchiramm__> lalatenduM_ not yet
16:08:06 <hchiramm__> but we can push..
16:08:17 * lalatenduM_ trying to get the github link
16:08:49 <hchiramm__> I will co-ordinate with u on this..
16:09:11 <lalatenduM_> #info CentOS dockerfiles https://github.com/CentOS/CentOS-Dockerfiles
16:09:19 <lalatenduM_> hchiramm__, sure
16:09:34 <hchiramm__> thats it from my side on Gluster
16:10:13 <lalatenduM_> hchiramm__, regarding the doc, once you publish them in Gluster , we can link them from storage sig
16:10:55 <lalatenduM_> if we dont have any more topic , we can end the meeting now
16:11:25 <lalatenduM_> going once..
16:11:38 <lalatenduM_> 2..
16:11:50 <lalatenduM_> 3..
16:11:56 <lalatenduM_> #endnmeeting
16:12:01 <lalatenduM_> #endmeeting