Search found 24 matches

by vamfoom
2018/06/11 22:52:21
Forum: CentOS 7 - General Support
Topic: KVM Installation Issue - CentOS7 - Dracut error
Replies: 17
Views: 489

Re: KVM Installation Issue - CentOS7 - Dracut error

I had almost the same error although I don't know if they actually are the same.

See my post : viewtopic.php?f=47&t=66587&p=279895#p279895
by vamfoom
2018/06/06 01:25:06
Forum: CentOS 7 - General Support
Topic: Network Manager
Replies: 3
Views: 164

Re: Network Manager

I just don't know enough about Network Manager, I guess.

After making changes to configs managed by Network Manager, what's the command to restart network manager and to load the new settings? restarting NetworkManager via systemd doesn't restart the network.
by vamfoom
2018/06/05 01:20:37
Forum: CentOS 7 - General Support
Topic: Network Manager
Replies: 3
Views: 164

Network Manager

I used nmtui to configure two network interfaces and successfully start them up using ifup . However, after some time, both interfaces are reset to unconfigured state which I'm guessing by Network Manager. How do I get this to stick? nmtui seems to have saved the info because running it again has th...
by vamfoom
2018/04/17 23:13:13
Forum: CentOS 7 - General Support
Topic: cloud-init resolv.conf not being setup
Replies: 4
Views: 397

Re: cloud-init resolv.conf not being setup

I figured out why resolv.conf was not being changed via cloud-init. Turns out the resolv_conf cloud-init module isn't enabled by default so you have to enable it. Ideally, every module should be enabled or at least a log entry should be made to indicate unknown module. Took me a couple of hours of t...
by vamfoom
2018/04/17 00:25:00
Forum: CentOS 7 - General Support
Topic: cloud-init resolv.conf not being setup
Replies: 4
Views: 397

Re: cloud-init resolv.conf not being setup

I figured it out after playing with it for a little while.

Turns out cloud-init by default doesn't run the resolv_conf module. I had to enable this module in cloud_config_module.
by vamfoom
2018/04/13 22:27:20
Forum: CentOS 7 - General Support
Topic: cloud-init resolv.conf not being setup
Replies: 4
Views: 397

cloud-init resolv.conf not being setup

I have the following in my user-data file for cloud-init, but this doesn't seem to work: #cloud-config manage_resolv_conf: true resolv_conf: nameservers: ['10.1.1.100] searchdomains: - myawesomedomain.com domain: myawesomedomain.com options: rotate: true timeout: 1 But this is written in resolv.conf...
by vamfoom
2018/04/13 00:02:43
Forum: CentOS 7 - General Support
Topic: Cloud images. Is there a minimal install version like the ISOs ?
Replies: 4
Views: 344

Re: Cloud images. Is there a minimal install version like the ISOs ?

I noticed that the cloud image is installed on a single partition. I would like to split that at least into two partitions, with /var or /var/log on its own partition. Is the easiest way just to attach another storage device there?
by vamfoom
2018/04/12 23:59:53
Forum: CentOS 7 - General Support
Topic: Generic cloud image - how to add storage?
Replies: 5
Views: 1379

Re: Generic cloud image - how to add storage?

The only thing I don't like about the cloud image provided is that it's made of one single partition so if you have run-away logs (in /var/log, for example), it could render the system unusable. I'm looking at the cloud-init disk_setup module but I don't think it can resize existing images (such as ...
by vamfoom
2018/04/02 21:58:51
Forum: CentOS 7 - General Support
Topic: can't kick a centos 7 guest VM
Replies: 5
Views: 391

Re: can't kick a centos 7 guest VM

Found the problem. Apparently, centos 7 needs the Live folder. I should've used the whole ISO instead of picking and choosing to start with. I don't remember centos 6 needing this folder.

At least I'm unblocked..
by vamfoom
2018/04/02 21:35:50
Forum: CentOS 7 - General Support
Topic: can't kick a centos 7 guest VM
Replies: 5
Views: 391

Re: can't kick a centos 7 guest VM

Instead of setting up the NIC with extra-args argument, I used the KS file but I'm still stuck at the same error. This is the new virt-install command: virt-install --name ponos --ram 8192 --vcpus=6 --os-variant=rhel7 --accelerate -v -w bridge:coreblue,mac=00:1d:55:31:40:b7 --disk path=/dev/misc2vg/...