[*SOLVED*]Weird Spacewalk issue

A 5 star hangout for overworked and underpaid system admins.
Post Reply
Uke
Posts: 14
Joined: 2015/03/13 17:55:30

[*SOLVED*]Weird Spacewalk issue

Post by Uke » 2015/10/12 15:19:00

Hi everyone,

I am in the process of creating a new Spacewalk server. My current one is on version 1.8 so I figured I would start fresh at 2.3 (well it was fresh until last week). I have been following the "How To" guides from https://fedorahosted.org/spacewalk/wiki/HowToInstall23.

In RHEL Satellite guide it mentions it is best practice to to leave the "Default Organization" for new user and organization creation only. It is not recommended to download systems or repos into this organization. I am having an issue where
in my "second" organization I am unable to create activation keys. Also many options under the "System" tab are missing when I am logged into this organization. I have some screenshots to give a better look.
Here is a shot of the "systems tab" on my current server. Notice it is not the "Default Organization" and I have many options.
Here is a shot of the "systems tab" on my current server. Notice it is not the "Default Organization" and I have many options.
spacewalkold.PNG (123.79 KiB) Viewed 1706 times
Here is a shot of my new server. Notice I don't have "activation keys" as an option.
Here is a shot of my new server. Notice I don't have "activation keys" as an option.
spacewalknew.PNG (104.56 KiB) Viewed 1706 times
Here are the permissions set on my current server for the user.
Here are the permissions set on my current server for the user.
olduser.PNG (83.77 KiB) Viewed 1706 times
Last edited by Uke on 2015/10/12 15:53:59, edited 1 time in total.

Uke
Posts: 14
Joined: 2015/03/13 17:55:30

Re: Weird Spacewalk issue

Post by Uke » 2015/10/12 15:22:39

Same user on my new server.
Same user on my new server.
newuser.PNG (94.92 KiB) Viewed 1704 times
Same user on my new server.
Same user on my new server.
newuser.PNG (94.92 KiB) Viewed 1704 times
Thank you in advance for any help.

Greg
Attachments
My admin logged into "Default Organization" on my new server. Notice I have the activation keys and system groups options available.
My admin logged into "Default Organization" on my new server. Notice I have the activation keys and system groups options available.
admindefault.PNG (104.63 KiB) Viewed 1704 times

Uke
Posts: 14
Joined: 2015/03/13 17:55:30

Re: [*SOLVED*]Weird Spacewalk issue

Post by Uke » 2015/10/12 15:56:22

After a few days of staring at the Organizations and comparing every text field I noticed that my proposed number of systems to be provisioned test field was empty.

Once that field was populated with a value, all of the options under the "System" tab came back.

Post Reply

Return to “CentOS Social”