CentOS 5 http not working and port 80 also not working

A 5 star hangout for overworked and underpaid system admins.
Post Reply
shivendra
Posts: 1
Joined: 2018/04/25 04:27:42

CentOS 5 http not working and port 80 also not working

Post by shivendra » 2018/04/25 04:49:22

Hello,

Iam getting error in starting httpd in centos5.4
service httpd start
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using smalservicedesk.co.in for ServerName
[FAILED]

my nameserver is ok.
I have checked many post and corrected hosts ,resolve.conf file.

There is prtoblem in port 80.

i have did follwing diagnos -
iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:http
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:https
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited


but iam not getting output of
[root@smalservicedesk ~]# lsof -i tcp:80
[root@smalservicedesk httpd]# lsof -Pi tcp:80 | head -3
[root@smalservicedesk httpd]#



[root@smalservicedesk httpd]# iptables -vnL
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
0 0 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:80
0 0 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:80
2500 242K ACCEPT all -- * * 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED
0 0 ACCEPT icmp -- * * 0.0.0.0/0 0.0.0.0/0
24 1062 ACCEPT all -- lo * 0.0.0.0/0 0.0.0.0/0
1 52 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:22
81 4092 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:80
0 0 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:443
166K 17M REJECT all -- * * 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
0 0 REJECT all -- * * 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited

[root@smalservicedesk httpd]# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 *:sunrpc *:* LISTEN
tcp 0 0 *:ndmp *:* LISTEN
tcp 0 0 localhost:5939 *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 localhost:ipp *:* LISTEN
tcp 0 0 *:40600 *:* LISTEN
tcp 0 0 localhost:smtp *:* LISTEN
tcp 0 0 *:mysql *:* LISTEN
udp 0 0 *:kerberos-iv *:*
udp 0 0 *:sunrpc *:*
udp 0 0 *:880 *:*
udp 0 0 *:60017 *:*
udp 0 0 *:ipp *:*
udp 0 0 *:783 *:*
udp 0 0 *:ndmp *:*
udp 0 0 *:puparp *:*



i guess , port 80 is missing in http, it not working ..

how to resolve it pls guide me..

User avatar
TrevorH
Forum Moderator
Posts: 23452
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 5 http not working and port 80 also not working

Post by TrevorH » 2018/04/25 08:46:37

I have moved your post to the Social forum as the CentOS 5 section is now closed and readonly.

CentOS 5 is End of Life and should not be used. Most especially, no one - not in their right minds anyway - should be running 5.4 which came out in 2009 and has received no fixes since the release of 5.5. Current versions are 6.9 and 7.5 (any day soon).
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using smalservicedesk.co.in for ServerName
Is an informational message only and not an error. You need to look further at your logs and find the real error since it's not the one above.

In addition, you should look at pointing your yum repos at vault.centos.org and yum update to the latest and last CentOS 5 which was 5.11. That's still more than a year old but better than running something that dates from prehistory like 5.4. Start planning your migration to a supported version ASAP.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

cnlxh
Posts: 5
Joined: 2018/04/22 02:12:00

Re: CentOS 5 http not working and port 80 also not working

Post by cnlxh » 2018/04/27 10:49:46

shivendra wrote:Hello,

Iam getting error in starting httpd in centos5.4
service httpd start
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using smalservicedesk.co.in for ServerName
[FAILED]
Eh, Is there some logs to show us when its starting

[Moderator: edited to remove massive over-quote]

Post Reply