xrdp sesman.ini backward incompatibility

Comments, suggestions, compliments, etc
obsolesced
Posts: 1
Joined: 2017/03/16 08:16:56

xrdp sesman.ini backward incompatibility

Postby obsolesced » 2017/03/17 03:16:32

Just wanted to describe an issue I had with the recent xrdp update on CentOS 7, in case anyone else encounters the same.

After the update, xrdp stopped working, and it took me awhile to find the problem was from my sesman.ini not including the executable commands, e.g. Xvnc, in the parameter lists. At first, I thought to report this issue as a bug, but after more digging, I realized, from seeing a sesman.ini.rpmnew file, that my sesman.ini was not the one in the updated package, but rather what I must have modified before the update. The sesman.ini in the updated package, i.e. my sesman.ini.rpmnew, included the executable commands, and should presumably work out of the box.

Anyway, I thought it could save a bit of trouble if this backward incompatibility was mentioned somewhere in the update. Otherwise, I hope this post might be useful to some.

Return to “User Comments”

Who is online

Users browsing this forum: No registered users and 2 guests