Updated Postfix + VDA (maildir++ quota support) for Centos/RHEL 6 packages

Comments, suggestions, compliments, etc
NStorm
Posts: 12
Joined: 2007/12/05 09:02:38

Updated Postfix + VDA (maildir++ quota support) for Centos/RHEL 6 packages

Postby NStorm » 2016/04/13 12:31:08

Hello community!

I was using postfix on CentOS 5 with VDA patches (http://vda.sourceforge.net/) for a long time. Surely there are other ways to add quota support to the postfix, but I prefer it with VDA. When I wanted the same on CentOS 6 I've found it's not available. Because default CentOS/RHEL 6 repos ships older postfix version 2.6.6 and VDA website doesn't offers patches for 2.6 branch already. Of course you can always install from sources, but that might break your system and aren't really a good way. So I've decided to do it right way and build a correct RPM package.
Gladly I was able to find newer postfix package version 2.11.3 on GhettoForge repository (http://ghettoforge.org/index.php/Main_Page). Unfortunately VDA doesn't offers patches for 2.11 branch, newest is 2.10. :) But gladly the patch from latest 2.10.9 applied to 2.11.3 source without any issues. So I've updated the .spec file and built a binary packages for CentOS 6. GhettoForge mod also comes with builtin support for PostgreSQL, MySQL, sqlite and ldap.

I've uploaded them to packagecloud.io so anyone could use them: https://packagecloud.io/nstorm/postfix-vda-el6
Installing these packages are as easy, as running couple of commands to add a custom repo and install a package, thanks to packagecloud.io (https://packagecloud.io/nstorm/postfix-vda-el6/install):

Code: Select all

curl -s https://packagecloud.io/install/repositories/nstorm/postfix-vda-el6/script.rpm.sh | sudo bash

Then you just install postfix and optionally perl scripts:

Code: Select all

yum install postfix postfix-perl-scripts


Source RPM are also available on packagecloud.io.

NStorm
Posts: 12
Joined: 2007/12/05 09:02:38

Re: Updated Postfix + VDA (maildir++ quota support) for Centos/RHEL 6 packages

Postby NStorm » 2017/10/16 10:12:00

I've updated the repo to include latest Postfix 3.2.3 with patches. Packages for this version are named postfix3-*. But they might interfere with previous postfix 2.11.x versions, as it doesn't checks for dependencies. It shouldn't overwrite your files when installed with postfix-2.x.x, instead yum will give you a conflict error. So please manually uninstall previous postfix version before upgrading to postfix-3.x.x.

Code: Select all

yum erase postfix postfix-perl-scripts

Check for uninstalled dependencies and re-install them after next step:

Code: Select all

yum install postfix3 postfix3-perl-scripts

If you are upgrading from 2.x.x, you might want to check these release notes and these nice instructions from GhettoForge on how to upgrade.
Please also be aware that 3.x.x versions of postfix shipped from GhettoForge has separate library packages for database support. For example, to add MySQL support, you must install postfix3-mysql package. Check 'yum search postfix3' to see all packages available.
Optionally install most common libraries:

Code: Select all

yum install postfix3-mysql postfix3-pcre postfix3-ldap