Unable to use yum getting: 14: PYCURL ERROR 7 - "Failed to connect to 2a02:2498:1:3d:5054:ff:fed3:e9

General support questions
RedWagon
Posts: 1
Joined: 2015/02/18 18:07:43

Re: Unable to use yum getting: 14: PYCURL ERROR 7 -

Post by RedWagon » 2015/02/18 18:33:20

ccie2020 wrote:I had the exactly same problem. I was too much focus on disabling ipv6. But it turned out the message itself has nothing to do with ipv6. In my case, it was
missing proxy setting in the /etc/yum.conf. As soon as I added "proxy=http://<ipv4addr>:3128" to yum.conf, everything started working.
This fixed my CentOS7 box as well. I was receiving the following when attempting to update:

Code: Select all

[root@hostname ~]# yum check-update 
Loaded plugins: fastestmirror, langpacks
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os error was
14: curl#7 - "Failed to connect to 2a02:2498:1:3d:5054:ff:fed3:e91a: Network is unreachable"

 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64

datakid
Posts: 3
Joined: 2016/01/07 04:37:52

Re: Unable to use yum getting: 14: PYCURL ERROR 7 -

Post by datakid » 2016/01/07 04:39:25

This worked for me, without turning any IPv6 off.

nikohal
Posts: 5
Joined: 2014/11/06 16:09:36

Re: Unable to use yum getting: 14: PYCURL ERROR 7 -

Post by nikohal » 2016/04/16 19:45:21

avij wrote:prozit: To be clear, disabling IPv6 was not the fix. The fix was to fix your IPv4 routing. Disabling IPv6 only changed the error message.

If you don't want to use IPv6, do not disable loading the IPv6 module, as doing that can cause other problems. There is a better way to get rid of IPv6 if you need to. See the FAQ entry for details.
Can you explain what expressly need to do? Because disabling ipv6 not works for me?

mashkoorqadir
Posts: 70
Joined: 2012/06/27 07:55:01

Re: Unable to use yum getting: 14: PYCURL ERROR 7 -

Post by mashkoorqadir » 2016/04/22 05:00:56

I was having same issue before.
here is how I solve this.

in Base repository commit out the mirror url if it is already than commit the base url and enable mirror url.
Set the http_proxy=proxy.com:8080 in Centos_Base.repo
if above do noesn't work than give direct internet access to the machine.

and have fun.

niklaus.kappeler
Posts: 1
Joined: 2016/05/29 19:57:10

Re: Unable to use yum getting: 14: PYCURL ERROR 7 -

Post by niklaus.kappeler » 2016/05/29 20:04:57

you can force yum to ipv4 over adding

Code: Select all

ip_resolve=4
to

Code: Select all

/etc/yum.conf

Post Reply

Return to “CentOS 6 - General Support”