YUM Update Error - Dependencies?

General support questions
Ryuzzaki
Posts: 5
Joined: 2015/01/28 23:04:48
Location: UK

YUM Update Error - Dependencies?

Post by Ryuzzaki » 2015/01/28 23:18:40

Hello all, first post here, and sadly it's not quite the cheery one I had hoped.

The past week or so has been my first real foray into the world of server administration having purchased my first VPS. I'm just about managing to get to grip with things but please, consider me a beginner. Like a 'REAL' beginner.

Trying to update glibc on account of that nasty little bug that's making headlines. Worryingly, I'm not getting very far with things. When running yum update I'm getting the following output:

Code: Select all

Loaded plugins: downloadonly, fastestmirror, priorities
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.denit.net
 * epel: ftp.nluug.nl
 * extras: ftp.nluug.nl
 * rpmforge: ftp.nluug.nl
 * updates: ftp.nluug.nl
1642 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package dhclient.x86_64 12:4.1.1-43.P1.el6.centos will be updated
---> Package dhclient.x86_64 12:4.1.1-43.P1.el6.centos.1 will be an update
---> Package dhcp-common.x86_64 12:4.1.1-43.P1.el6.centos will be updated
---> Package dhcp-common.x86_64 12:4.1.1-43.P1.el6.centos.1 will be an update
---> Package glibc.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.4 will be updated
--> Processing Dependency: glibc-common = 2.12-1.149.el6_6.4 for package: glibc-2.12-1.149.el6_6.4.i686
---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package jasper-devel.x86_64 0:1.900.1-16.el6_6.2 will be updated
---> Package jasper-devel.x86_64 0:1.900.1-16.el6_6.3 will be an update
---> Package jasper-libs.x86_64 0:1.900.1-16.el6_6.2 will be updated
---> Package jasper-libs.x86_64 0:1.900.1-16.el6_6.3 will be an update
---> Package openssl.x86_64 0:1.0.1e-30.el6_6.4 will be updated
---> Package openssl.x86_64 0:1.0.1e-30.el6_6.5 will be an update
---> Package openssl-devel.x86_64 0:1.0.1e-30.el6_6.4 will be updated
---> Package openssl-devel.x86_64 0:1.0.1e-30.el6_6.5 will be an update
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.149.el6_6.4.i686 (@updates)
           Requires: glibc-common = 2.12-1.149.el6_6.4
           Removing: glibc-common-2.12-1.149.el6_6.4.x86_64 (@updates)
               glibc-common = 2.12-1.149.el6_6.4
           Updated By: glibc-common-2.12-1.149.el6_6.5.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.5
           Available: glibc-common-2.12-1.149.el6.x86_64 (base)
               glibc-common = 2.12-1.149.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Have tried a few different things including the following this article: http://www.bonusbits.com/main/KB:Fix_Ce ... ce_Upgrade


So far though, nothing has worked. Any ideas guys? Had a search around but couldn't dig anything up relevant so forgive me if I've missed a previous thread on this. Here's hoping it's a schoolboy error that we can chalk down to a lack of experience!

All the best,
Ryuzzaki

User avatar
TrevorH
Forum Moderator
Posts: 23456
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: YUM Update Error - Dependencies?

Post by TrevorH » 2015/01/29 00:14:39

Could you post the output from rpm -qa --qf '%{name}.%{version}.%{release}.%{arch}\n' glibc\* | sort
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Ryuzzaki
Posts: 5
Joined: 2015/01/28 23:04:48
Location: UK

Re: YUM Update Error - Dependencies?

Post by Ryuzzaki » 2015/01/29 07:54:01

Sure, here it is:

Code: Select all

glibc.2.12.1.149.el6_6.4.i686
glibc.2.12.1.149.el6_6.4.x86_64
glibc-common.2.12.1.149.el6_6.4.x86_64
glibc-devel.2.12.1.149.el6_6.4.x86_64
glibc-headers.2.12.1.149.el6_6.4.x86_64

User avatar
TrevorH
Forum Moderator
Posts: 23456
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: YUM Update Error - Dependencies?

Post by TrevorH » 2015/01/29 09:14:30

Hmm. That didn't show what I expected to be wrong. Can you post the output from yum list available glibc\*
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Ryuzzaki
Posts: 5
Joined: 2015/01/28 23:04:48
Location: UK

Re: YUM Update Error - Dependencies?

Post by Ryuzzaki » 2015/01/29 10:06:59

Thanks for your reply TrevorH!

Here's the output:

Code: Select all

Available Packages
glibc.x86_64                                             2.12-1.149.el6_6.5                                      updates
glibc-common.x86_64                                      2.12-1.149.el6_6.5                                      updates
glibc-devel.x86_64                                       2.12-1.149.el6_6.5                                      updates
glibc-headers.x86_64                                     2.12-1.149.el6_6.5                                      updates
glibc-static.x86_64                                      2.12-1.149.el6_6.5                                      updates
glibc-utils.x86_64                                       2.12-1.149.el6_6.5                                      updates

User avatar
TrevorH
Forum Moderator
Posts: 23456
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: YUM Update Error - Dependencies?

Post by TrevorH » 2015/01/29 10:53:20

Do you have any exclude= lines in either /etc/yum.conf or /etc/yum.repos.d/*.repo? It looks to me like you have excluded all 32 bit packages so it's not updating glibc.i686 and then the installed one is backlevel...
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Ryuzzaki
Posts: 5
Joined: 2015/01/28 23:04:48
Location: UK

Re: YUM Update Error - Dependencies?

Post by Ryuzzaki » 2015/01/29 11:49:40

Okay, I can see that /etc/yum.conf contains "exclude=*.i386 *.i586 *.i686 nginx* php* mysql*" which I imagine is the source of this issue being that .i686 files are being excluded?

Again, forgive me for being a beginner here but is there a reason that YUM is trying to pull a 32bit version of glibc when it seems that a 64bit version is available and I'm running a 64bit system?

I should probably note that I'm running a minimal centos install from my VPS provider on top of which I've installed CentminMod to get everything installed without too much hassle, which I guess would explain the excludes for nginx, php and mysql, but are the rest of the excludes just as a result of me running a 64bit system or is it not normal that they be there?

User avatar
TrevorH
Forum Moderator
Posts: 23456
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: YUM Update Error - Dependencies?

Post by TrevorH » 2015/01/29 11:57:05

It's because you already have the 32 bit version installed - glibc.2.12.1.149.el6_6.4.i686 is in your rpm -q output. So, someone installed the 32 bit C runtime so that 32 bit apps can run on your 64 bit system then somone (else?) told yum to exclude 32 bit packages. Now you cannot update the installed one and 32 and 64 bit multi-lib packages need to match exact version numbers. Running rpm -qa | grep -i "i[3-6]86" will show you any other 32 bit packages that you currently have installed.

I just had a look at the centminmod web page and I have to say that it looks like a nightmare to me. Something I would go out of my way to avoid.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Ryuzzaki
Posts: 5
Joined: 2015/01/28 23:04:48
Location: UK

Re: YUM Update Error - Dependencies?

Post by Ryuzzaki » 2015/01/29 13:36:37

Well there were only a handful of 32bit packages so I went ahead and removed the excludes temporarily which allowed the updates to succeed. Will see if I can find out if CentminMod applies the excludes or installs the 32bit packages, if not I'll put it down to something being weird with my VPS provider's image.

I'm curious as to why you say that it looks like a nightmare? I chose it to simplify the install process and get me started without spending too long worrying about configuration and I can't say I've had any issues so far though I accept that these "All-In-One" packages are never optimal. That said, do you have any alternate suggestions or would you recommend just going at it alone and installing manually?

Thanks for all your help TrevorH, much appreciated as I'd have been lost without it!

User avatar
TrevorH
Forum Moderator
Posts: 23456
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: YUM Update Error - Dependencies?

Post by TrevorH » 2015/01/29 16:37:39

I called it a nightmare because of
Centmin Mod auto installs Nginx server along with the following software:

Nginx 1.7.9 (https / SPDY SSL + ngx_pagespeed support)
PHP 5.4.37 (php-fpm) with support for PHP 5.3/5.4/5.5/5.6
MariaDB 5.5.41 MySQL performance fork (MariaDB 10.x soon)
PHP opcode cache: Zend OpCache 7.0.4, APC Cache 3.13, Xcache 3.1.0
Memcached Server 1.4.20 + Memcache 3.0.8 PHP Extension
Libmemcached 1.0.18 + Memcached 2.2.0 PHP Extension (Centmin Mod v1.2.3-eva2000.01+)
PHP Extensions: Suhosin, FFPMPEG (optional)
Siege Benchmark Tool
Ioping Random Disk I/O Benchmark Tool (optional)
Multi-threaded compression: pigz, pbzip2, lbzip2, plzip, p7zip (optional)
Python 2.7.8 (optional)
CSF Firewall
So it's overwriting core packages from CentOS base and updates repos - specifically php, mariadb (on CentOS 7), memcache and python!
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply