I can not update centos 6.6. Error: Package: and duplicated

General support questions
Gian.T
Posts: 6
Joined: 2015/09/04 20:21:58

I can not update centos 6.6. Error: Package: and duplicated

Post by Gian.T » 2015/09/04 20:27:47

I'm no expert in vps server support, I'm learning. I am getting the following error when trying to 'yum update'.

Code: Select all

    [root@localhost ~]# yum update
    .
    .
    .
    Error: Package: php-process-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-pdo-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-cli-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-tidy-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-xml-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-mbstring-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-bcmath-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-gd-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: php-mcrypt-5.4.42-1.el6.remi.x86_64 (@remi)
               Requires: php-common(x86-64) = 5.4.42-1.el6.remi
               Removing: php-common-5.4.42-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.42-1.el6.remi
               Updated By: php-common-5.4.44-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.44-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
               Available: php-common-5.4.43-1.el6.remi.x86_64 (remi)
                   php-common(x86-64) = 5.4.43-1.el6.remi
    Error: Package: mysql-5.5.44-1.el6.remi.x86_64 (@remi)
               Requires: real-mysql-libs(x86-64) = 5.5.44-1.el6.remi
               Removing: mysql-libs-5.5.44-1.el6.remi.x86_64 (@remi)
                   real-mysql-libs(x86-64) = 5.5.44-1.el6.remi
               Updated By: mysql-libs-5.5.45-1.el6.remi.x86_64 (remi)
                   real-mysql-libs(x86-64) = 5.5.45-1.el6.remi
     You could try using --skip-broken to work around the problem
    ** Found 76 pre-existing rpmdb problem(s), 'yum check' output follows:
    binutils-2.20.51.0.2-5.43.el6.x86_64 is a duplicate with binutils-2.20.51.0.2-5.42.el6.x86_64
    dejavu-fonts-common-2.33-1.el6.noarch is a duplicate with dejavu-fonts-common-2.30-2.el6.noarch
    dejavu-sans-fonts-2.33-1.el6.noarch is a duplicate with dejavu-sans-fonts-2.30-2.el6.noarch
    e2fsprogs-libs-1.41.12-22.el6.x86_64 is a duplicate with e2fsprogs-libs-1.41.12-21.el6.x86_64
    2:ethtool-3.5-6.el6.x86_64 is a duplicate with 2:ethtool-3.5-5.el6.x86_64
    gdbm-1.8.0-38.el6.x86_64 is a duplicate with gdbm-1.8.0-36.el6.x86_64
    grep-2.20-3.el6.x86_64 is a duplicate with grep-2.6.3-6.el6.x86_64
    hwdata-0.233-14.1.el6.noarch is a duplicate with hwdata-0.233-11.1.el6.noarch
    kernel-firmware-2.6.32-573.3.1.el6.centos.plus.noarch is a duplicate with kernel-firmware-2.6.32-504.23.4.el6.centos.plus.noarch
    krb5-devel-1.10.3-42.el6.x86_64 is a duplicate with krb5-devel-1.10.3-37.el6_6.x86_64
    krb5-libs-1.10.3-42.el6.x86_64 is a duplicate with krb5-libs-1.10.3-37.el6_6.x86_64
    libX11-1.6.0-6.el6.x86_64 has installed conflicts libxcb < ('0', '1.9.1', '3'): libxcb-1.9.1-2.el6.x86_64
    libX11-1.6.0-6.el6.x86_64 is a duplicate with libX11-1.6.0-2.2.el6.x86_64
    libX11-common-1.6.0-6.el6.noarch is a duplicate with libX11-common-1.6.0-2.2.el6.noarch
    libcom_err-1.41.12-22.el6.x86_64 is a duplicate with libcom_err-1.41.12-21.el6.x86_64
    libcom_err-devel-1.41.12-22.el6.x86_64 is a duplicate with libcom_err-devel-1.41.12-21.el6.x86_64
    libcurl-7.19.7-46.el6.x86_64 is a duplicate with libcurl-7.19.7-40.el6_6.4.x86_64
    libgcc-4.4.7-16.el6.x86_64 is a duplicate with libgcc-4.4.7-11.el6.x86_64
    libicu-4.2.1-12.el6.x86_64 is a duplicate with libicu-4.2.1-9.1.el6_2.x86_64
    libsemanage-2.0.43-5.1.el6.x86_64 is a duplicate with libsemanage-2.0.43-4.2.el6.x86_64
    libsemanage-python-2.0.43-5.1.el6.x86_64 is a duplicate with libsemanage-python-2.0.43-4.2.el6.x86_64
    libstdc++-4.4.7-16.el6.x86_64 is a duplicate with libstdc++-4.4.7-11.el6.x86_64
    libudev-147-2.63.el6.x86_64 is a duplicate with libudev-147-2.57.el6.x86_64
    libxcb-1.9.1-3.el6.x86_64 is a duplicate with libxcb-1.9.1-2.el6.x86_64
    libxml2-2.7.6-20.el6.x86_64 is a duplicate with libxml2-2.7.6-17.el6_6.1.x86_64
    mysql-5.5.45-1.el6.remi.x86_64 is a duplicate with mysql-5.5.44-1.el6.remi.x86_64
    mysql-5.5.45-1.el6.remi.x86_64 has missing requires of real-mysql-libs(x86-64) = ('0', '5.5.45', '1.el6.remi')
    ncurses-base-5.7-4.20090207.el6.x86_64 is a duplicate with ncurses-base-5.7-3.20090208.el6.x86_64
    ncurses-libs-5.7-4.20090207.el6.x86_64 is a duplicate with ncurses-libs-5.7-3.20090208.el6.x86_64
    nss-3.19.1-3.el6_6.x86_64 is a duplicate with nss-3.18.0-5.3.el6_6.x86_64
    nss-sysinit-3.19.1-3.el6_6.x86_64 is a duplicate with nss-sysinit-3.18.0-5.3.el6_6.x86_64
    nss-tools-3.19.1-3.el6_6.x86_64 is a duplicate with nss-tools-3.18.0-5.3.el6_6.x86_64
    nss-util-3.19.1-1.el6_6.x86_64 is a duplicate with nss-util-3.18.0-1.el6_6.x86_64
    openldap-2.4.40-5.el6.x86_64 is a duplicate with openldap-2.4.39-8.el6.x86_64
    openssl-1.0.1e-42.el6.x86_64 is a duplicate with openssl-1.0.1e-30.el6.11.x86_64
    pam-1.1.1-20.el6_7.1.x86_64 is a duplicate with pam-1.1.1-20.el6.x86_64
    pcre-7.8-7.el6.x86_64 is a duplicate with pcre-7.8-6.el6.x86_64
    4:perl-5.10.1-141.el6.x86_64 is a duplicate with 4:perl-5.10.1-136.el6_6.1.x86_64
    1:perl-Compress-Raw-Zlib-2.021-141.el6.x86_64 is a duplicate with 1:perl-Compress-Raw-Zlib-2.021-136.el6_6.1.x86_64
    perl-Compress-Zlib-2.021-141.el6.x86_64 is a duplicate with perl-Compress-Zlib-2.021-136.el6_6.1.x86_64
    perl-IO-Compress-Base-2.021-141.el6.x86_64 is a duplicate with perl-IO-Compress-Base-2.021-136.el6_6.1.x86_64
    perl-IO-Compress-Zlib-2.021-141.el6.x86_64 is a duplicate with perl-IO-Compress-Zlib-2.021-136.el6_6.1.x86_64
    1:perl-IO-Zlib-1.09-141.el6.x86_64 is a duplicate with 1:perl-IO-Zlib-1.09-136.el6_6.1.x86_64
    1:perl-Module-Pluggable-3.90-141.el6.x86_64 is a duplicate with 1:perl-Module-Pluggable-3.90-136.el6_6.1.x86_64
    1:perl-Package-Constants-0.02-141.el6.x86_64 is a duplicate with 1:perl-Package-Constants-0.02-136.el6_6.1.x86_64
    1:perl-Pod-Escapes-1.04-141.el6.x86_64 is a duplicate with 1:perl-Pod-Escapes-1.04-136.el6_6.1.x86_64
    1:perl-Pod-Simple-3.13-141.el6.x86_64 is a duplicate with 1:perl-Pod-Simple-3.13-136.el6_6.1.x86_64
    4:perl-libs-5.10.1-141.el6.x86_64 is a duplicate with 4:perl-libs-5.10.1-136.el6_6.1.x86_64
    3:perl-version-0.77-141.el6.x86_64 is a duplicate with 3:perl-version-0.77-136.el6_6.1.x86_64
    php-bcmath-5.4.44-1.el6.remi.x86_64 is a duplicate with php-bcmath-5.4.42-1.el6.remi.x86_64
    php-bcmath-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-cli-5.4.44-1.el6.remi.x86_64 is a duplicate with php-cli-5.4.42-1.el6.remi.x86_64
    php-cli-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-gd-5.4.44-1.el6.remi.x86_64 is a duplicate with php-gd-5.4.42-1.el6.remi.x86_64
    php-gd-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-mbstring-5.4.44-1.el6.remi.x86_64 is a duplicate with php-mbstring-5.4.42-1.el6.remi.x86_64
    php-mbstring-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-mcrypt-5.4.44-1.el6.remi.x86_64 is a duplicate with php-mcrypt-5.4.42-1.el6.remi.x86_64
    php-mcrypt-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-mysql-5.4.44-1.el6.remi.x86_64 is a duplicate with php-mysql-5.4.42-1.el6.remi.x86_64
    php-pdo-5.4.44-1.el6.remi.x86_64 is a duplicate with php-pdo-5.4.42-1.el6.remi.x86_64
    php-pdo-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-phpseclib-crypt-aes-1.0.0-1.el6.remi.noarch is a duplicate with php-phpseclib-crypt-aes-0.3.10-1.el6.remi.noarch
    php-phpseclib-crypt-base-1.0.0-1.el6.remi.noarch is a duplicate with php-phpseclib-crypt-base-0.3.10-1.el6.remi.noarch
    php-phpseclib-crypt-random-1.0.0-1.el6.remi.noarch is a duplicate with php-phpseclib-crypt-random-0.3.10-1.el6.remi.noarch
    php-phpseclib-crypt-rijndael-1.0.0-1.el6.remi.noarch is a duplicate with php-phpseclib-crypt-rijndael-0.3.10-1.el6.remi.noarch
    php-process-5.4.44-1.el6.remi.x86_64 is a duplicate with php-process-5.4.42-1.el6.remi.x86_64
    php-process-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-tidy-5.4.44-1.el6.remi.x86_64 is a duplicate with php-tidy-5.4.42-1.el6.remi.x86_64
    php-tidy-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    php-xml-5.4.44-1.el6.remi.x86_64 is a duplicate with php-xml-5.4.42-1.el6.remi.x86_64
    php-xml-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.4.44', '1.el6.remi')
    sqlite-3.6.20-1.el6_7.2.x86_64 is a duplicate with sqlite-3.6.20-1.el6.x86_64
    sysvinit-tools-2.87-6.dsf.el6.x86_64 is a duplicate with sysvinit-tools-2.87-5.dsf.el6.x86_64
    2:tar-1.23-13.el6.x86_64 is a duplicate with 2:tar-1.23-11.el6.x86_64
    2:vim-minimal-7.4.629-5.el6.x86_64 is a duplicate with 2:vim-minimal-7.2.411-1.8.el6.x86_64
Much appreciate the help, I have been looking for a solution for different websites and have not achieved anything. So I decided to ask.

User avatar
ChubaDuba
Posts: 44
Joined: 2015/08/16 06:06:41
Location: Rostov-on-Don
Contact:

Re: I can not update centos 6.6. Error: Package: and duplica

Post by ChubaDuba » 2015/09/04 21:47:06

For a start, show the result of the command:

Code: Select all

$ yum repolist

Gian.T
Posts: 6
Joined: 2015/09/04 20:21:58

Re: I can not update centos 6.6. Error: Package: and duplica

Post by Gian.T » 2015/09/05 01:11:56

Hi, ChubaDuba. #yum repolsit:

Code: Select all

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: less.cogeco.net
 * centosplus: mirror.gpmidi.net
 * contrib: centos.bhs.mirrors.ovh.net
 * epel: mirror.symnds.com
 * extras: centos.bhs.mirrors.ovh.net
 * remi: remi.check-update.co.uk
 * updates: centos.bhs.mirrors.ovh.net
repo id           repo name                                               status
base              CentOS-6 - Base                                          6,575
centosplus        CentOS-6 - Plus                                             26
contrib           CentOS-6 - Contrib                                           0
epel              Extra Packages for Enterprise Linux 6 - x86_64          11,765
extras            CentOS-6 - Extras                                           35
iRedMail          iRedMail                                                    80
nodesource        Node.js Packages for Enterprise Linux 6 - x86_64            37
remi              Les RPM de remi pour Enterprise Linux 6 - x86_64         2,728
updates           CentOS-6 - Updates                                         297
repolist: 21,543

User avatar
TrevorH
Forum Moderator
Posts: 26324
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I can not update centos 6.6. Error: Package: and duplica

Post by TrevorH » 2015/09/05 01:56:00

Try yum --disablerepo=\* --enablerepo=base,updates update

Your errors are with packages from the remi repo.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Gian.T
Posts: 6
Joined: 2015/09/04 20:21:58

Re: I can not update centos 6.6. Error: Package: and duplica

Post by Gian.T » 2015/09/05 02:03:19

Thank you very much, it worked for me. One question always should I use this code to update?

User avatar
TrevorH
Forum Moderator
Posts: 26324
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I can not update centos 6.6. Error: Package: and duplica

Post by TrevorH » 2015/09/05 02:10:42

No, once you've updated you should work out the conflicts and fix them. Those are probably questions for remi.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Gian.T
Posts: 6
Joined: 2015/09/04 20:21:58

Re: I can not update centos 6.6. Error: Package: and duplica

Post by Gian.T » 2015/09/05 02:14:55

and how he solved the problem of duplicate packages?

Code: Select all

Error: Package: mysql-5.5.44-1.el6.remi.x86_64 (@remi)
           Requires: real-mysql-libs(x86-64) = 5.5.44-1.el6.remi
           Removing: mysql-libs-5.5.44-1.el6.remi.x86_64 (@remi)
               real-mysql-libs(x86-64) = 5.5.44-1.el6.remi
           Updated By: mysql-libs-5.5.45-1.el6.remi.x86_64 (remi)
               real-mysql-libs(x86-64) = 5.5.45-1.el6.remi
 You could try using --skip-broken to work around the problem
** Found 76 pre-existing rpmdb problem(s), 'yum check' output follows:
binutils-2.20.51.0.2-5.43.el6.x86_64 is a duplicate with binutils-2.20.51.0.2-5.                                                                                42.el6.x86_64
dejavu-fonts-common-2.33-1.el6.noarch is a duplicate with dejavu-fonts-common-2.                                                                                30-2.el6.noarch
dejavu-sans-fonts-2.33-1.el6.noarch is a duplicate with dejavu-sans-fonts-2.30-2                                                                                .el6.noarch
e2fsprogs-libs-1.41.12-22.el6.x86_64 is a duplicate with e2fsprogs-libs-1.41.12-                                                                                21.el6.x86_64
2:ethtool-3.5-6.el6.x86_64 is a duplicate with 2:ethtool-3.5-5.el6.x86_64
gdbm-1.8.0-38.el6.x86_64 is a duplicate with gdbm-1.8.0-36.el6.x86_64
grep-2.20-3.el6.x86_64 is a duplicate with grep-2.6.3-6.el6.x86_64
hwdata-0.233-14.1.el6.noarch is a duplicate with hwdata-0.233-11.1.el6.noarch
kernel-firmware-2.6.32-573.3.1.el6.centos.plus.noarch is a duplicate with kernel                                                                                -firmware-2.6.32-504.23.4.el6.centos.plus.noarch
krb5-devel-1.10.3-42.el6.x86_64 is a duplicate with krb5-devel-1.10.3-37.el6_6.x                                                                                86_64
krb5-libs-1.10.3-42.el6.x86_64 is a duplicate with krb5-libs-1.10.3-37.el6_6.x86                                                                                _64
libX11-1.6.0-6.el6.x86_64 has installed conflicts libxcb < ('0', '1.9.1', '3'):                                                                                 libxcb-1.9.1-2.el6.x86_64
libX11-1.6.0-6.el6.x86_64 is a duplicate with libX11-1.6.0-2.2.el6.x86_64
libX11-common-1.6.0-6.el6.noarch is a duplicate with libX11-common-1.6.0-2.2.el6                                                                                .noarch
libcom_err-1.41.12-22.el6.x86_64 is a duplicate with libcom_err-1.41.12-21.el6.x                                                                                86_64
libcom_err-devel-1.41.12-22.el6.x86_64 is a duplicate with libcom_err-devel-1.41                                                                                .12-21.el6.x86_64
libcurl-7.19.7-46.el6.x86_64 is a duplicate with libcurl-7.19.7-40.el6_6.4.x86_6                                                                                4
libgcc-4.4.7-16.el6.x86_64 is a duplicate with libgcc-4.4.7-11.el6.x86_64
libicu-4.2.1-12.el6.x86_64 is a duplicate with libicu-4.2.1-9.1.el6_2.x86_64
libsemanage-2.0.43-5.1.el6.x86_64 is a duplicate with libsemanage-2.0.43-4.2.el6                                                                                .x86_64
libsemanage-python-2.0.43-5.1.el6.x86_64 is a duplicate with libsemanage-python-                                                                                2.0.43-4.2.el6.x86_64
libstdc++-4.4.7-16.el6.x86_64 is a duplicate with libstdc++-4.4.7-11.el6.x86_64
libudev-147-2.63.el6.x86_64 is a duplicate with libudev-147-2.57.el6.x86_64
libxcb-1.9.1-3.el6.x86_64 is a duplicate with libxcb-1.9.1-2.el6.x86_64
libxml2-2.7.6-20.el6.x86_64 is a duplicate with libxml2-2.7.6-17.el6_6.1.x86_64
mysql-5.5.45-1.el6.remi.x86_64 is a duplicate with mysql-5.5.44-1.el6.remi.x86_6                                                                                4
mysql-5.5.45-1.el6.remi.x86_64 has missing requires of real-mysql-libs(x86-64) =                                                                                 ('0', '5.5.45', '1.el6.remi')
ncurses-base-5.7-4.20090207.el6.x86_64 is a duplicate with ncurses-base-5.7-3.20                                                                                090208.el6.x86_64
ncurses-libs-5.7-4.20090207.el6.x86_64 is a duplicate with ncurses-libs-5.7-3.20                                                                                090208.el6.x86_64
nss-3.19.1-3.el6_6.x86_64 is a duplicate with nss-3.18.0-5.3.el6_6.x86_64
nss-sysinit-3.19.1-3.el6_6.x86_64 is a duplicate with nss-sysinit-3.18.0-5.3.el6                                                                                _6.x86_64
nss-tools-3.19.1-3.el6_6.x86_64 is a duplicate with nss-tools-3.18.0-5.3.el6_6.x                                                                                86_64
nss-util-3.19.1-1.el6_6.x86_64 is a duplicate with nss-util-3.18.0-1.el6_6.x86_6                                                                                4
openldap-2.4.40-5.el6.x86_64 is a duplicate with openldap-2.4.39-8.el6.x86_64
openssl-1.0.1e-42.el6.x86_64 is a duplicate with openssl-1.0.1e-30.el6.11.x86_64
pam-1.1.1-20.el6_7.1.x86_64 is a duplicate with pam-1.1.1-20.el6.x86_64
pcre-7.8-7.el6.x86_64 is a duplicate with pcre-7.8-6.el6.x86_64
4:perl-5.10.1-141.el6.x86_64 is a duplicate with 4:perl-5.10.1-136.el6_6.1.x86_6                                                                                4
1:perl-Compress-Raw-Zlib-2.021-141.el6.x86_64 is a duplicate with 1:perl-Compres                                                                                s-Raw-Zlib-2.021-136.el6_6.1.x86_64
perl-Compress-Zlib-2.021-141.el6.x86_64 is a duplicate with perl-Compress-Zlib-2                                                                                .021-136.el6_6.1.x86_64
perl-IO-Compress-Base-2.021-141.el6.x86_64 is a duplicate with perl-IO-Compress-                                                                                Base-2.021-136.el6_6.1.x86_64
perl-IO-Compress-Zlib-2.021-141.el6.x86_64 is a duplicate with perl-IO-Compress-                                                                                Zlib-2.021-136.el6_6.1.x86_64
1:perl-IO-Zlib-1.09-141.el6.x86_64 is a duplicate with 1:perl-IO-Zlib-1.09-136.e                                                                                l6_6.1.x86_64
1:perl-Module-Pluggable-3.90-141.el6.x86_64 is a duplicate with 1:perl-Module-Pl                                                                                uggable-3.90-136.el6_6.1.x86_64
1:perl-Package-Constants-0.02-141.el6.x86_64 is a duplicate with 1:perl-Package-                                                                                Constants-0.02-136.el6_6.1.x86_64
1:perl-Pod-Escapes-1.04-141.el6.x86_64 is a duplicate with 1:perl-Pod-Escapes-1.                                                                                04-136.el6_6.1.x86_64
1:perl-Pod-Simple-3.13-141.el6.x86_64 is a duplicate with 1:perl-Pod-Simple-3.13                                                                                -136.el6_6.1.x86_64
4:perl-libs-5.10.1-141.el6.x86_64 is a duplicate with 4:perl-libs-5.10.1-136.el6                                                                                _6.1.x86_64
3:perl-version-0.77-141.el6.x86_64 is a duplicate with 3:perl-version-0.77-136.e                                                                                l6_6.1.x86_64
php-bcmath-5.4.44-1.el6.remi.x86_64 is a duplicate with php-bcmath-5.4.42-1.el6.                                                                                remi.x86_64
php-bcmath-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) =                                                                                 ('0', '5.4.44', '1.el6.remi')
php-cli-5.4.44-1.el6.remi.x86_64 is a duplicate with php-cli-5.4.42-1.el6.remi.x                                                                                86_64
php-cli-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('                                                                                0', '5.4.44', '1.el6.remi')
php-gd-5.4.44-1.el6.remi.x86_64 is a duplicate with php-gd-5.4.42-1.el6.remi.x86                                                                                _64
php-gd-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('0                                                                                ', '5.4.44', '1.el6.remi')
php-mbstring-5.4.44-1.el6.remi.x86_64 is a duplicate with php-mbstring-5.4.42-1.                                                                                el6.remi.x86_64
php-mbstring-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64)                                                                                 = ('0', '5.4.44', '1.el6.remi')
php-mcrypt-5.4.44-1.el6.remi.x86_64 is a duplicate with php-mcrypt-5.4.42-1.el6.                                                                                remi.x86_64
php-mcrypt-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) =                                                                                 ('0', '5.4.44', '1.el6.remi')
php-mysql-5.4.44-1.el6.remi.x86_64 is a duplicate with php-mysql-5.4.42-1.el6.re                                                                                mi.x86_64
php-pdo-5.4.44-1.el6.remi.x86_64 is a duplicate with php-pdo-5.4.42-1.el6.remi.x                                                                                86_64
php-pdo-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('                                                                                0', '5.4.44', '1.el6.remi')
php-phpseclib-crypt-aes-1.0.0-1.el6.remi.noarch is a duplicate with php-phpsecli                                                                                b-crypt-aes-0.3.10-1.el6.remi.noarch
php-phpseclib-crypt-base-1.0.0-1.el6.remi.noarch is a duplicate with php-phpsecl                                                                                ib-crypt-base-0.3.10-1.el6.remi.noarch
php-phpseclib-crypt-random-1.0.0-1.el6.remi.noarch is a duplicate with php-phpse                                                                                clib-crypt-random-0.3.10-1.el6.remi.noarch
php-phpseclib-crypt-rijndael-1.0.0-1.el6.remi.noarch is a duplicate with php-php                                                                                seclib-crypt-rijndael-0.3.10-1.el6.remi.noarch
php-process-5.4.44-1.el6.remi.x86_64 is a duplicate with php-process-5.4.42-1.el                                                                                6.remi.x86_64
php-process-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64)                                                                                 = ('0', '5.4.44', '1.el6.remi')
php-tidy-5.4.44-1.el6.remi.x86_64 is a duplicate with php-tidy-5.4.42-1.el6.remi                                                                                .x86_64
php-tidy-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = (                                                                                '0', '5.4.44', '1.el6.remi')
php-xml-5.4.44-1.el6.remi.x86_64 is a duplicate with php-xml-5.4.42-1.el6.remi.x                                                                                86_64
php-xml-5.4.44-1.el6.remi.x86_64 has missing requires of php-common(x86-64) = ('                                                                                0', '5.4.44', '1.el6.remi')
sqlite-3.6.20-1.el6_7.2.x86_64 is a duplicate with sqlite-3.6.20-1.el6.x86_64
sysvinit-tools-2.87-6.dsf.el6.x86_64 is a duplicate with sysvinit-tools-2.87-5.d                                                                                sf.el6.x86_64
2:tar-1.23-13.el6.x86_64 is a duplicate with 2:tar-1.23-11.el6.x86_64
2:vim-minimal-7.4.629-5.el6.x86_64 is a duplicate with 2:vim-minimal-7.2.411-1.8                                                                                .el6.x86_64

User avatar
TrevorH
Forum Moderator
Posts: 26324
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I can not update centos 6.6. Error: Package: and duplica

Post by TrevorH » 2015/09/05 02:30:56

Did you have a previous yum run go wrong in mid-flight?
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Gian.T
Posts: 6
Joined: 2015/09/04 20:21:58

Re: I can not update centos 6.6. Error: Package: and duplica

Post by Gian.T » 2015/09/05 02:37:23

TrevorH wrote:Did you have a previous yum run go wrong in mid-flight?
yum update

User avatar
TrevorH
Forum Moderator
Posts: 26324
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I can not update centos 6.6. Error: Package: and duplica

Post by TrevorH » 2015/09/05 02:51:58

Yes, that's ended up leaving your rpm database inconsistent and it's quite tricky to fix. I would a) make a backup and b) use rpm -e --nodeps on each of the duplicate packages in turn to remove the newer of the two duplicate packages. Once you have no duplicates and only the older version listed you can run yum update again and it will reinstall the newer packages and make sure that they are up to date. You'll also need to fix the remi errors if they are not the same sort of thing.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply