CentOS 6.9 and yum update

General support questions
KillroyWasHere
Posts: 6
Joined: 2017/05/26 13:24:43

CentOS 6.9 and yum update

Post by KillroyWasHere » 2017/05/26 13:58:21

Hello - new poster, long time user. Thanks in advance for the help!

Issue: I am currently running CentOS 6.9 and have not been able to update software packages on my system since early May. I have looked at the repos and know there are updates sitting out there but yum will not process them.

Code: Select all

yum history
ID     | Login user               | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
    62 |  <redacted>                | 2017-05-11 13:36 | Update         |    2
    61 |  <redacted>                | 2017-04-21 12:26 | Update         |    8
    60 |  <redacted>                | 2017-04-16 13:03 | E, I, U        |   20 EE
    59 |  <redacted>                | 2017-04-05 16:39 | E, I, O, U     |  141 EE

...snip...

Code: Select all

rpm -q centos-release
centos-release-6-9.el6.12.3.x86_64

Code: Select all

cat /etc/*-release
CentOS release 6.9 (Final)
CentOS release 6.9 (Final)
CentOS release 6.9 (Final)
When I issue the yum update command, the output tells me "No Packages marked for Update".

Code: Select all

yum update
Loaded plugins: fastestmirror, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * epel: fedora-epel.mirrors.tds.net
No Packages marked for Update
However, if I enable debug up to level 10, I see 152 packages for "simple update".

Code: Select all

 yum -d10 update
Loading "fastestmirror" plugin
Not loading "protectbase" plugin, as it is disabled
Loading "security" plugin
Running "config" handler for "security" plugin
Config time: 0.021
Running "init" handler for "fastestmirror" plugin
Yum Version: 3.2.29
COMMAND: yum update
Installroot: /
Reading Local RPMDB
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
Setting up Package Sacks
Running "postreposetup" handler for "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * epel: fedora-epel.mirrors.tds.net
Running "exclude" handler for "security" plugin
pkgsack time: 0.191
up:Obs Init time: 0.177
putting freetype in simple update
putting libkadm5 in simple update
putting libnet-devel in simple update
putting glibc-devel in simple update
putting popt in simple update
putting libnih in simple update
putting libnfnetlink in simple update
putting libcap-ng in simple update
putting cracklib in simple update
...snip...
up:simple updates time: 0.008
up:obs time: 0.004
up:condense time: 0.000
updates time: 0.707
No Packages marked for Update

yum update |grep "simple update" |wc -l
152
I have issued yum clean all commands and verified that I am pointed at the proper repos (example updates):

Code: Select all

Repo-id      : updates
Repo-name    : CentOS-6 - Updates
Repo-revision: 1495717899
Repo-updated : Thu May 25 13:12:57 2017
Repo-pkgs    : 318
Repo-size    : 1.5 G
Repo-baseurl : http://mirror.centos.org/centos/6/updates/x86_64/
Repo-expire  : 21,600 second(s) (last: Fri May 26 13:07:06 2017)
I'll be monitoring the thread and will respond to any requests for additional information. Again, thanks in advance!

User avatar
TrevorH
Forum Moderator
Posts: 22806
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6.9 and yum update

Post by TrevorH » 2017/05/26 14:45:38

You appear to have disabled all repos except EPEL. Edit /etc/yum.repos.d/CentOS-Base.repo and change enabled=0 to 1 for [base], [updates] and [extras] (the default enabled ones) and retry.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

KillroyWasHere
Posts: 6
Joined: 2017/05/26 13:24:43

Re: CentOS 6.9 and yum update

Post by KillroyWasHere » 2017/05/26 15:00:10

You are absolutely correct. The /etc/yum.repos.d/CentOS-Base.repo did not contain enable statements for any repos...I had to manually add them.

I do not recall removing those statements...crap.

KillroyWasHere
Posts: 6
Joined: 2017/05/26 13:24:43

Re: CentOS 6.9 and yum update

Post by KillroyWasHere » 2017/05/26 15:17:56

After I added enabled=1 to all the config stanzas in /etc/yum.repos.d/CentOS-Base.repo, I ran yum update and was presented with a new kernel update but no software packages.

Code: Select all

ID     | Login user               | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
    64 |  <redacted>                | 2017-05-26 14:59 | E, I, U        |    6 EE
    63 |  <redacted>                | 2017-05-26 13:17 | Install        |    1
Running yum -d10 update still shows me 152 packages being put into "simple update" but produces the same exit criteria of "No Packages marked for Update"

Updated & current /etc/yum.repos.d/CentOS-Base.repo:

Code: Select all

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

#released updates
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

#contrib - packages by Centos Users
[contrib]
name=CentOS-$releasever - Contrib
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/contrib/$basearch/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

Code: Select all

yum -d2 repolist enabled
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: mirror.genesisadaptive.com
 * centosplus: mirror.netdepot.com
 * contrib: mirror.cs.pitt.edu
 * epel: fedora-epel.mirrors.tds.net
 * extras: mirror.trouble-free.net
 * updates: mirror.trouble-free.net
repo id                                                                   repo name                                                                                         status
base                                                                      CentOS-6 - Base                                                                                    6,706
centosplus                                                                CentOS-6 - Plus                                                                                       18
contrib                                                                   CentOS-6 - Contrib                                                                                     0
cr                                                                        CentOS-6 - CR                                                                                          0
czanik-syslog-ng37epel6                                                   Copr repo for syslog-ng37epel6 owned by czanik                                                        35
epel                                                                      Extra Packages for Enterprise Linux 6 - x86_64                                                    12,305
extras                                                                    CentOS-6 - Extras                                                                                     45
updates                                                                   CentOS-6 - Updates                                                                                   318

User avatar
TrevorH
Forum Moderator
Posts: 22806
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6.9 and yum update

Post by TrevorH » 2017/05/27 14:34:24

Only base/updates and extras are enabled out of the box. Centosplus contains packages that are not in RHEL that overwrite ones from base/updates and should only be used if you actually know that you want those overrides. Contrib has never had anything in it and probably never will.

Looking at my /var/log/yum.log on a CentOS 6 system, the latest packages that received updates were

Code: Select all

May 16 00:55:36 Updated: nss-util-3.28.4-1.el6_9.x86_64
May 16 00:55:36 Updated: nss-3.28.4-1.el6_9.x86_64
May 16 00:55:36 Updated: nss-sysinit-3.28.4-1.el6_9.x86_64
May 16 00:55:36 Updated: 32:bind-libs-9.8.2-0.62.rc1.el6_9.2.x86_64
May 16 00:55:36 Updated: 32:bind-utils-9.8.2-0.62.rc1.el6_9.2.x86_64
May 16 00:55:36 Updated: nss-tools-3.28.4-1.el6_9.x86_64
Use rpm -q nss to check what version of the nss package you have installed. Maybe you're not getting updates listed because there are none.

Also check for other common misconfigurations with e.g. grep -ir exclud /etc/yum.* and that you haven't set up yum-plugin-priorities wrongly using sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n

Also, what is the output from rpm -q --qf '%{version}\n' centos-release
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

KillroyWasHere
Posts: 6
Joined: 2017/05/26 13:24:43

Re: CentOS 6.9 and yum update

Post by KillroyWasHere » 2017/05/27 21:55:22

Contents of yum.log show similar versioning of recent updates:

Code: Select all

Apr 21 12:26:17 Updated: nss-util-3.28.4-1.el6_9.x86_64
Apr 21 12:26:17 Updated: nss-sysinit-3.28.4-1.el6_9.x86_64
Apr 21 12:26:17 Updated: nss-3.28.4-1.el6_9.x86_64
Apr 21 12:26:17 Updated: nss-util-devel-3.28.4-1.el6_9.x86_64
Apr 21 12:26:17 Updated: 32:bind-libs-9.8.2-0.62.rc1.el6_9.1.x86_64
Apr 21 12:26:18 Updated: 32:bind-utils-9.8.2-0.62.rc1.el6_9.1.x86_64
Apr 21 12:26:18 Updated: nss-devel-3.28.4-1.el6_9.x86_64
Apr 21 12:26:18 Updated: nss-tools-3.28.4-1.el6_9.x86_64
May 11 13:36:24 Updated: 32:bind-libs-9.8.2-0.62.rc1.el6_9.2.x86_64
May 11 13:36:24 Updated: 32:bind-utils-9.8.2-0.62.rc1.el6_9.2.x86_64
May 26 14:59:09 Updated: kernel-firmware-2.6.32-696.1.1.el6.centos.plus.noarch
May 26 14:59:20 Installed: kernel-2.6.32-696.1.1.el6.centos.plus.x86_64
May 26 14:59:38 Installed: kernel-devel-2.6.32-696.1.1.el6.centos.plus.x86_64
May 26 14:59:39 Updated: kernel-headers-2.6.32-696.1.1.el6.centos.plus.x86_64
May 27 13:46:46 Installed: centos-release-6-9.el6.12.3.x86_64 (note this was a reinstall)

Code: Select all

 grep -ir exclud /etc/yum.*
/etc/yum.repos.d/CentOS-CR.repo:# should expect to see included / excluded

Code: Select all

sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n
priority = 1 [base]
priority = 1 [centosplus]
priority = 1 [extras]
priority = 1 [updates]
priority = 2 [contrib]
priority = 3 [czanik-syslog-ng37epel6]
priority = 3 [epel]
priority = 3 [epel-debuginfo]
priority = 3 [epel-source]
I also ran getinfo.sh to provide a larger snapshot into the system:

Code: Select all

== BEGIN uname -rmi ==
2.6.32-642.4.2.el6.x86_64 x86_64 x86_64
== END   uname -rmi ==

== BEGIN rpm -qa \*-release\* ==
centos-release-cr-6-0.el6.centos.x86_64
epel-release-6-8.noarch
centos-release-6-9.el6.12.3.x86_64
== END   rpm -qa \*-release\* ==

== BEGIN cat /etc/redhat-release ==
CentOS release 6.9 (Final)
== END   cat /etc/redhat-release ==

== BEGIN getenforce ==
Disabled
== END   getenforce ==

== BEGIN free -m ==
             total       used       free     shared    buffers     cached
Mem:          1877       1742        134          0         26        673
-/+ buffers/cache:       1042        834
Swap:            0          0          0
== END   free -m ==

== BEGIN rpm -qa yum\* rpm-\* python | sort ==
python-2.6.6-66.el6_8.x86_64
rpm-libs-4.8.0-55.el6.x86_64
rpm-python-4.8.0-55.el6.x86_64
yum-3.2.29-81.el6.centos.noarch
yum-metadata-parser-1.1.2-16.el6.x86_64
yum-plugin-fastestmirror-1.1.30-40.el6.noarch
yum-plugin-priorities-1.1.30-40.el6.noarch
yum-plugin-protectbase-1.1.30-40.el6.noarch
yum-plugin-security-1.1.30-40.el6.noarch
yum-utils-1.1.30-40.el6.noarch
== END   rpm -qa yum\* rpm-\* python | sort ==

== BEGIN ls /etc/yum.repos.d ==
CentOS-Base.repo
CentOS-CR.repo
CentOS-Debuginfo.repo
CentOS-fasttrack.repo
CentOS-Media.repo
CentOS-Vault.repo
czanik-syslog-ng37epel6-epel-6.repo
epel.repo
epel-testing.repo
== END   ls /etc/yum.repos.d ==

== BEGIN cat /etc/yum.conf ==
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=2
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=19&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release

#  This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
#  It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
== END   cat /etc/yum.conf ==

== BEGIN yum repolist all ==
Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: mirror.datto.com
 * centosplus: mirror.cogentco.com
 * contrib: centos.mirrors.tds.net
 * epel: fedora-epel.mirrors.tds.net
 * extras: mirror.netdepot.com
 * updates: mirror.net.cen.ct.gov
111 packages excluded due to repository priority protections
repo id                 repo name                            status
C6.0-base               CentOS-6.0 - Base                    disabled
C6.0-centosplus         CentOS-6.0 - CentOSPlus              disabled
C6.0-contrib            CentOS-6.0 - Contrib                 disabled
C6.0-extras             CentOS-6.0 - Extras                  disabled
C6.0-updates            CentOS-6.0 - Updates                 disabled
C6.1-base               CentOS-6.1 - Base                    disabled
C6.1-centosplus         CentOS-6.1 - CentOSPlus              disabled
C6.1-contrib            CentOS-6.1 - Contrib                 disabled
C6.1-extras             CentOS-6.1 - Extras                  disabled
C6.1-updates            CentOS-6.1 - Updates                 disabled
C6.2-base               CentOS-6.2 - Base                    disabled
C6.2-centosplus         CentOS-6.2 - CentOSPlus              disabled
C6.2-contrib            CentOS-6.2 - Contrib                 disabled
C6.2-extras             CentOS-6.2 - Extras                  disabled
C6.2-updates            CentOS-6.2 - Updates                 disabled
C6.3-base               CentOS-6.3 - Base                    disabled
C6.3-centosplus         CentOS-6.3 - CentOSPlus              disabled
C6.3-contrib            CentOS-6.3 - Contrib                 disabled
C6.3-extras             CentOS-6.3 - Extras                  disabled
C6.3-updates            CentOS-6.3 - Updates                 disabled
C6.4-base               CentOS-6.4 - Base                    disabled
C6.4-centosplus         CentOS-6.4 - CentOSPlus              disabled
C6.4-contrib            CentOS-6.4 - Contrib                 disabled
C6.4-extras             CentOS-6.4 - Extras                  disabled
C6.4-updates            CentOS-6.4 - Updates                 disabled
C6.5-base               CentOS-6.5 - Base                    disabled
C6.5-centosplus         CentOS-6.5 - CentOSPlus              disabled
C6.5-contrib            CentOS-6.5 - Contrib                 disabled
C6.5-extras             CentOS-6.5 - Extras                  disabled
C6.5-updates            CentOS-6.5 - Updates                 disabled
C6.6-base               CentOS-6.6 - Base                    disabled
C6.6-centosplus         CentOS-6.6 - CentOSPlus              disabled
C6.6-contrib            CentOS-6.6 - Contrib                 disabled
C6.6-extras             CentOS-6.6 - Extras                  disabled
C6.6-updates            CentOS-6.6 - Updates                 disabled
C6.7-base               CentOS-6.7 - Base                    disabled
C6.7-centosplus         CentOS-6.7 - CentOSPlus              disabled
C6.7-contrib            CentOS-6.7 - Contrib                 disabled
C6.7-extras             CentOS-6.7 - Extras                  disabled
C6.7-updates            CentOS-6.7 - Updates                 disabled
C6.8-base               CentOS-6.8 - Base                    disabled
C6.8-centosplus         CentOS-6.8 - CentOSPlus              disabled
C6.8-contrib            CentOS-6.8 - Contrib                 disabled
C6.8-extras             CentOS-6.8 - Extras                  disabled
C6.8-updates            CentOS-6.8 - Updates                 disabled
base                    CentOS-6 - Base                      enabled:      6,706
base-debuginfo          CentOS-6 - Debuginfo                 disabled
c6-media                CentOS-6 - Media                     disabled
centosplus              CentOS-6 - Plus                      enabled:         18
contrib                 CentOS-6 - Contrib                   enabled:          0
cr                      CentOS-6 - CR                        enabled:          0
czanik-syslog-ng37epel6 Copr repo for syslog-ng37epel6 owned enabled:       28+7
epel                    Extra Packages for Enterprise Linux  enabled: 12,194+111
epel-debuginfo          Extra Packages for Enterprise Linux  disabled
epel-source             Extra Packages for Enterprise Linux  disabled
epel-testing            Extra Packages for Enterprise Linux  disabled
epel-testing-debuginfo  Extra Packages for Enterprise Linux  disabled
epel-testing-source     Extra Packages for Enterprise Linux  disabled
extras                  CentOS-6 - Extras                    enabled:         45
fasttrack               CentOS-6 - fasttrack                 disabled
updates                 CentOS-6 - Updates                   enabled:        318
repolist: 19,309
== END   yum repolist all ==

== BEGIN egrep 'include|exclude' /etc/yum.repos.d/*.repo ==
/etc/yum.repos.d/CentOS-CR.repo:# should expect to see included / excluded
== END   egrep 'include|exclude' /etc/yum.repos.d/*.repo ==

== BEGIN sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n ==
priority = 1 [base]
priority = 1 [centosplus]
priority = 1 [extras]
priority = 1 [updates]
priority = 2 [contrib]
priority = 3 [czanik-syslog-ng37epel6]
priority = 3 [epel]
priority = 3 [epel-debuginfo]
priority = 3 [epel-source]
== END   sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n ==

== BEGIN cat /etc/fstab ==

#
# /etc/fstab
# Created by anaconda on Wed Aug 31 00:20:50 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=392e979e-8196-4b95-87f9-8e2d6355c42d /                       ext4    defaults        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
== END   cat /etc/fstab ==

== BEGIN df -h ==
Filesystem      Size  Used Avail Use% Mounted on
/dev/vda1        40G  6.0G   32G  17% /
tmpfs           939M     0  939M   0% /dev/shm
== END   df -h ==

== BEGIN fdisk -lu ==

WARNING: GPT (GUID Partition Table) detected on '/dev/vda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/vda: 42.9 GB, 42949672960 bytes
255 heads, 63 sectors/track, 5221 cylinders, total 83886080 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/vda1               1    83886079    41943039+  ee  GPT
== END   fdisk -lu ==

== BEGIN parted -l ==
Model: Virtio Block Device (virtblk)
Disk /dev/vda: 42.9GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name       Flags
15      1049kB  2097kB  1049kB               bios_grub
 1      2097kB  42.9GB  42.9GB  ext4         primary


== END   parted -l ==

== BEGIN blkid ==
/dev/vda1: LABEL="DOROOT" UUID="392e979e-8196-4b95-87f9-8e2d6355c42d" TYPE="ext4" 
== END   blkid ==

== BEGIN cat /proc/mdstat ==
Personalities : 
unused devices: <none>
== END   cat /proc/mdstat ==

== Warning: pvs is not installed ==

== Warning: vgs is not installed ==

== Warning: lvs is not installed ==

== BEGIN rpm -qa kernel\* | sort ==
kernel-2.6.32-642.4.2.el6.x86_64
kernel-2.6.32-696.1.1.el6.centos.plus.x86_64
kernel-devel-2.6.32-642.4.2.el6.x86_64
kernel-devel-2.6.32-696.1.1.el6.centos.plus.x86_64
kernel-firmware-2.6.32-696.1.1.el6.centos.plus.noarch
kernel-headers-2.6.32-696.1.1.el6.centos.plus.x86_64
== END   rpm -qa kernel\* | sort ==

== BEGIN lspci -nn ==
00:00.0 Host bridge [0600]: Intel Corporation 440FX - 82441FX PMC [Natoma] [8086:1237] (rev 02)
00:01.0 ISA bridge [0601]: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] [8086:7000]
00:01.1 IDE interface [0101]: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II] [8086:7010]
00:01.2 USB controller [0c03]: Intel Corporation 82371SB PIIX3 USB [Natoma/Triton II] [8086:7020] (rev 01)
00:01.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 03)
00:02.0 VGA compatible controller [0300]: Red Hat, Inc. QXL paravirtual graphic card [1b36:0100] (rev 04)
00:03.0 Ethernet controller [0200]: Red Hat, Inc Virtio network device [1af4:1000]
00:04.0 SCSI storage controller [0100]: Red Hat, Inc Virtio SCSI [1af4:1004]
00:05.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
00:06.0 Unclassified device [00ff]: Red Hat, Inc Virtio memory balloon [1af4:1002]
== END   lspci -nn ==

== Warning: lsusb is not installed ==

== BEGIN rpm -qa kmod\* kmdl\* ==
== END   rpm -qa kmod\* kmdl\* ==

== BEGIN ifconfig -a ==
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:xxx.xxx.xxx.xxx  Bcast:xxx.xxx.xxx.255  Mask:255.255.240.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26942 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24742 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4930196 (4.7 MiB)  TX bytes:29701393 (28.3 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12346 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12346 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:17819618 (16.9 MiB)  TX bytes:17819618 (16.9 MiB)

== END   ifconfig -a ==

== BEGIN brctl show ==
bridge name	bridge id		STP enabled	interfaces
== END   brctl show ==

== BEGIN route -n ==
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
xxx.xxx.xxx.x   0.0.0.0         255.255.240.0   U     0      0        0 eth0
10.17.0.0       0.0.0.0         255.255.0.0     U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
0.0.0.0         xxx.xxx.xxx.x   0.0.0.0         UG    0      0        0 eth0
== END   route -n ==

== BEGIN sysctl -a | grep .rp_filter ==
net.ipv4.conf.all.rp_filter = 1
net.ipv4.conf.all.arp_filter = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.arp_filter = 0
net.ipv4.conf.lo.rp_filter = 1
net.ipv4.conf.lo.arp_filter = 0
net.ipv4.conf.eth0.rp_filter = 1
net.ipv4.conf.eth0.arp_filter = 0
== END   sysctl -a | grep .rp_filter ==

== BEGIN ip rule show ==
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
== END   ip rule show ==

== BEGIN ip route show ==
xxx.xxx.xxx.0/20 dev eth0  proto kernel  scope link  src xxx.xxx.xxx.xxx 
10.17.0.0/16 dev eth0  proto kernel  scope link  src 10.17.0.5 
169.254.0.0/16 dev eth0  scope link  metric 1002 
default via xxx.xxx.xxx.1 dev eth0 
== END   ip route show ==

== BEGIN cat /etc/resolv.conf ==
nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx
== END   cat /etc/resolv.conf ==

== BEGIN egrep 'net|hosts' /etc/nsswitch.conf ==
#hosts:     db files nisplus nis dns
hosts:      files dns
#networks:   nisplus [NOTFOUND=return] files
#netmasks:   nisplus [NOTFOUND=return] files     
netmasks:   files
networks:   files
netgroup:   nisplus
== END   egrep 'net|hosts' /etc/nsswitch.conf ==

== BEGIN chkconfig --list | grep -Ei 'network|wpa' ==
network        	0:off	1:off	2:on	3:on	4:on	5:on	6:off
== END   chkconfig --list | grep -Ei 'network|wpa' ==


User avatar
TrevorH
Forum Moderator
Posts: 22806
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6.9 and yum update

Post by TrevorH » 2017/05/27 23:10:47

Your system looks fully up to date to me.

One thing to bear in mind is that CentOS 6 entered Production Phase 3 on May 10th 2017 and from now on, only critical security bugs will get patches (or things that really big Redhat customer's who pay lots of money want patched!). The frequency of updates will thus be somewhat less from now on until it goes EOL in 2020.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

KillroyWasHere
Posts: 6
Joined: 2017/05/26 13:24:43

Re: CentOS 6.9 and yum update

Post by KillroyWasHere » 2017/05/27 23:47:07

Well, that is good news.

One follow-up - when entering yum update with -d10, i see roughly 152 packages put into "simple update". I looked at yum source code here https://github.com/rpm-software-managem ... updates.py and found the debug output. I assumed this meant a package is to be updated (hence my journey on this thread). I'm guessing this is an incorrect assumption - does simple update simply mean a package match was found but no new version is available?

Thanks for your patience and guidance in all this!

Code: Select all

yum -d10 update
Loading "fastestmirror" plugin
Loading "priorities" plugin
Not loading "protectbase" plugin, as it is disabled
Loading "security" plugin
Running "config" handler for "priorities" plugin
Running "config" handler for "security" plugin
Config time: 0.013
Running "init" handler for "fastestmirror" plugin
Yum Version: 3.2.29
COMMAND: yum -d10 update
Installroot: /
Reading Local RPMDB
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
Setting up Package Sacks
Running "postreposetup" handler for "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * centosplus: mirror.cogentco.com
 * contrib: centos.mirrors.tds.net
 * epel: fedora-epel.mirrors.tds.net
 * extras: mirror.netdepot.com
 * updates: mirror.net.cen.ct.gov
Running "exclude" handler for "priorities" plugin
Running "exclude" handler for "priorities" plugin
 --> PyPAM-0.5.0-11.el6.x86_64 from epel excluded (priority)
 --> a2ps-4.14-10.1.el6.i686 from epel excluded (priority)
 --> a2ps-4.14-10.1.el6.x86_64 from epel excluded (priority)
 --> bakefile-0.2.8-3.el6.x86_64 from epel excluded (priority)
 --> cloud-init-0.7.4-2.el6.noarch from epel excluded (priority)
 --> emacs-a2ps-4.14-10.1.el6.x86_64 from epel excluded (priority)
 --> emacs-a2ps-el-4.14-10.1.el6.x86_64 from epel excluded (priority)
 --> epel-release-6-8.noarch from epel excluded (priority)
 --> febootstrap-2.7-1.el6.x86_64 from epel excluded (priority)
 --> freerdp-1.0.2-1.el6.x86_64 from epel excluded (priority)
 --> freerdp-devel-1.0.2-1.el6.i686 from epel excluded (priority)
 --> freerdp-devel-1.0.2-1.el6.x86_64 from epel excluded (priority)
 --> freerdp-libs-1.0.2-1.el6.i686 from epel excluded (priority)
 --> freerdp-libs-1.0.2-1.el6.x86_64 from epel excluded (priority)
 --> freerdp-plugins-1.0.2-1.el6.x86_64 from epel excluded (priority)
 --> google-crosextra-caladea-fonts-1.002-0.2.20130214.el6.noarch from epel excluded (priority)
 --> google-crosextra-carlito-fonts-1.103-0.1.20130920.el6.noarch from epel excluded (priority)
 --> ht2html-2.0-10.el6.noarch from epel excluded (priority)
 --> html2ps-1.0-0.4.b5.el6.noarch from epel excluded (priority)
 --> libmicrohttpd-0.9.22-1.el6.i686 from epel excluded (priority)
 --> libmicrohttpd-0.9.22-1.el6.x86_64 from epel excluded (priority)
 --> libmicrohttpd-devel-0.9.22-1.el6.i686 from epel excluded (priority)
 --> libmicrohttpd-devel-0.9.22-1.el6.x86_64 from epel excluded (priority)
 --> libmicrohttpd-doc-0.9.22-1.el6.noarch from epel excluded (priority)
 --> libreswan-3.13-1.el6.x86_64 from epel excluded (priority)
 --> lshw-B.02.14-3.el6.x86_64 from epel excluded (priority)
 --> lshw-gui-B.02.14-3.el6.x86_64 from epel excluded (priority)
 --> lzop-1.02-0.9.rc1.el6.x86_64 from epel excluded (priority)
 --> perl-B-Keywords-1.09-3.1.el6.noarch from epel excluded (priority)
 --> perl-Class-Accessor-0.31-0.6.1.el6.noarch from epel excluded (priority)
 --> perl-Class-Data-Inheritable-0.08-0.3.1.el6.noarch from epel excluded (priority)
 --> perl-Class-MethodMaker-2.15-2.el6.x86_64 from epel excluded (priority)
 --> perl-Class-Trigger-0.13-0.2.1.el6.noarch from epel excluded (priority)
 --> perl-Config-Simple-4.59-5.el6.noarch from epel excluded (priority)
 --> perl-Crypt-PasswdMD5-1.3-0.6.el6.noarch from epel excluded (priority)
 --> perl-DateTime-Format-DateParse-0.05-4.el6.noarch from epel excluded (priority)
 --> perl-Devel-Cycle-1.10-3.1.el6.noarch from epel excluded (priority)
 --> perl-Exception-Class-1.29-1.1.el6.noarch from epel excluded (priority)
 --> perl-File-pushd-1.00-0.3.1.el6.noarch from epel excluded (priority)
 --> perl-Font-AFM-1.20-3.1.el6.noarch from epel excluded (priority)
 --> perl-HTML-Format-2.04-11.1.el6.noarch from epel excluded (priority)
 --> perl-IO-Tty-1.08-3.el6.x86_64 from epel excluded (priority)
 --> perl-IPC-Run-0.84-1.el6.noarch from epel excluded (priority)
 --> perl-Locale-Maketext-Gettext-1.27-12.el6.noarch from epel excluded (priority)
 --> perl-Locale-PO-0.21-2.1.el6.noarch from epel excluded (priority)
 --> perl-MIME-Types-1.28-2.el6.noarch from epel excluded (priority)
 --> perl-Module-Find-0.08-3.el6.noarch from epel excluded (priority)
 --> perl-Net-SMTP-SSL-1.01-4.el6.noarch from epel excluded (priority)
 --> perl-PadWalker-1.9-1.el6.x86_64 from epel excluded (priority)
 --> perl-Parse-RecDescent-1.965-1.el6.noarch from epel excluded (priority)
 --> perl-Perl-Critic-1.105-2.el6.noarch from epel excluded (priority)
 --> perl-Pod-Spell-1.01-6.1.el6.noarch from epel excluded (priority)
 --> perl-String-Format-1.15-2.1.el6.noarch from epel excluded (priority)
 --> perl-Syntax-Highlight-Engine-Kate-0.04-5.1.el6.noarch from epel excluded (priority)
 --> perl-Term-ProgressBar-2.09-8.el6.noarch from epel excluded (priority)
 --> perl-Test-Memory-Cycle-1.04-7.1.el6.noarch from epel excluded (priority)
 --> perl-Test-Perl-Critic-1.01-7.1.el6.noarch from epel excluded (priority)
 --> perl-Test-Spelling-0.11-5.1.el6.noarch from epel excluded (priority)
 --> perl-UNIVERSAL-can-1.15-1.el6.noarch from epel excluded (priority)
 --> perl-UNIVERSAL-isa-1.03-1.el6.noarch from epel excluded (priority)
 --> perl-XML-TokeParser-0.05-2.1.el6.noarch from epel excluded (priority)
 --> perl-XML-Writer-0.606-6.el6.noarch from epel excluded (priority)
 --> pexpect-2.3-5.el6.noarch from epel excluded (priority)
 --> pytest-2.3.5-3.el6.noarch from epel excluded (priority)
 --> python-backports-1.0-3.el6.x86_64 from epel excluded (priority)
 --> python-empy-3.3-5.el6.noarch from epel excluded (priority)
 --> python-jsonpatch-1.2-2.el6.noarch from epel excluded (priority)
 --> python-jsonpointer-1.0-3.el6.noarch from epel excluded (priority)
 --> python-krbV-1.0.90-1.el6.x86_64 from epel excluded (priority)
 --> python-oauth-1.0.1-1.el6.noarch from epel excluded (priority)
 --> python-ordereddict-1.1-2.el6.noarch from epel excluded (priority)
 --> python-py-1.4.18-1.el6.noarch from epel excluded (priority)
 --> python-sphinx10-1.0.8-1.el6.noarch from epel excluded (priority)
 --> python-sphinx10-doc-1.0.8-1.el6.noarch from epel excluded (priority)
 --> python-tornado-2.2.1-7.el6.noarch from epel excluded (priority)
 --> python-tornado-doc-2.2.1-7.el6.noarch from epel excluded (priority)
 --> python-urwid-0.9.9.1-1.el6.x86_64 from epel excluded (priority)
 --> scl-utils-20120229-1.el6.x86_64 from epel excluded (priority)
 --> scl-utils-build-20120229-1.el6.x86_64 from epel excluded (priority)
 --> scons-2.0.1-1.el6.noarch from epel excluded (priority)
 --> snappy-1.0.5-1.el6.i686 from epel excluded (priority)
 --> snappy-1.0.5-1.el6.x86_64 from epel excluded (priority)
 --> snappy-devel-1.0.5-1.el6.i686 from epel excluded (priority)
 --> snappy-devel-1.0.5-1.el6.x86_64 from epel excluded (priority)
 --> suitesparse-3.4.0-0.9.el6.1.i686 from epel excluded (priority)
 --> suitesparse-3.4.0-0.9.el6.1.x86_64 from epel excluded (priority)
 --> suitesparse-devel-3.4.0-0.9.el6.1.i686 from epel excluded (priority)
 --> suitesparse-devel-3.4.0-0.9.el6.1.x86_64 from epel excluded (priority)
 --> suitesparse-doc-3.4.0-0.9.el6.1.noarch from epel excluded (priority)
 --> suitesparse-static-3.4.0-0.9.el6.1.i686 from epel excluded (priority)
 --> suitesparse-static-3.4.0-0.9.el6.1.x86_64 from epel excluded (priority)
 --> wordnet-3.0-13.el6.i686 from epel excluded (priority)
 --> wordnet-3.0-13.el6.x86_64 from epel excluded (priority)
 --> wordnet-devel-3.0-13.el6.i686 from epel excluded (priority)
 --> wordnet-devel-3.0-13.el6.x86_64 from epel excluded (priority)
 --> wxBase-2.8.12-1.el6.i686 from epel excluded (priority)
 --> wxBase-2.8.12-1.el6.x86_64 from epel excluded (priority)
 --> wxGTK-2.8.12-1.el6.i686 from epel excluded (priority)
 --> wxGTK-2.8.12-1.el6.x86_64 from epel excluded (priority)
 --> wxGTK-devel-2.8.12-1.el6.i686 from epel excluded (priority)
 --> wxGTK-devel-2.8.12-1.el6.x86_64 from epel excluded (priority)
 --> wxGTK-gl-2.8.12-1.el6.i686 from epel excluded (priority)
 --> wxGTK-gl-2.8.12-1.el6.x86_64 from epel excluded (priority)
 --> wxGTK-media-2.8.12-1.el6.i686 from epel excluded (priority)
 --> wxGTK-media-2.8.12-1.el6.x86_64 from epel excluded (priority)
 --> xerces-c-3.0.1-0.20.1.el6.i686 from epel excluded (priority)
 --> xerces-c-3.0.1-0.20.1.el6.x86_64 from epel excluded (priority)
 --> xerces-c-devel-3.0.1-0.20.1.el6.i686 from epel excluded (priority)
 --> xerces-c-devel-3.0.1-0.20.1.el6.x86_64 from epel excluded (priority)
 --> xerces-c-doc-3.0.1-0.20.1.el6.noarch from epel excluded (priority)
 --> xhtml2ps-1.0-0.4.b5.el6.noarch from epel excluded (priority)
111 packages excluded due to repository priority protections
Running "exclude" handler for "security" plugin
pkgsack time: 2.436
up:Obs Init time: 0.243
putting freetype in simple update
putting libkadm5 in simple update
putting libnet-devel in simple update
putting glibc-devel in simple update
putting popt in simple update
putting libnih in simple update
putting libnfnetlink in simple update
putting libcap-ng in simple update
putting cracklib in simple update
putting libpng in simple update
putting libstdc++ in simple update
putting ipset in simple update
putting nss-util in simple update
putting gd in simple update
putting tcp_wrappers-libs in simple update
putting libudev in simple update
putting mysql-libs in simple update
putting expat in simple update
putting python-libs in simple update
putting bzip2-libs in simple update
putting nspr in simple update
putting zlib-devel in simple update
putting file-devel in simple update
putting snappy in simple update
putting libcgroup in simple update
putting libpciaccess in simple update
putting krb5-devel in simple update
putting audit-libs in simple update
putting libselinux in simple update
putting libsepol in simple update
putting lua-devel in simple update
putting libX11 in simple update
putting libpcap-devel in simple update
putting libblkid in simple update
putting xz-libs in simple update
putting plymouth-core-libs in simple update
putting libcap in simple update
putting python-devel in simple update
putting libcom_err-devel in simple update
putting lua in simple update
putting file-libs in simple update
putting libXpm in simple update
putting libtasn1 in simple update
putting libmnl in simple update
putting rpm-libs in simple update
putting openldap in simple update
putting p11-kit-trust in simple update
putting libpcap in simple update
putting GeoIP in simple update
putting dialog in simple update
putting libyaml-devel in simple update
putting libcap-ng-devel in simple update
putting libgomp in simple update
putting clamav in simple update
putting syslog-ng in simple update
putting libxcb in simple update
putting nss-softokn-freebl-devel in simple update
putting nss-softokn-devel in simple update
putting setools-libs in simple update
putting gpgme in simple update
putting elfutils-libs in simple update
putting cryptsetup-luks-libs in simple update
putting libacl in simple update
putting pcre-devel in simple update
putting cyrus-sasl-lib in simple update
putting eventlog in simple update
putting libnetfilter_queue-devel in simple update
putting pam in simple update
putting nss-util-devel in simple update
putting zlib in simple update
putting nss-softokn in simple update
putting apr-util in simple update
putting libusb in simple update
putting libutempter in simple update
putting ncurses-libs in simple update
putting pciutils-libs in simple update
putting ustr in simple update
putting readline in simple update
putting libattr in simple update
putting apr in simple update
putting libffi-devel in simple update
putting libjpeg-turbo in simple update
putting openssl-devel in simple update
putting gdbm in simple update
putting newt in simple update
putting nss-softokn-freebl in simple update
putting jansson in simple update
putting p11-kit in simple update
putting nss-devel in simple update
putting jansson-devel in simple update
putting augeas-libs in simple update
putting libuser in simple update
putting fipscheck-lib in simple update
putting libuuid in simple update
putting libnfnetlink-devel in simple update
putting gnutls in simple update
putting parted in simple update
putting libgcrypt in simple update
putting gpm-libs in simple update
putting e2fsprogs-libs in simple update
putting libdrm in simple update
putting gmp in simple update
putting libselinux-devel in simple update
putting db4 in simple update
putting fontconfig in simple update
putting libXau in simple update
putting libgpg-error in simple update
putting krb5-libs in simple update
putting libssh2 in simple update
putting nspr-devel in simple update
putting iptables in simple update
putting sqlite in simple update
putting libestr in simple update
putting pcre in simple update
putting libidn in simple update
putting libsemanage in simple update
putting libsepol-devel in simple update
putting pth in simple update
putting cloog-ppl in simple update
putting glibc in simple update
putting libffi in simple update
putting libxslt in simple update
putting ppl in simple update
putting libnet in simple update
putting perl-libs in simple update
putting libdbi in simple update
putting keyutils-libs in simple update
putting gamin in simple update
putting libnetfilter_queue in simple update
putting nss in simple update
putting keyutils-libs-devel in simple update
putting bind-libs in simple update
putting glib2 in simple update
putting openssl in simple update
putting util-linux-ng in simple update
putting libyaml in simple update
putting lzo in simple update
putting json-c in simple update
putting libedit in simple update
putting dbus-glib in simple update
putting libxml2 in simple update
putting dbus-libs in simple update
putting mpfr in simple update
putting procps in simple update
putting device-mapper-libs in simple update
putting libss in simple update
putting slang in simple update
putting elfutils-libelf in simple update
putting libgcc in simple update
putting libcom_err in simple update
putting libcurl in simple update
up:simple updates time: 0.011
up:obs time: 0.006
up:condense time: 0.000
updates time: 2.782
No Packages marked for Update

yum -d10 update |grep excluded |wc -l
112
yum -d10 update |grep simple |wc -l
152
yum list installed |egrep -v "Loaded|Installed" |wc -l
492


User avatar
TrevorH
Forum Moderator
Posts: 22806
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6.9 and yum update

Post by TrevorH » 2017/05/28 12:02:00

I don't know what those simple update messages mean but I checked a system here and picked a package at random from the list of simple updates, in my case openssl. Then I ran yum list openssl --noplugins --showdupli to list all copies of the openssl package that are installed or in any enabled repo but disabling all plugins which stops yum-plugin-priorities from excluding duplicates from prioritised repos etc. What I see for that package is

Code: Select all

Installed Packages
openssl.x86_64                                           1.0.1e-57.el6                                           @QA 
Available Packages
openssl.i686                                             1.0.1e-57.el6                                           base
openssl.x86_64                                           1.0.1e-57.el6                                           base
As you can see, the copy I have installed is the same one that's available in the repos so there is nothing to update for this package. Whatever that message means, it doesn't seem to mean the package needs updating.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

phantom21
Posts: 7
Joined: 2013/11/21 06:26:03

Re: CentOS 6.8 and yum update

Post by phantom21 » 2018/02/09 00:04:55

I have centos 6.8 final. Trying to perform update. The mirrors weren't working so I enabled the baseurl but that is also not working, I get this message below

Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6 ... nfra=stock error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'"
Error: Cannot find a valid baseurl for repo: centosplus

Can anyone suggest a fix. I know 6 is not EOLed yet, won't be until 2020.

Appreciate the assist. Thanks.

Post Reply