Postfix/Roundcube/iRedmail not sending to 1 domain.

General support questions
johnmani707
Posts: 4
Joined: 2017/04/10 17:56:42

Postfix/Roundcube/iRedmail not sending to 1 domain.

Postby johnmani707 » 2017/09/20 19:42:26

Hey folks, newish at centos/postfx and I'm having a problem I can't resolve.

I can send and receive email from our new server from both on and off network but I am not able to send messages to 1 domain. Unfortunately that is the one domain 99% of our emails get delivered to. When sending email to that domain I receive 1 of two messages in the maillog.

Error 1: Sep 20 11:47:28 mail1 postfix/smtp[28647]: connect to mydomain.com[End server IP address]:25: Connection timed out

Error 2: Sep 20 11:29:06 mail1 postfix/error[28247]: 019BB82522: to=<me@mydomain.com>, relay=none, delay=153433, delays=153433/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to mydomain.com[my IP address]:25: Connection timed out)


I attached copies of my master.cf and main.cf I changed from my fqdn to "mydomain.org" Any help or ideas on where to look would be great!

I'm leaning towards the problem being the port 25 part. I'm thinking it should be port 587 but I can not find where I would change that.

Whoever
Posts: 945
Joined: 2013/09/06 03:12:10

Re: Postfix/Roundcube/iRedmail not sending to 1 domain.

Postby Whoever » 2017/09/21 01:56:23

You can configure that in the transport map file.

johnmani707
Posts: 4
Joined: 2017/04/10 17:56:42

Re: Postfix/Roundcube/iRedmail not sending to 1 domain.

Postby johnmani707 » 2017/09/21 19:48:48

Whoever wrote:You can configure that in the transport map file.


Thanks I figured it out late yesterday. It turns out it was a DNS problem, for some reason it was trying to connect to domain web server not MX?