MySql won't start after upgrade from 5.1 to 5.7

General support questions
Post Reply
Posts: 1
Joined: 2018/01/11 22:25:21

MySql won't start after upgrade from 5.1 to 5.7

Post by shella » 2018/01/11 22:36:48

Hello World,
as the subject says I tried to perform an upgrade from a MySql 5.1 to a 5.7 and now the service is not running. I used the remi repo to do it.

- CentOS release 6.7 (Final)
- Mysql Ver 14.14 Distrib 5.7.20, for Linux (x86_64) using EditLine wrapper

Actually if I launch the mysql service I got this:

Code: Select all

[root@www etc]# mysql -u root -p
Enter password:**********
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
System is right: there's no mysql.sock file there and even if I try to "touch" it the output is gonna be:

Code: Select all

[root@www local]# 2018-01-11T22:58:31.381719Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.20-log) starting as process 31906 ...
2018-01-11T22:58:31.387351Z 0 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

2018-01-11T22:58:31.387482Z 0 [ERROR] Aborting

2018-01-11T22:58:31.387826Z 0 [Note] Binlog end
2018-01-11T22:58:31.388011Z 0 [Note] /usr/sbin/mysqld: Shutdown complete
Diggin' around the web I tried some solutions and I found someone with similar issue trying to launch this command:

Code: Select all

sudo /usr/sbin/mysqld --skip-grant-tables --skip-networking --user=mysql &
But I got this result and nothing is running anyway.

Code: Select all

[root@www local]# sudo /usr/sbin/mysqld --skip-grant-tables --skip-networking --user=mysql &
[1] 31910
[root@www local]# 2018-01-11T22:59:38.858174Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.20-log) starting as process 31911 ...
2018-01-11T22:59:38.868489Z 0 [Note] InnoDB: PUNCH HOLE support available
2018-01-11T22:59:38.868541Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-01-11T22:59:38.868563Z 0 [Note] InnoDB: Uses event mutexes
2018-01-11T22:59:38.868577Z 0 [Note] InnoDB: GCC builtin __sync_synchronize() is used for memory barrier
2018-01-11T22:59:38.868591Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-01-11T22:59:38.868604Z 0 [Note] InnoDB: Using Linux native AIO
2018-01-11T22:59:38.870055Z 0 [Note] InnoDB: Number of pools: 1
2018-01-11T22:59:38.871958Z 0 [Note] InnoDB: Using CPU crc32 instructions
2018-01-11T22:59:38.882695Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-01-11T22:59:38.904975Z 0 [Note] InnoDB: Completed initialization of buffer pool
2018-01-11T22:59:38.909339Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2018-01-11T22:59:38.946190Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2018-01-11T22:59:39.016312Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2018-01-11T22:59:39.016434Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2018-01-11T22:59:39.066565Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2018-01-11T22:59:39.067998Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2018-01-11T22:59:39.068030Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2018-01-11T22:59:39.071683Z 0 [Note] InnoDB: Waiting for purge to start
2018-01-11T22:59:39.121986Z 0 [Note] InnoDB: 5.7.20 started; log sequence number 18814190143
2018-01-11T22:59:39.124946Z 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2018-01-11T22:59:39.126798Z 0 [Note] Plugin 'FEDERATED' is disabled.
2018-01-11T22:59:39.127010Z 0 [ERROR] unknown option '--skip-locking'
2018-01-11T22:59:39.127025Z 0 [ERROR] Aborting

2018-01-11T22:59:39.127046Z 0 [Note] Binlog end
2018-01-11T22:59:39.127156Z 0 [Note] Shutting down plugin 'ngram'
2018-01-11T22:59:39.127174Z 0 [Note] Shutting down plugin 'BLACKHOLE'
2018-01-11T22:59:39.127191Z 0 [Note] Shutting down plugin 'partition'
2018-01-11T22:59:39.127200Z 0 [Note] Shutting down plugin 'ARCHIVE'
2018-01-11T22:59:39.127209Z 0 [Note] Shutting down plugin 'MyISAM'
2018-01-11T22:59:39.130359Z 0 [Note] Shutting down plugin 'CSV'
2018-01-11T22:59:39.130397Z 0 [Note] Shutting down plugin 'INNODB_SYS_VIRTUAL'
2018-01-11T22:59:39.130408Z 0 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
2018-01-11T22:59:39.130417Z 0 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
2018-01-11T22:59:39.130425Z 0 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
2018-01-11T22:59:39.130434Z 0 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
2018-01-11T22:59:39.130443Z 0 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
2018-01-11T22:59:39.130451Z 0 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
2018-01-11T22:59:39.130460Z 0 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
2018-01-11T22:59:39.130468Z 0 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
2018-01-11T22:59:39.130477Z 0 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
2018-01-11T22:59:39.130486Z 0 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
2018-01-11T22:59:39.130494Z 0 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
2018-01-11T22:59:39.130503Z 0 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
2018-01-11T22:59:39.130511Z 0 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
2018-01-11T22:59:39.130519Z 0 [Note] Shutting down plugin 'INNODB_FT_DELETED'
2018-01-11T22:59:39.130528Z 0 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
2018-01-11T22:59:39.130536Z 0 [Note] Shutting down plugin 'INNODB_METRICS'
2018-01-11T22:59:39.130544Z 0 [Note] Shutting down plugin 'INNODB_TEMP_TABLE_INFO'
2018-01-11T22:59:39.130553Z 0 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
2018-01-11T22:59:39.130562Z 0 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
2018-01-11T22:59:39.130570Z 0 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
2018-01-11T22:59:39.130580Z 0 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
2018-01-11T22:59:39.130588Z 0 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
2018-01-11T22:59:39.130597Z 0 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
2018-01-11T22:59:39.130607Z 0 [Note] Shutting down plugin 'INNODB_CMPMEM'
2018-01-11T22:59:39.130616Z 0 [Note] Shutting down plugin 'INNODB_CMP_RESET'
2018-01-11T22:59:39.130625Z 0 [Note] Shutting down plugin 'INNODB_CMP'
2018-01-11T22:59:39.130633Z 0 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
2018-01-11T22:59:39.130642Z 0 [Note] Shutting down plugin 'INNODB_LOCKS'
2018-01-11T22:59:39.130650Z 0 [Note] Shutting down plugin 'INNODB_TRX'
2018-01-11T22:59:39.130659Z 0 [Note] Shutting down plugin 'InnoDB'
2018-01-11T22:59:39.130815Z 0 [Note] InnoDB: FTS optimize thread exiting.
2018-01-11T22:59:39.131239Z 0 [Note] InnoDB: Starting shutdown...
2018-01-11T22:59:39.131738Z 0 [Note] InnoDB: Buffer pool(s) load completed at 180111 23:59:39
2018-01-11T22:59:39.131812Z 0 [Note] InnoDB: Dumping buffer pool(s) to /var/lib/mysql/ib_buffer_pool
2018-01-11T22:59:39.134425Z 0 [Note] InnoDB: Buffer pool(s) dump completed at 180111 23:59:39
2018-01-11T22:59:40.741487Z 0 [Note] InnoDB: Shutdown completed; log sequence number 18814190162
2018-01-11T22:59:40.744620Z 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
2018-01-11T22:59:40.744669Z 0 [Note] Shutting down plugin 'MEMORY'
2018-01-11T22:59:40.744689Z 0 [Note] Shutting down plugin 'MRG_MYISAM'
2018-01-11T22:59:40.744705Z 0 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2018-01-11T22:59:40.744896Z 0 [Note] Shutting down plugin 'sha256_password'
2018-01-11T22:59:40.744913Z 0 [Note] Shutting down plugin 'mysql_native_password'
2018-01-11T22:59:40.745128Z 0 [Note] Shutting down plugin 'binlog'
2018-01-11T22:59:40.745510Z 0 [Note] /usr/sbin/mysqld: Shutdown complete
I don't really know what to do, any help please?


Post Reply