System error with default boot option

General support questions
hoanggeneral
Posts: 4
Joined: 2017/03/30 19:47:09

System error with default boot option

Postby hoanggeneral » 2018/01/18 17:02:31

I have 2 options to boot at the yellow screen (below):

1) SHMZ (2.6.32-642.6.2.el6.x86_64)
2) PBX (2.6.32-431.el6.x86_64)
2018-01-18 11_58_29-System error with default boot option - FreePBX _ Installation - FreePBX Communi.jpg
yellow boot screen
2018-01-18 11_58_29-System error with default boot option - FreePBX _ Installation - FreePBX Communi.jpg (33.47 KiB) Viewed 355 times


The 1st option is the default option. However, if I leave the system to auto boot into this option, the system will give me the error ERST: Failed to get Error Log Address Range. Kernel panic - not syncing: VFS: Unable to mount root fs on unknown -block(0,0)
2018-01-18 11_59_34-System error with default boot option - FreePBX _ Installation - FreePBX Communi.jpg
error if continue with 1st boot option
2018-01-18 11_59_34-System error with default boot option - FreePBX _ Installation - FreePBX Communi.jpg (25.24 KiB) Viewed 355 times


A- How can I fix this crash issue?
B- In the mean time, how can I set the 2nd option (PBX) as the default boot?

Thank you.
Earth is our home. Preserve it!

User avatar
TrevorH
Forum Moderator
Posts: 22584
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: System error with default boot option

Postby TrevorH » 2018/01/18 19:00:51

Boot to the working kernel and yum reinstall the other one by full name and version number. However, that really doesn't look like a CentOS system at all... and if it is, it's very badly out of date and needs a yum update

For FreePBX questions you need to ask the freepbx people. It is not CentOS.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

hoanggeneral
Posts: 4
Joined: 2017/03/30 19:47:09

Re: System error with default boot option

Postby hoanggeneral » 2018/01/23 15:28:57

Hi Trevor.
It's a CentOS machine.
This is the kernel of the working once.

Code: Select all

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.32-431.el6.x86_64 #1 SMP Fri Nov 22 03:15:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

How can I set the 2nd option (PBX) as the default boot?
Earth is our home. Preserve it!

hoanggeneral
Posts: 4
Joined: 2017/03/30 19:47:09

Re: System error with default boot option

Postby hoanggeneral » 2018/01/23 15:48:02

hoanggeneral wrote:How can I set the 2nd option (PBX) as the default boot?


Edit the file grub.conf in /boot/grub to change the "default" from 0 to 1 to set the boot default to the 2nd option.
Earth is our home. Preserve it!