time + 1 hour

General support questions
Post Reply
Posts: 1
Joined: 2018/02/14 09:47:40

time + 1 hour

Post by jordan85 » 2018/02/14 10:10:56

Hi all,

I have a problem with my Centos 6.8, the server is not on time, it shows me an hour more. I am on the right time zone but the time is not correct. I tried to force the time change with the date command but the change only works for one minute after the server switches back with an extra hour. Same principle with the command ntpdate, I make the change and it only works for a minute. I tried a lot of manipulation but none works, would you have a resolution track?

Thanks in advance,


User avatar
Forum Moderator
Posts: 24809
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: time + 1 hour

Post by TrevorH » 2018/02/14 10:26:43

What is the output from rpm -V tzdata ? If there is any output then use yum reinstall tzdata to reinstall it.

On CentOS 6 the file /etc/localtime should be a copy (made using cp) of the relevant /usr/share/zoneinfo file for your area. If it is a symlink then this will happen as yum updates will sometimes follow a symlink and overwrite the original file and require the rpm to be reinstalled. If /etc/localtime is a symlink on el6 then remove the symlink and cp -p /usr/share/zoneinfo/$yourzone /etc/localtime instead.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply