Vitrual Box 4.1 help!

General support questions
Post Reply
swarsi
Posts: 4
Joined: 2017/10/27 20:42:07

Vitrual Box 4.1 help!

Post by swarsi » 2018/02/15 16:50:27

Hi,

I am running centos 6.2 on my machine and have installed Virtual Box 4.1. I am attempting to update dependencies and kernals but I am running into the error below. Any help would be appreciated.

From : https://www.virtualbox.org/download/oracle_vbox.asc
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : libX11-common-1.6.4-3.el6.noarch 1/8
Updating : libxcb-1.12-4.el6.x86_64 2/8
Updating : libX11-1.6.4-3.el6.x86_64 3/8
Installing : SDL-1.2.14-7.el6_7.1.x86_64 4/8
Installing : VirtualBox-4.1-4.1.44_104071_el6-1.x86_64 5/8

Creating group 'vboxusers'. VM users must be member of that group!

No precompiled module for this kernel found -- trying to build one. Messages
emitted during module compilation will be logged to /var/log/vbox-install.log.

Stopping VirtualBox kernel modules [ OK ]
Uninstalling old VirtualBox DKMS kernel modules [ OK ]
Trying to register the VirtualBox kernel modules using DKMS
Error! Your kernel headers for kernel 2.6.32-220.el6.x86_64 cannot be found at
/lib/modules/2.6.32-220.el6.x86_64/build or /lib/modules/2.6.32-220.el6.x86_64/source.
[FAILED]
(Failed, trying without DKMS)
Recompiling VirtualBox kernel modules [FAILED]
(Look at /var/log/vbox-install.log to find out what went wrong)
Cleanup : libX11-1.3-2.el6.x86_64 6/8
Cleanup : libX11-common-1.3-2.el6.noarch 7/8
Cleanup : libxcb-1.5-1.el6.x86_64 8/8

Installed:
VirtualBox-4.1.x86_64 0:4.1.44_104071_el6-1

Dependency Installed:
SDL.x86_64 0:1.2.14-7.el6_7.1

Updated:
libX11.x86_64 0:1.6.4-3.el6 libxcb.x86_64 0:1.12-4.el6

Dependency Updated:
libX11-common.noarch 0:1.6.4-3.el6

User avatar
TrevorH
Forum Moderator
Posts: 22797
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Vitrual Box 4.1 help!

Post by TrevorH » 2018/02/15 17:36:11

So from this we gather that you really really like ancient software?

CentOS 6.2 is old, out of date and riddled with security bugs and should not be used. Run yum update to get up to date and use 6.9. In addition, Vbox 4.1 is just as ancient - current version is 5.2.6 and is the one to use. 4.1 has been out of support for over 2 years.

You will also need to make sure you have the kernel-headers and/or kernel-devel packages installed.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply