Cant install Php5.6 or higher on CentOS 32bit

General support questions
Post Reply
TheRiderU
Posts: 1
Joined: 2018/02/22 15:07:53

Cant install Php5.6 or higher on CentOS 32bit

Post by TheRiderU » 2018/02/22 15:10:57

Hello Community,

i have a problem i cant update/upgrade the php 5.3.3 on my CentOS6.9 and dont have any clue why.
i enabled the repo remi and epel but when i try to install the php 56 yum always install php 5.3.3.

can someone of you help me pls?

User avatar
TrevorH
Forum Moderator
Posts: 23456
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Cant install Php5.6 or higher on CentOS 32bit

Post by TrevorH » 2018/02/22 16:23:12

I have no idea if Remi provides packages for 32 bit CentOS 6 but check if you have yum-plugin-priorities installed and configured so that packages from an unknown unprioritised repo are not used.

The IUS repo has 32 bit packages for CentOS 6 and they have php56u, php70u and php71u packages available. The way IUS works, those will not install in parallel with the distro php so you have to remove those first (or use yum-plugin-replace)
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
remirepo
Posts: 292
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: Cant install Php5.6 or higher on CentOS 32bit

Post by remirepo » 2018/02/22 16:58:15

> i enabled the repo remi and epel but when i try to install the php 56 yum always install php 5.3.3.

Available, just follow the Wizard instructions
https://rpms.remirepo.net/wizard/
Remi's Repository - Forum - Blog

Post Reply