fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

General support questions
fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby fivedai » 2018/04/14 03:20:40

when reinstalling centos, i wan to remain /home/ /opt not formated.
I chose the old partition, and the /boot /boot/efi as reformate, but /home /opt remain old, then it shows must has /boot/efi partition, and blocks, can't continue...
So i tried many ways to solve the problem.
Just to make different sequence of setting the partition, so we can continue the reinstalling.
I just set the /boot/efi/ as the last one, only this way can continue...
It looks like the centos 6.9 DVD1 has some bugs when reinstalling.
andalso the DVD1 has some files missing during install, i just download the files from mirror, and copy them to the correct dir.

User avatar
TrevorH
Forum Moderator
Posts: 22599
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby TrevorH » 2018/04/14 12:20:16

andalso the DVD1 has some files missing during install, i just download the files from mirror, and copy them to the correct dir.


Err, no, it doesn't. Did you check the sha256sum of your downloaded iso image against the list we publish https://wiki.centos.org/Manuals/ReleaseNotes/CentOS6.9

Are you installing from a USB key? If so then see http://wiki.centos.org/HowTos/InstallFromUSBkey as there are some utilities that actively break the iso image by amending it as they copy it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby fivedai » 2018/04/18 11:48:40

hi, just the file type name missed, the files exist. such as a299xxx shuld be a299xxx.html

User avatar
TrevorH
Forum Moderator
Posts: 22599
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby TrevorH » 2018/04/18 14:21:23

Something is corrupting your DVD iso image as it's being written then. Or whatever you're using to view it is not displaying it correctly.

I see no files called a299* on the CentOS 6.9 DVD image. Please give an exact example of a wrong filename.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby fivedai » 2018/04/24 11:08:56

under dir /repodata
Attachments
Selection_file.png
Selection_file.png (26.01 KiB) Viewed 271 times

User avatar
TrevorH
Forum Moderator
Posts: 22599
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby TrevorH » 2018/04/24 11:18:36

That's a symptom of the corruption. What are you using to view that? Don't forget that Windows strips off file extensions by default unless you tell it not to. On my copy of CentOS-6.9-x86_64-bin-DVD1.iso when it's mounted, I see the following files are present:

$ ll CentOS-6-x86_64/repodata/
total 27056
-r--r--r-- 1 root root 231286 Mar 28 2017 1cde788f77b08a7eb3dfdba12fa384a5f0214147a717a1e2d4504368037fba90-c6-x86_64-comps.xml.gz
-r--r--r-- 1 root root 1260410 Mar 28 2017 43d8fd068164b0f042845474d6a22262798b9f0d1f49ad1bf9f95b953089777d-c6-x86_64-comps.xml
-r--r--r-- 1 root root 6635346 Mar 28 2017 594889376c2452dc8178bbaed982deba4dff38a42716ac03fc84576c17b1d79b-filelists.sqlite.bz2
-r--r--r-- 1 root root 3115016 Mar 28 2017 92299bd89d0ef9e4030e78d31399a96b41712239f032d0092f2345ba5cb01404-other.xml.gz
-r--r--r-- 1 root root 2782079 Mar 28 2017 9f2ef5087547b18bdccc798b0cad7456047fc69ca17db69d3159b6dd84ed1c11-primary.xml.gz
-r--r--r-- 1 root root 2575 Mar 28 2017 TRANS.TBL
-r--r--r-- 1 root root 4903474 Mar 28 2017 ad73b7fa76bb45feea7e4cdb2d896279524039545e8764ceaa515665f897a0c5-primary.sqlite.bz2
-r--r--r-- 1 root root 5899804 Mar 28 2017 dc8a406c3cc1c5103ff2e22a1b9d3d0d09a13a6fda831ffecebdd55484bf5146-filelists.xml.gz
-r--r--r-- 1 root root 2868247 Mar 28 2017 f18d3f35ab887f27a5acc563138bd58a0c9b668e8cd79dbb32c4fc610c88e320-other.sqlite.bz2
-r--r--r-- 1 root root 4062 Mar 28 2017 repomd.xml
$ sha256sum CentOS-6.9-x86_64-bin-DVD1.iso
d27cf37a40509c17ad70f37bc743f038c1feba00476fe6b69682aa424c399ea6 CentOS-6.9-x86_64-bin-DVD1.iso


That sha256sum matches with the one in the CentOS 6.9 release notes

d27cf37a40509c17ad70f37bc743f038c1feba00476fe6b69682aa424c399ea6 CentOS-6.9-x86_64-bin-DVD1.iso
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
avij
Forum Moderator
Posts: 2455
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby avij » 2018/04/24 12:08:12

This happens when you copy the files individually from a mounted .iso to the USB stick.

Don't do that, but instead, dd the .iso image to the USB stick. See the link posted by TrevorH for details.

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby fivedai » 2018/05/03 09:43:07

thanks for your correct reply.
In linux is ok.
I use UniversalUSB to burn the ISO to USB in windows, should be caused by that.
Next time i should use DD in linux.
But my notebook just has win10 installed initially.


total 27056
-r--r--r--. 1 root root 5899804 Mar 29 2017 dc8a406c3cc1c5103ff2e22a1b9d3d0d09a13a6fda831ffecebdd55484bf5146-filelists.xml.gz
-r--r--r--. 1 root root 2782079 Mar 29 2017 9f2ef5087547b18bdccc798b0cad7456047fc69ca17db69d3159b6dd84ed1c11-primary.xml.gz
-r--r--r--. 1 root root 3115016 Mar 29 2017 92299bd89d0ef9e4030e78d31399a96b41712239f032d0092f2345ba5cb01404-other.xml.gz
-r--r--r--. 1 root root 2868247 Mar 29 2017 f18d3f35ab887f27a5acc563138bd58a0c9b668e8cd79dbb32c4fc610c88e320-other.sqlite.bz2
-r--r--r--. 1 root root 6635346 Mar 29 2017 594889376c2452dc8178bbaed982deba4dff38a42716ac03fc84576c17b1d79b-filelists.sqlite.bz2
-r--r--r--. 1 root root 4062 Mar 29 2017 repomd.xml
-r--r--r--. 1 root root 4903474 Mar 29 2017 ad73b7fa76bb45feea7e4cdb2d896279524039545e8764ceaa515665f897a0c5-primary.sqlite.bz2
-r--r--r--. 1 root root 2575 Mar 29 2017 TRANS.TBL
-r--r--r--. 1 root root 1260410 Mar 29 2017 43d8fd068164b0f042845474d6a22262798b9f0d1f49ad1bf9f95b953089777d-c6-x86_64-comps.xml
-r--r--r--. 1 root root 231286 Mar 29 2017 1cde788f77b08a7eb3dfdba12fa384a5f0214147a717a1e2d4504368037fba90-c6-x86_64-comps.xml.gz

TrevorH wrote:That's a symptom of the corruption. What are you using to view that? Don't forget that Windows strips off file extensions by default unless you tell it not to. On my copy of CentOS-6.9-x86_64-bin-DVD1.iso when it's mounted, I see the following files are present:

$ ll CentOS-6-x86_64/repodata/
total 27056
-r--r--r-- 1 root root 231286 Mar 28 2017 1cde788f77b08a7eb3dfdba12fa384a5f0214147a717a1e2d4504368037fba90-c6-x86_64-comps.xml.gz
-r--r--r-- 1 root root 1260410 Mar 28 2017 43d8fd068164b0f042845474d6a22262798b9f0d1f49ad1bf9f95b953089777d-c6-x86_64-comps.xml
-r--r--r-- 1 root root 6635346 Mar 28 2017 594889376c2452dc8178bbaed982deba4dff38a42716ac03fc84576c17b1d79b-filelists.sqlite.bz2
-r--r--r-- 1 root root 3115016 Mar 28 2017 92299bd89d0ef9e4030e78d31399a96b41712239f032d0092f2345ba5cb01404-other.xml.gz
-r--r--r-- 1 root root 2782079 Mar 28 2017 9f2ef5087547b18bdccc798b0cad7456047fc69ca17db69d3159b6dd84ed1c11-primary.xml.gz
-r--r--r-- 1 root root 2575 Mar 28 2017 TRANS.TBL
-r--r--r-- 1 root root 4903474 Mar 28 2017 ad73b7fa76bb45feea7e4cdb2d896279524039545e8764ceaa515665f897a0c5-primary.sqlite.bz2
-r--r--r-- 1 root root 5899804 Mar 28 2017 dc8a406c3cc1c5103ff2e22a1b9d3d0d09a13a6fda831ffecebdd55484bf5146-filelists.xml.gz
-r--r--r-- 1 root root 2868247 Mar 28 2017 f18d3f35ab887f27a5acc563138bd58a0c9b668e8cd79dbb32c4fc610c88e320-other.sqlite.bz2
-r--r--r-- 1 root root 4062 Mar 28 2017 repomd.xml
$ sha256sum CentOS-6.9-x86_64-bin-DVD1.iso
d27cf37a40509c17ad70f37bc743f038c1feba00476fe6b69682aa424c399ea6 CentOS-6.9-x86_64-bin-DVD1.iso


That sha256sum matches with the one in the CentOS 6.9 release notes

d27cf37a40509c17ad70f37bc743f038c1feba00476fe6b69682aa424c399ea6 CentOS-6.9-x86_64-bin-DVD1.iso

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby fivedai » 2018/05/03 09:49:58

ok, thanks, it's as u described.
dd in liunx is ok.
My question is that dd in linux support the uefi install?
I use UniversalUSB to burn ISO to usb, and it support UEFI well.

BTW:
in win10, OS doesn't support file name with '-' .


and my sha256sum is ok:

d27cf37a40509c17ad70f37bc743f038c1feba00476fe6b69682aa424c399ea6
avij wrote:This happens when you copy the files individually from a mounted .iso to the USB stick.

Don't do that, but instead, dd the .iso image to the USB stick. See the link posted by TrevorH for details.

User avatar
TrevorH
Forum Moderator
Posts: 22599
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: fix bug: blocked at must has /boot/efi partition when reinstall centos 6.9

Postby TrevorH » 2018/05/03 09:53:57

Our iso images already support UEFI. It is the attempt by that utility to add support for it to something that it already has that is causing the problems.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke