Centos 6 / Samba / SMB2 appears broken

General support questions
Post Reply
jamesjameson
Posts: 4
Joined: 2018/05/04 16:09:13

Centos 6 / Samba / SMB2 appears broken

Post by jamesjameson » 2018/05/04 16:14:25

I have my CentOS servers hooked up to Active Directory and I use SSSD. This all worked fine so long as SMB1 was enabled on the servers. I recently disabled SMB1 and now I can't join new Centos 6 servers to my domain.

I did try adding max protocol = SMB2 to my smb.conf file but it still doesn't work.

Specific error message I get using the net ads join command
Failed to join domain: failed to lookup DC info for domain 'EXAMPLE.COM' over rpc: NT_STATUS_CONNECTION_RESET

If I run the command with -d 10 I see this error
failed negprot: NT_STATUS_CONNECTION_RESET

If anyone has any ideas I've been digging around and nothing seems to help.

User avatar
TrevorH
Forum Moderator
Posts: 23652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos 6 / Samba / SMB2 appears broken

Post by TrevorH » 2018/05/04 17:53:15

Are you up to date?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

jamesjameson
Posts: 4
Joined: 2018/05/04 16:09:13

Re: Centos 6 / Samba / SMB2 appears broken

Post by jamesjameson » 2018/05/04 18:41:28

Yes I made sure to yum update all packages before posting here to make sure it wasn't related to an old package.

User avatar
TrevorH
Forum Moderator
Posts: 23652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos 6 / Samba / SMB2 appears broken

Post by TrevorH » 2018/05/04 19:13:15

And rebooted into the newer kernel? There is a kernel module involved so it would need that too.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

jamesjameson
Posts: 4
Joined: 2018/05/04 16:09:13

Re: Centos 6 / Samba / SMB2 appears broken

Post by jamesjameson » 2018/05/07 13:29:06

Linux servername 2.6.32-696.23.1.el6.x86_64 is what I get from uname command. I believe this is the most recent available. I did reboot it last time I ran updates.

jamesjameson
Posts: 4
Joined: 2018/05/04 16:09:13

Re: Centos 6 / Samba / SMB2 appears broken

Post by jamesjameson » 2018/09/06 20:02:53

FYI this is still a problem with Centos 6, but it works perfectly fine on Centos 7 so I'm not sure why. If anyone does have a fix for this I would greatly appreciate it.

Post Reply