CentOS 6.9 snd-hda-intel driver not loaded

General support questions
Post Reply
harrywangca
Posts: 8
Joined: 2016/01/12 23:27:04
Location: Vista California

CentOS 6.9 snd-hda-intel driver not loaded

Post by harrywangca » 2018/05/21 18:37:55

HI Team,

I just installed CentOS 6.9 onto my new HP Laptop 850 5G and found there is no sound.
From the terminal line:

aplay: device_list:268: no soundcards found...
lspci -v:

00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21) (prog-if 80)
Subsystem: Hewlett-Packard Company Device 83b2
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at 1ff3018000 (64-bit, non-prefetchable)
Memory at 1ff3000000 (64-bit, non-prefetchable)
Capabilities: [50] Power Management version 3
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
cat /proc/asound/modules: not this file or folder. Actually there is no asound folder there.

I also tried tried : alsamixer to press F6 and only see: default and prompt to input device name.

lsmod | grep snd: have nothing

This looks like snd-hda-intel driver not loaded. it is intel sound card, I don't know why sound driver is not loaded.

kernel: 2.6.32-696

Please help.
Thanks

User avatar
TrevorH
Forum Moderator
Posts: 22800
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6.9 snd-hda-intel driver not loaded

Post by TrevorH » 2018/05/21 18:45:58

Why CentOS 6? It's already in production phase 3 and only critical security bugs will be fixed from now on. Also no new hardware support will be added. CentOS 7 would be a much better fit for a laptop.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

harrywangca
Posts: 8
Joined: 2016/01/12 23:27:04
Location: Vista California

Re: CentOS 6.9 snd-hda-intel driver not loaded

Post by harrywangca » 2018/05/21 19:25:20

Thank you Trevorh.

Because company's requirement and all our application need to run based on 32-bit CentOS too. I also see the up-to-date released 32-bit is CentOS 6.9 too.

User avatar
TrevorH
Forum Moderator
Posts: 22800
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 6.9 snd-hda-intel driver not loaded

Post by TrevorH » 2018/05/21 19:57:50

There is a 32 bit version of CentOS 7 too. Look for the altarch builds.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

harrywangca
Posts: 8
Joined: 2016/01/12 23:27:04
Location: Vista California

Re: CentOS 6.9 snd-hda-intel driver not loaded

Post by harrywangca » 2018/05/22 21:02:39

Yes I tried CentOS 7 32 bit 1708 and 1804. Both of these 2 release freezing during installation when prompt to choose language to go to next. I am not sure what is going on but it looks like a kernel panic.

Post Reply