Package Conflict in repo Centos6 - scl-utils

General support questions
Post Reply
Nerigal
Posts: 9
Joined: 2015/05/04 17:01:54

Package Conflict in repo Centos6 - scl-utils

Post by Nerigal » 2018/07/25 15:42:04

# yum whatprovides scl-util*
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Loading mirror speeds from cached hostfile
* base: mirror.calgah.com
* epel: fedora-epel.mirror.iweb.com
* extras: centos.mirror.globo.tech
* updates: centos.mirror.globo.tech
scl-utils-20120927-29.el6_9.x86_64 : Utilities for alternative packaging
Repo : base
Matched from:
Other : scl-utils = 20120927-29.el6_9
Other : scl-utils(x86-64) = 20120927-29.el6_9



scl-utils-build-20120927-29.el6_9.x86_64 : RPM build macros for alternative packaging
Repo : base
Matched from:
Other : scl-utils-build(x86-64) = 20120927-29.el6_9
Other : scl-utils-build = 20120927-29.el6_9



scl-utils-20130529-17.el7_1.x86_64 : Utilities for alternative packaging
Repo : centos6
Matched from:
Other : scl-utils(x86-64) = 20130529-17.el7_1
Other : scl-utils = 20130529-17.el7_1



scl-utils-build-20130529-17.el7_1.x86_64 : RPM build macros for alternative packaging
Repo : centos6
Matched from:
Other : scl-utils-build = 20130529-17.el7_1
Other : scl-utils-build(x86-64) = 20130529-17.el7_1



scl-utils-20120927-27.el6_6.x86_64 : Utilities for alternative packaging
Repo : centos6
Matched from:
Other : scl-utils(x86-64) = 20120927-27.el6_6
Other : scl-utils = 20120927-27.el6_6



scl-utils-build-20120927-27.el6_6.x86_64 : RPM build macros for alternative packaging
Repo : centos6
Matched from:
Other : scl-utils-build = 20120927-27.el6_6
Other : scl-utils-build(x86-64) = 20120927-27.el6_6



scl-utils-20120927-29.el6_9.x86_64 : Utilities for alternative packaging
Repo : centos6
Matched from:
Other : scl-utils = 20120927-29.el6_9
Other : scl-utils(x86-64) = 20120927-29.el6_9



scl-utils-build-20120927-29.el6_9.x86_64 : RPM build macros for alternative packaging
Repo : centos6
Matched from:
Other : scl-utils-build(x86-64) = 20120927-29.el6_9
Other : scl-utils-build = 20120927-29.el6_9



scl-utils-20120229-1.el6.x86_64 : Utilities for alternative packaging
Repo : epel
Matched from:
Other : scl-utils(x86-64) = 20120229-1.el6
Other : scl-utils = 20120229-1.el6



scl-utils-build-20120229-1.el6.x86_64 : RPM build macros for alternative packaging
Repo : epel
Matched from:
Other : scl-utils-build = 20120229-1.el6
Other : scl-utils-build(x86-64) = 20120229-1.el6



if you look in the list you will see
scl-utils-20130529-17.el7_1.x86_64 and scl-utils-build-20130529-17.el7_1.x86_64 from centos6 repo

This cause yum to fail to install because the package expecting glibc 2.14 + which is not available by default
EL7 package should not be there at all

Thank you.

User avatar
TrevorH
Forum Moderator
Posts: 23900
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Package Conflict in repo Centos6 - scl-utils

Post by TrevorH » 2018/07/25 16:40:25

scl-utils-20130529-17.el7_1.x86_64 and scl-utils-build-20130529-17.el7_1.x86_64 from centos6 repo
We do not supply either of those. This is the output from your yum whatprovides here on an unmodified CentOS 6 system pointing to CentOS repos
scl-utils-20120927-29.el6_9.x86_64 : Utilities for alternative packaging
Repo : base
Matched from:
Other : scl-utils = 20120927-29.el6_9
Other : scl-utils(x86-64) = 20120927-29.el6_9



scl-utils-build-20120927-29.el6_9.x86_64 : RPM build macros for alternative packaging
Repo : base
Matched from:
Other : scl-utils-build(x86-64) = 20120927-29.el6_9
Other : scl-utils-build = 20120927-29.el6_9
Your problem ones appear to be for CentOS 7 ... el7_1.x86_64!
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Nerigal
Posts: 9
Joined: 2015/05/04 17:01:54

Re: Package Conflict in repo Centos6 - scl-utils

Post by Nerigal » 2018/07/25 17:00:38

Yeah, after further investigation, found that the repo "centos6" is in fact spacewalk

sorry for this

Post Reply