Help with YUM command before update libcurl

General support questions
Post Reply
nekoqiuncy
Posts: 5
Joined: 2018/11/20 23:39:51

Help with YUM command before update libcurl

Post by nekoqiuncy » 2018/11/21 00:30:28

Hi, im new on centOS server and on the forum :D , im update libcurl and now when update my server show this message:

Code: Select all

[root@server ~]# yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   libnghttp2.so.14: cannot open shared object file: No such file or directory

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.6 (r266:84292, Aug 18 2016, 15:13:37)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-17)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://yum.baseurl.org/wiki/Faq
how can fix this?, i tried upgrading YUM via RPM But it does not work, on a post found what i need update Python to 2.7, how can resolve this?, thanks this is my yum.log:

Code: Select all

[root@server ~]# tail -n 10 /var/log/yum.log
Nov 15 04:12:37 Updated: ea-php55-php-gd-5.5.38-39.39.13.cpanel.x86_64
Nov 15 04:12:38 Updated: ea-php55-php-calendar-5.5.38-39.39.13.cpanel.x86_64
Nov 15 04:12:43 Updated: cpanel-wordpress-instance-manager-plugin-2.0.1-1.1.1.cpanel.noarch
Nov 20 13:04:28 Installed: epel-release-6-8.noarch
Nov 20 13:20:36 Updated: libssh2-1.8.0-8.0.cf.rhel6.x86_64
Nov 20 13:20:36 Installed: c-ares-1.15.0-1.0.cf.rhel6.x86_64
Nov 20 13:20:36 Updated: libcurl-7.62.0-1.0.cf.rhel6.x86_64
Nov 20 13:20:37 Installed: libmetalink-0.1.3-7.rhel6.x86_64
Nov 20 13:20:37 Updated: curl-7.62.0-1.0.cf.rhel6.x86_64
Nov 20 13:20:38 Updated: libssh2-devel-1.8.0-8.0.cf.rhel6.x86_64
this is my "locate" result of libnghttp2.so.14 when i tried search:

Code: Select all

[root@server ~]# locate libnghttp2.so.14
/opt/cpanel/nghttp2/lib/libnghttp2.so.14
/opt/cpanel/nghttp2/lib/libnghttp2.so.14.16.2

User avatar
TrevorH
Forum Moderator
Posts: 27127
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Help with YUM command before update libcurl

Post by TrevorH » 2018/11/21 01:09:47

You have installed the dreadful "city-fan" repo and it breaks things. You will need to download from your nearest CentOS mirror, the packages curl and libcurl that match your current version of CentOS 6 (use rpm -qa \*curl\* to get a list of the package names you need to download. Once downloaded you will need to use rpm to install them using the --oldpackage switch to get it to replace allegedly newer versions.

Remove city-fan. It's not compatible with CentOS and just breaks it.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

nekoqiuncy
Posts: 5
Joined: 2018/11/20 23:39:51

Re: Help with YUM command before update libcurl

Post by nekoqiuncy » 2018/11/21 18:28:40

TrevorH wrote:
2018/11/21 01:09:47
You have installed the dreadful "city-fan" repo and it breaks things. You will need to download from your nearest CentOS mirror, the packages curl and libcurl that match your current version of CentOS 6 (use rpm -qa \*curl\* to get a list of the package names you need to download. Once downloaded you will need to use rpm to install them using the --oldpackage switch to get it to replace allegedly newer versions.

Remove city-fan. It's not compatible with CentOS and just breaks it.
im newbie on CentOS and RPM :? , the command to install old package is?...

Code: Select all

rpm install "curl package" --oldpackage

when i try execute get this message:

Code: Select all

[root@s107-180-77-243 ~]# rpm --oldpackage install curl-7.19.7-53.el6_9.x86_64.rpm
rpm: only installation, upgrading, rmsource and rmspec may be forced
[root@s107-180-77-243 ~]#
this is my terminal output:

Code: Select all

[root@s107-180-77-243 ~]# rpm -qa \*curl\*
ea-php55-php-curl-5.5.38-39.39.13.cpanel.x86_64
curl-7.62.0-1.0.cf.rhel6.x86_64
ea-php56-php-curl-5.6.38-2.2.4.cpanel.x86_64
libcurl-7.62.0-1.0.cf.rhel6.x86_64
ea-libcurl-7.62.0-2.2.1.cpanel.x86_64
ea-php70-php-curl-7.0.32-2.2.4.cpanel.x86_64
python-pycurl-7.19.0-9.el6.x86_64
[root@s107-180-77-243 ~]#

im downloaded curl from this mirror:
https://centos.pkgs.org/6/centos-x86_64 ... 4.rpm.html

if install this package can solve all this packages? or need download one per one?

Whoever
Posts: 1089
Joined: 2013/09/06 03:12:10

Re: Help with YUM command before update libcurl

Post by Whoever » 2018/11/21 23:15:57

that should be:

Code: Select all

rpm --install --oldpackage curl-7.19.7-53.el6_9.x86_64.rpm

nekoqiuncy
Posts: 5
Joined: 2018/11/20 23:39:51

Re: Help with YUM command before update libcurl

Post by nekoqiuncy » 2018/11/21 23:38:52

Whoever wrote:
2018/11/21 23:15:57
that should be:

Code: Select all

rpm --install --oldpackage curl-7.19.7-53.el6_9.x86_64.rpm
show me this message:

Code: Select all

[root@s107-180-77-243 ~]# rpm --install --oldpackage curl-7.19.7-53.el6_9.x86_64.rpm
error: Failed dependencies:
        libcurl = 7.19.7-53.el6_9 is needed by curl-7.19.7-53.el6_9.x86_64
[root@s107-180-77-243 ~]#
found that i need downgrade booth RPM but if i tried this same time, the terminal show me this message:

Code: Select all

[root@s107-180-77-243 ~]# rpm --install --oldpackage libcurl-7.19.7-53.el6_9.x86_64.rpm
        file /usr/lib64/libcurl.so.4 from install of libcurl-7.19.7-53.el6_9.x86_64 conflicts with file from package libcurl-7.62.0-1.0.cf.rhel6.x86_64
[root@s107-180-77-243 ~]# rpm --install --oldpackage curl-7.19.7-53.el6_9.x86_64.rpm
error: Failed dependencies:
        libcurl = 7.19.7-53.el6_9 is needed by curl-7.19.7-53.el6_9.x86_64
[root@s107-180-77-243 ~]#

Whoever
Posts: 1089
Joined: 2013/09/06 03:12:10

Re: Help with YUM command before update libcurl

Post by Whoever » 2018/11/22 00:41:38

You probably need to downgrade libcurl at the same time (in the same command) when you downgrade curl.

Code: Select all

rpm --install --oldpackage curl-7.19.7-53.el6_9.x86_64.rpm libcurl-7.19.7-53.el6_9.x86_64.rpm

nekoqiuncy
Posts: 5
Joined: 2018/11/20 23:39:51

Re: Help with YUM command before update libcurl

Post by nekoqiuncy » 2018/11/22 00:59:43

if tried in same command line i get this message:

Code: Select all

[root@s107-180-77-243 ~]# rpm --install --oldpackage curl-7.19.7-53.el6_9.x86_64.rpm libcurl-7.19.7-53.el6_9.x86_64.rpm
        file /usr/lib64/libcurl.so.4 from install of libcurl-7.19.7-53.el6_9.x86_64 conflicts with file from package libcurl-7.62.0-1.0.cf.rhel6.x86_64
        file /usr/bin/curl from install of curl-7.19.7-53.el6_9.x86_64 conflicts with file from package curl-7.62.0-1.0.cf.rhel6.x86_64
        file /usr/share/man/man1/curl.1.gz from install of curl-7.19.7-53.el6_9.x86_64 conflicts with file from package curl-7.62.0-1.0.cf.rhel6.x86_64
[root@s107-180-77-243 ~]#
this is weird, i have more issues on my server before update curl with fan-city repo??

Whoever
Posts: 1089
Joined: 2013/09/06 03:12:10

Re: Help with YUM command before update libcurl

Post by Whoever » 2018/11/22 03:17:47

Perhaps "--install" is the wrong command. Try "--upgrade" instead.

nekoqiuncy
Posts: 5
Joined: 2018/11/20 23:39:51

Re: Help with YUM command before update libcurl

Post by nekoqiuncy » 2018/11/22 16:37:08

I am very grateful for the help, my CentOS Server work correctly again :D

Post Reply

Return to “CentOS 6 - General Support”