A Better Way To Do vga=

General support questions
Post Reply
etpoole60
Posts: 51
Joined: 2015/06/21 23:25:20

A Better Way To Do vga=

Post by etpoole60 » 2019/02/18 23:11:02

I have the following parameter on my CentOS 6.10 grub kernel parameter:

kernel /vmlinuz-2.6.32-754.10.1.el6.x86_64 ro … rhgb quiet vga=34A

(the vga=34A parm)

However when I reboot I have to reenter this parm every time.
BTW, the vga=34A parm gives me a 1600x1200x32 VESA resolution.

But, even though it's coded during reboot the message comes up:
Undefined Video Mode Number: 22
So I have to enter 34A manually.

Why does it accept this parm when I enter it manually and not automatically?
How can I set this as a permanant setting and where do I set it?

And better yet, when I move to CentOS 7 how do I or do I need to set this on grub2?
TIA
Gene

User avatar
TrevorH
Forum Moderator
Posts: 26983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: A Better Way To Do vga=

Post by TrevorH » 2019/02/18 23:35:07

Try vga=0x34a
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

etpoole60
Posts: 51
Joined: 2015/06/21 23:25:20

Re: A Better Way To Do vga=

Post by etpoole60 » 2019/02/19 20:49:13

Thanks!
Will make the change and test in about an hour!
TIA

Post Reply

Return to “CentOS 6 - General Support”