No network when not running Gnome

General support questions
Post Reply
grubgrub
Posts: 1
Joined: 2019/03/27 17:44:35

No network when not running Gnome

Post by grubgrub » 2019/03/27 17:49:19

I am running Centos 6 inside a vmware on my mac.
I want to use a custom compiled window manager.
I installed xorg-x11-xinit-session and created a ~/.xinitrc starting my WM. Upon log in I choose "User script" as the session and my WM starts as expected. However the network is down and vmware tools is not running.

How do I address this? I have tried using nmcli but all my attempts fail with Error: Connection activation failed: The connection is not for this device. What scripts are Gnome running during start up activates these things?

Thanks in advance!

User avatar
TrevorH
Forum Moderator
Posts: 26956
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No network when not running Gnome

Post by TrevorH » 2019/03/27 18:03:27

I don't believe gnome has anything to do with the network at all. Network connections should be started by the network or NetworkManager services at boot time unless the ifcfg file for the connection has "ONBOOT=no" specified.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Whoever
Posts: 1087
Joined: 2013/09/06 03:12:10

Re: No network when not running Gnome

Post by Whoever » 2019/03/28 04:21:31

Try:

Code: Select all

NM_CONTROLLED="no"
ONBOOT="yes"
in the file /etc/sysconfig/network-scripts/ifcfg-<interface>

Post Reply

Return to “CentOS 6 - General Support”