Yum update problem

General support questions
Post Reply
optikab
Posts: 22
Joined: 2014/01/19 18:04:15

Yum update problem

Post by optikab » 2019/04/03 12:12:39

** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
coreutils-libs-8.4-47.el6.x86_64 is a duplicate with coreutils-libs-8.4-46.el6.x86_64
coreutils-libs-8.4-47.el6.x86_64 has missing requires of coreutils = ('0', '8.4', '47.el6')
kernel-firmware-2.6.32-696.23.1.el6.noarch is a duplicate with kernel-firmware-2.6.32-696.20.1.el6.noarch
kernel-firmware-2.6.32-754.11.1.el6.noarch is a duplicate with kernel-firmware-2.6.32-696.23.1.el6.noarch

I've done the usual cleanup and yum-complete-transaction --skip-broken etc but am getting nowhere. I think I need to manually delete these duplicates but am not 100% on how to do that correctly.

mghe
Posts: 749
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Yum update problem

Post by mghe » 2019/04/03 12:32:34

Do You use CentOS 7 or CentOS 6 ?
Repo el6 belong for CentOS 6.

optikab
Posts: 22
Joined: 2014/01/19 18:04:15

Re: Yum update problem

Post by optikab » 2019/04/03 12:47:31

Sorry this server is Centos 6 my mistake, I was updating a lot this morning.

User avatar
TrevorH
Forum Moderator
Posts: 26887
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum update problem

Post by TrevorH » 2019/04/03 15:50:07

Moved to the correct forum.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

lightman47
Posts: 976
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Yum update problem

Post by lightman47 » 2019/04/03 18:51:56

-
Last edited by lightman47 on 2019/04/03 19:44:58, edited 1 time in total.
Multple login IDs are not your friend when asking for help!

User avatar
TrevorH
Forum Moderator
Posts: 26887
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum update problem

Post by TrevorH » 2019/04/03 19:42:05

https://wiki.centos.org/HowTos/Cleaning ... tePackages is intended for CentOS 7 which has a package-cleanup parameter that is new in 7.5.

On CentOS 6 you will need to run package-cleanup --dupes to get a list of the duplicates then manually work out which of the duplicate packages is the newest and use rpm -e --nodeps --justdb $package to remove each of the newest duplicates. Once the newer ones are gone, re-run yum update to make sure that the older duplicate is re-updated to the newer version.

If you remove the older one then you might have a package database that says the newer one is installed but the files it owns might not be up to date.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

optikab
Posts: 22
Joined: 2014/01/19 18:04:15

Re: Yum update problem

Post by optikab » 2019/04/04 08:12:02

Thanks all sorted, I only had to remove coreutils-libs-8.4-47.el6.x86_64 and update.

Post Reply

Return to “CentOS 6 - General Support”