Page 1 of 1

EPEL XRDP error

Posted: 2019/10/15 11:07:27
by harishkumar01452
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirrors.praction.in
* epel: mirror01.idc.hinet.net
* extras: mirrors.praction.in
* nux-dextop: mirror.li.nux.ro
* updates: mirrors.praction.in
Resolving Dependencies
--> Running transaction check
---> Package xrdp.x86_64 1:0.9.11-5.el7 will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Processing Dependency: systemd for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Processing Dependency: systemd for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Processing Dependency: systemd for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Processing Dependency: systemd-sysv for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Processing Dependency: tigervnc-server-minimal for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: 1:xrdp-0.9.11-5.el7.x86_64
--> Finished Dependency Resolution
Error: Package: 1:xrdp-0.9.11-5.el7.x86_64 (epel)
Requires: systemd-sysv
Error: Package: 1:xrdp-0.9.11-5.el7.x86_64 (epel)
Requires: systemd
Error: Package: 1:xrdp-0.9.11-5.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: 1:xrdp-0.9.11-5.el7.x86_64 (epel)
Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: 1:xrdp-0.9.11-5.el7.x86_64 (epel)
Requires: tigervnc-server-minimal
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


unable to install XRDP on CentOS release 6.10 (Final)
please help as soon as possible

Re: EPEL XRDP error

Posted: 2019/10/15 11:35:47
by owl102
You have EPEL enabled for CentOS 7.

Remove it and install EPEL support for CentOS 6 instead.

Re: EPEL XRDP error

Posted: 2019/10/15 12:03:59
by TrevorH
Don't forget to run yum clean all either immediately before removing the el7 version or after installing the correct el6 package. The repo needs to be enabled for yum clean all to work.