SOLVED: firefox update fails Athlon XP2200+ processor

General support questions
Post Reply
jankom
Posts: 6
Joined: 2019/10/23 21:34:37

SOLVED: firefox update fails Athlon XP2200+ processor

Post by jankom » 2019/10/23 22:18:58

I recently installed CentOS-6 on my old 32 bit machine that has an nvidia video card. The nouveau driver of CentOS-6 and all other installed programs work well. After running the AddRemove Programs required updates firefox (60.9.0.1) would not load. When I remove it and reinstall the original 52.8.0 version it works again. I'll show below the error messages.

Code: Select all

libGL error: unable to load driver: nouveau_vieux_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau_vieux
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Illegal instruction (core dumped)
My installation is from downloaded iso using DVD, graphic install. Everything is great. My other boot on this old machine is a highly customized (and probably buggered up by myself) Fedora-3, and I was happy to find the still supported CentOS-6 for a 32 bit machine.

Can anybody please help making the updated firefox work? I did search the official Cent-OS repositories for "nouveau_vieux_dri" but could not find it. Also, I do have something like "pachage gtk module" and "libcanberra" installed with the original installation (or updates?) yet the updated firefox is looking for it.

Thanks - Janos
Last edited by jankom on 2019/10/30 14:04:53, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 26942
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: firefox update does not work

Post by TrevorH » 2019/10/24 06:42:59

Is the rest of your system up to date? Nouveau is part of the kernel so you not only need to update that but also reboot into it so that the uname -r command tells you the same version number as the kernel package.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

jankom
Posts: 6
Joined: 2019/10/23 21:34:37

Re: firefox update does not work

Post by jankom » 2019/10/26 23:09:04

Thx for your reply. My system is fully updated except for firefox. When I update firefox it does not work. See below:

Code: Select all

[apu@andraslinux Desktop]$ uname -r
2.6.32-754.23.1.el6.centos.plus.i686
[apu@andraslinux Desktop]$ firefox &
[1] 3986
[apu@andraslinux Desktop]$ firefox -v
Mozilla Firefox 52.8.0
[1]+  Done                    firefox
[apu@andraslinux Desktop]$ firefox -v
Starting a11y dbus service...
Mozilla Firefox 60.9.0
[apu@andraslinux Desktop]$ firefox &
[1] 4355
[apu@andraslinux Desktop]$ libGL error: unable to load driver: nouveau_vieux_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau_vieux
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"

[1]+  Illegal instruction     (core dumped) firefox
[apu@andraslinux Desktop]$ 

jankom
Posts: 6
Joined: 2019/10/23 21:34:37

Re: firefox update does not work

Post by jankom » 2019/10/27 00:55:34

Then I rebooted, and firefox still does not work - same output of errors. Then I removed the updated version and re-installed the original version (52.8.0) and it works again.

chemal
Posts: 606
Joined: 2013/12/08 19:44:49

Re: firefox update does not work

Post by chemal » 2019/10/28 19:25:40

"Illegal instruction" means there is an instruction in the firefox binary that your CPU doesn't understand. What's your CPU?

jankom
Posts: 6
Joined: 2019/10/23 21:34:37

Re: firefox update does not work

Post by jankom » 2019/10/29 01:15:07

AMD Athlon XP 2200+

chemal
Posts: 606
Joined: 2013/12/08 19:44:49

Re: firefox update does not work

Post by chemal » 2019/10/29 01:31:34

Official Firefox builds require SSE2 which your CPU doesn't have. Maybe the RH/CentOS 32-bit build of FF60esr requires SSE2, too.

jankom
Posts: 6
Joined: 2019/10/23 21:34:37

Re: firefox update does not work

Post by jankom » 2019/10/29 18:24:08

yes! - thank you. Now I realize I ran into same problem on my other boot fc3 customized installation. HOWEVER - the nouveaux-vieux is a different issue, isn't it? Another program (xawtv) complained about the same thing. I searched files and there is nothing like *vieux* .so or otherwise in my CentOS boot. Anyway, I'll have to find a different browser not relying on SSE2 instruction. :)

chemal
Posts: 606
Joined: 2013/12/08 19:44:49

Re: firefox update does not work

Post by chemal » 2019/10/29 19:42:40

Nouveau_vieux_dri.so is a nouveau driver component for nvidia cards très vieux. It's so out of date that not even C6 ships it. This means you're not getting hardware accelerated OpenGL.

You could try seamonkey available from epel. It's still based on ff52esr and has had a new release just recently. If you are lucky it works without sse2.

jankom
Posts: 6
Joined: 2019/10/23 21:34:37

Re: firefox update does not work

Post by jankom » 2019/10/30 13:58:26

Thank you, again, thank you. Downloaded seamonkey epel rpm, installed, and it works. Removed firefox because it kept reminding me of update needed. This issue is now SOLVED thanks to your suggestion. I'll fork the -vieux issue to a new question. Yes, my machine is "tres vieux" - but I like it! :D

Post Reply

Return to “CentOS 6 - General Support”