fail to install AdobeReader_enu-7.0.9-1.i386.rpm

General support questions
Post Reply
pengyou54
Posts: 22
Joined: 2006/03/24 20:26:37

fail to install AdobeReader_enu-7.0.9-1.i386.rpm

Post by pengyou54 » 2011/07/12 23:51:49

Today I installed a fresh CentOS 6 on my laptop. the kernel is 2.6.32-71.el6.x86_64. I attempted to install AdobeReader_enu-7.0.9-1.i386.rpm and the installation failed. The error messages are as follows:

[root@dell4300 Downloads]# rpm -ivh AdobeReader_enu-7.0.9-1.i386.rpm
error: Failed dependencies:
libGL.so.1 is needed by AdobeReader_enu-7.0.9-1.i386
libGLU.so.1 is needed by AdobeReader_enu-7.0.9-1.i386
libX11.so.6 is needed by AdobeReader_enu-7.0.9-1.i386
libXext.so.6 is needed by AdobeReader_enu-7.0.9-1.i386
libXt.so.6 is needed by AdobeReader_enu-7.0.9-1.i386
libatk-1.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libfontconfig.so.1 is needed by AdobeReader_enu-7.0.9-1.i386
libgdk-x11-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libgdk_pixbuf-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libgdk_pixbuf_xlib-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libglib-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libgmodule-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libgobject-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libgtk-x11-2.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libpango-1.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libpangox-1.0.so.0 is needed by AdobeReader_enu-7.0.9-1.i386
libz.so.1 is needed by AdobeReader_enu-7.0.9-1.i386


Then I checked the above libraries and found they are already installed. I don't know what is wrong with this installation.
Any help on this problem is appreciated. Thank you in advance.

cschanzle
Posts: 16
Joined: 2008/08/22 15:34:35

Re: fail to install AdobeReader_enu-7.0.9-1.i386.rpm

Post by cschanzle » 2011/07/13 01:50:41

Really, 7.0.9? Where'd you find that fossil? :-D Beware of security issues opening pdf's from the web if that's truly obsolete.

My guess is you are on x86_64 and while you have the 64-bit versions in /usr/lib64/, you don't have them in /usr/lib (32-bit). Adobe Reader is 32-bit software and needs 32-bit supporting libraries.

I suggest something like:

yum --nogpgcheck localinstall ./AdobeReader_enu-7.0.9-1.i386.rpm

That will assist you in pulling in the dependencies.

User avatar
TrevorH
Forum Moderator
Posts: 27127
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: fail to install AdobeReader_enu-7.0.9-1.i386.rpm

Post by TrevorH » 2011/07/13 06:03:27

Perhaps you should try the latest AdobeReader_enu-9.4.2-1.i486

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: fail to install AdobeReader_enu-7.0.9-1.i386.rpm

Post by pschaff » 2011/07/13 20:25:36

Install the Adobe YUM repository and AdobeReader_enu (or your choice of language):
[code]
rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm
yum --disablerepo\* --enablerepo adobe-linux-i386 list available
yum install AdobeReader_enu[/code]
Note that this will pollute your nice clean x86_64 system with ix86 multi-arch packages.

Post Reply

Return to “CentOS 6 - General Support”