GVFS-Mount: Samba Share not accessable, asking for password all the time

Issues related to applications and software problems
Kudie
Posts: 2
Joined: 2012/04/03 15:27:35

GVFS-Mount: Samba Share not accessable, asking for password all the time

Postby Kudie » 2017/01/10 09:39:12

Hello everybody,

I've Problems to Access a SMB share using GVFS-Mount:
When I try to Access a Password protected share, GVFS seems to reject the Password or it simply does "ignore" it. When using
gvfs-mount smb://<serverName>/<share>
I give the credentials and then I get the message that a Password is needed to Access this share and I'm asked for the credentials all over again.

When I try to Access the same share using smbclient:
smbclient \\\\<serverName>\\<share> -U <userName> -W <domainName>
I get Access!

I already figured out that I've to set "client use spnego = no" in /etc/samba/smb.conf. Otherwise it wouldn't work at all for smbclient as well.

According the things I've read gvfs uses the Settings from the samba config file, so I do not understand why this is not working.

Maybe anyone can give me a hint or solution for this?

Best regards,
Markus

PS: gvfs-mount was working before, even without any Special Setting in the samba config file. But during last September/October there was a package update and now it is not working any more.

RandomReaper
Posts: 1
Joined: 2017/05/04 11:08:53

Re: GVFS-Mount: Samba Share not accessable, asking for password all the time

Postby RandomReaper » 2017/05/04 11:13:26

Dear @Kudie,

You made my day!

I added the following lines to /etc/samba/smb.conf on ubuntu 16.04 LTS, and gvfs-mount is eventually working!

Code: Select all

security = user
client use spnego = no


Best regards


Marc