Sendmail Not Honoring MX Record Weight

Issues related to applications and software problems
Post Reply
StormTheGates
Posts: 9
Joined: 2014/06/25 00:16:09

Sendmail Not Honoring MX Record Weight

Post by StormTheGates » 2017/11/18 14:36:15

Hello all,

Have a really weird issue I have not encountered before.

I have a local sendmail server running on CentOS. I attempt to send an email out to user@domain.mil.

domain.mil has several MX records (according to http://digwebinterface.com), a 10 weight, a 20 weight, and 4 or 5 30 weights.

For some reason my sendmail will not honor the weights and keeps sending emails to the MX records marked 30 weight. These relays are all unavailable to the outside world, so all emails result in Deferred, cant connect.

Does anyone have any ideas?

Whoever
Posts: 1021
Joined: 2013/09/06 03:12:10

Re: Sendmail Not Honoring MX Record Weight

Post by Whoever » 2017/11/19 04:43:56

Are you sure that your mail server can contact the lower weight MX servers?

StormTheGates
Posts: 9
Joined: 2014/06/25 00:16:09

Re: Sendmail Not Honoring MX Record Weight

Post by StormTheGates » 2017/11/20 14:16:42

Honestly, I am not.

How would I go about verifying that they could?

User avatar
TrevorH
Forum Moderator
Posts: 23205
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Sendmail Not Honoring MX Record Weight

Post by TrevorH » 2017/11/20 15:44:04

telnet to port 25 on each one in turn and see if you get an SMTP banner.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply