SCLO repo not working

Issues related to applications and software problems
Post Reply
ewhuebie
Posts: 2
Joined: 2018/08/15 13:51:34

SCLO repo not working

Post by ewhuebie » 2018/08/15 14:24:53

Doesn't anyone know what's up with the Software Collections library (SCLO)?

I have a Centos6 machine that doesn't see the ruby193 packages even though I'm pretty sure I have the repo configured correctly. The repo [centos-sclo-rh] is enabled and I am able to navigate to the files I need via a browser - http://mirror.centos.org/centos/6/sclo/ ... h/ruby193/
I could install the rpms manually, but I really don't want to do that due to the number of dependencies. I've also replaced the baseurl=http://mirror.centos.org/centos/6/sclo/$basearch/rh/ param in the repo file with baseurl=http://mirror.centos.org/centos/6/sclo/x86_64/rh/ , and yielded the same results.

Tech notes below.

# yum install --noplugins ruby193 ruby193-ruby-devel ruby193-rub
Setting up Install Process
No package ruby193 available.
No package ruby193-ruby-devel available.
No package ruby193-rub available.
Error: Nothing to do

# lsb_release -a
LSB Version: :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: CentOS
Description: CentOS release 6.10 (Final)
Release: 6.10
Codename: Final


# ls /etc/yum.repos.d/
CentOS-Base.repo CentOS-fasttrack.repo CentOS-SCLo-scl.repo CentOS-Vault.repo epel-testing.repo hubzero-rh-php56.repo
CentOS-Debuginfo.repo CentOS-Media.repo CentOS-SCLo-scl-rh.repo epel.repo hubzero-eddie.repo openvz.repo


# cat /etc/yum.repos.d/CentOS-SCLo-scl-rh.repo
# CentOS-SCLo-rh.repo
#
# Please see http://wiki.centos.org/SpecialInterestGroup/SCLo for more
# information

[centos-sclo-rh]
name=CentOS-6 - SCLo rh
baseurl=http://mirror.centos.org/centos/6/sclo/$basearch/rh/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh-testing]
name=CentOS-6 - SCLo rh Testing
baseurl=http://buildlogs.centos.org/centos/6.10 ... search/rh/
gpgcheck=0
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh-source]
name=CentOS-6 - SCLo rh Sources
baseurl=http://vault.centos.org/centos/6/sclo/Source/rh/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh-debuginfo]
name=CentOS-6 - SCLo rh Debuginfo
baseurl=http://debuginfo.centos.org/centos/6/sclo/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

User avatar
TrevorH
Forum Moderator
Posts: 23907
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: SCLO repo not working

Post by TrevorH » 2018/08/15 14:36:05

I think they are deprecated, no longer supported and are about to be removed from the directories and already have been excluded from the metadata.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

ewhuebie
Posts: 2
Joined: 2018/08/15 13:51:34

Re: SCLO repo not working

Post by ewhuebie » 2018/08/15 16:09:30

Gotcha. Thank you.

Post Reply