No sound w/CentOS 6 x86_64

Issues related to applications and software problems
User avatar
TrevorH
Forum Moderator
Posts: 25553
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No sound w/CentOS 6 x86_64

Post by TrevorH » 2011/08/23 06:13:38

You can change which card is seen first/2nd etc by using options line in /etc/modprobe.conf like so

[code]
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0
[/code]

(Adjust module names for your environment!)

builder
Posts: 14
Joined: 2011/08/05 21:22:14
Location: Pollock Pines, CA
Contact:

Re: No sound w/CentOS 6 x86_64

Post by builder » 2011/08/23 20:21:45

There is no /etc/modprobe.conf file. Should I create one?

[code]# lsmod | grep snd
snd_virtuoso 13484 1
snd_oxygen_lib 34740 1 snd_virtuoso
snd_mpu401_uart 6825 1 snd_oxygen_lib
snd_rawmidi 23373 1 snd_mpu401_uart
snd_hda_codec_atihdmi 3023 1
snd_hda_intel 25194 0
snd_hda_codec 82097 2 snd_hda_codec_atihdmi,snd_hda_intel
snd_hwdep 6714 1 snd_hda_codec
snd_seq 56557 0
snd_seq_device 6626 2 snd_rawmidi,snd_seq
snd_pcm 84700 3 snd_oxygen_lib,snd_hda_intel,snd_hda_codec
snd_timer 23087 2 snd_seq,snd_pcm
snd 70053 13 snd_virtuoso,snd_oxygen_lib,snd_mpu401_uart,snd_rawmidi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore 8052 1 snd
snd_page_alloc 8628 2 snd_hda_intel,snd_pcm
#[/code]
if so, I should put something like this in there?
[code]
options snd-hda-intel index=-2
options snd-virtuoso index=0
[/code]

User avatar
TrevorH
Forum Moderator
Posts: 25553
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No sound w/CentOS 6 x86_64

Post by TrevorH » 2011/08/23 21:59:50

That looks like a good first stab at it, yes!

HDStretch
Posts: 2
Joined: 2011/08/24 17:55:55

Re: No sound w/CentOS 6 x86_64

Post by HDStretch » 2011/08/24 18:02:36

Hi. I know I am new to Cent 6, but I have something I can suggest about this issue.

There is a program called alsamixer. You should be able to run it from the command line, and
sometimes the speakers are muted.

Also, have you configured them in the sounds menu in system/preferences/sound?

There is a speaker test in that menu. I had to research all of this yesterday, but
my problem was my subwoofer volume was down. The sound in Linux is great.

builder
Posts: 14
Joined: 2011/08/05 21:22:14
Location: Pollock Pines, CA
Contact:

Re: No sound w/CentOS 6 x86_64

Post by builder » 2011/08/27 20:46:46

Well, I adjusted the modprob.conf file and rebooted. Now the ASUS Xonar D2 is registering as "card0", BUT still no audio.

The System->Preferences->Sound (a.k.a. gnome-volume-control) sees the ASUS card as the primary output device,
but when I "test speakers" there is nothing coming out. I've checked everything else that i can think of ... Even the simple
stuff like a "MUTE" button somewhere... nothing.

Any ideas out there? A utility program to use? Some other setting that might be getting in the way?

Let me know if there is something I can post here to help some of you smart guys to think me out of this.

User avatar
TrevorH
Forum Moderator
Posts: 25553
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No sound w/CentOS 6 x86_64

Post by TrevorH » 2011/08/27 20:52:33

Try System -> Administration -> Soundcard Detection

builder
Posts: 14
Joined: 2011/08/05 21:22:14
Location: Pollock Pines, CA
Contact:

Re: No sound w/CentOS 6 x86_64

Post by builder » 2011/09/09 15:15:58

Looks like the modprobe.conf changes did make the difference. Listening to The Drifters as I type.

A big thank you to everyone. :-D

Post Reply