hiredis package

Issues related to applications and software problems
vegetax
Posts: 1
Joined: 2016/12/16 21:24:24

hiredis package

Postby vegetax » 2016/12/16 21:30:33

I have a question I am looking for a package hiredis or hiredis-devel I have install epel.repo and when I do a yum search nothing comes up. The reason I need this package for installation of ntopng and it's a dependency. I am running centos 6.8 any guidance would be appreciated



um search hiredis
Loaded plugins: fastestmirror
Repository ntop is listed more than once in the configuration
Repository ntop-noarch is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* base: repo1.ash.innoscale.net
* epel: mirror.math.princeton.edu
* extras: mirror.datto.com
* updates: mirror.math.princeton.edu
Warning: No matches found for: hiredis
No Matches found



Error: Package: nprobe-7.5.161216-5535.x86_64 (ntop)
Requires: hiredis >= 0.10.1
Error: Package: nprobe-7.5.161216-5535.x86_64 (ntop)
Requires: hiredis
Error: Package: cento-1.3.161216-161.x86_64 (ntop)
Requires: zeromq >= 4.0.0
Available: zeromq-2.2.0-4.el6.i686 (epel)
zeromq = 2.2.0-4.el6
Error: Package: ntopng-2.5.161216-1905.x86_64 (ntop)
Requires: hiredis
Error: Package: nprobe-7.5.161216-5535.x86_64 (ntop)
Requires: zeromq >= 4.0.0
Available: zeromq-2.2.0-4.el6.i686 (epel)
zeromq = 2.2.0-4.el6
Error: Package: ntopng-2.5.161216-1905.x86_64 (ntop)
Requires: zeromq >= 4.0.0
Available: zeromq-2.2.0-4.el6.i686 (epel)
zeromq = 2.2.0-4.el6
Error: Package: cento-1.3.161216-161.x86_64 (ntop)
Requires: hiredis

dsdonut
Posts: 4
Joined: 2012/09/10 20:39:40

Re: hiredis package

Postby dsdonut » 2017/09/19 20:02:07

This is an old question, but I'd like to give it a bump. On some centos 6 boxes, I can install hiredis and hiredis-devel through yum. On others, it can't find the package. The epel repo is installed on all of the servers. Why can it be found on some boxes but not others?

User avatar
TrevorH
Forum Moderator
Posts: 20652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: hiredis package

Postby TrevorH » 2017/09/19 21:35:00

Most likely it's an EPEL package that got retired due to no maintainer. The boxes that were installed before it was retired will have it installed. Boxes without it installed won't be able to find it as it no longer exists. You can see by running yum list hiredis and it shows the repo on the right hand side if it exists. It'll either be listed under "Installed Packages" with @epel meaning that's where it was installed from or it'll be listed under "Available Packages" with just "epel". Or more likely, it'll just say "No matching Packages to list" as it doesn't exist in EPEL any more.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke