httpd udpate triggers 408 errors

Issues related to applications and software problems
Post Reply
username
Posts: 49
Joined: 2013/03/04 13:17:23

httpd udpate triggers 408 errors

Post by username » 2017/08/01 09:53:54

Hi,

Right after I updated Apache the 17th of July (from httpd-2.2.15-59.el6.centos.x86_64 to 2.2.15-60.el6.centos.4.x86_64 ) logwatch started reporting a lot of 408 errors. I've never seen that before on this server. Since it was deployed 4 years ago, apache has been running flawlessly.

I checked my access_log and ssl_access_log and it really seemed to start right after that specific update. I checked and there was not hint of a 408 errors during the previous month.

I downgraded httpd with yum history undo and the 408 errors stopped flooding.

What do you recommend ? Should I blacklist temporarily httpd updates ? Wait that they release another update ?

Thx

User avatar
TrevorH
Forum Moderator
Posts: 23879
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: httpd udpate triggers 408 errors

Post by TrevorH » 2017/08/01 12:33:58

Be aware that you are now missing the fixes for

Code: Select all

* Wed Jul 12 2017 Johnny Hughes <johnny@centos.org> - 2.2.15-60.4
- Roll in CentOS Branding

* Fri Jul 07 2017 Luboš Uhliarik <luhliari@redhat.com> - 2.2.15-60.4
- Related: #1427675 - CVE-2016-8743 httpd: Apache HTTP Request Parsing
  Whitespace Defects

* Thu Jun 29 2017 Luboš Uhliarik <luhliari@redhat.com> - 2.2.15-60.3
- Resolves: #1463205 - CVE-2017-7668 httpd: ap_find_token() buffer overread

* Tue Jun 20 2017 Luboš Uhliarik <luhliari@redhat.com> - 2.2.15-60.2
- Resolves: #1463354 - segfault in ap_proxy_set_scoreboard_lb

* Tue Jun 13 2017 Luboš Uhliarik <luhliari@redhat.com> - 2.2.15-60.1
- Resolves: #1427675 - CVE-2016-8743 httpd: Apache HTTP Request Parsing
  Whitespace Defects
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

username
Posts: 49
Joined: 2013/03/04 13:17:23

Re: httpd udpate triggers 408 errors

Post by username » 2017/08/04 09:27:55

I'm not quite sure if these 408 errors are affecting my users or if keeping these httpd bugs not fixed could be realistically harmful ...

I think I will just wait for the next release to update I think.

User avatar
TrevorH
Forum Moderator
Posts: 23879
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: httpd udpate triggers 408 errors

Post by TrevorH » 2017/08/04 15:27:47

Did you look in your error_log(s) to see if there was any more information on what sort of timeout it was that caused the 408?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

username
Posts: 49
Joined: 2013/03/04 13:17:23

Re: httpd udpate triggers 408 errors

Post by username » 2017/08/08 07:47:38

Yes, but there is no pattern. It seems to happen completely randomly everywhere and affect most of the users. I've changed the timeout value in httdp.conf (but it was already 60 seconds) and I've tested Apache with the KeepAlive option On but it doesn't solve the issue. It never happened before. Really weird.

michaelm111
Posts: 2
Joined: 2017/08/22 04:41:57

Re: httpd udpate triggers 408 errors

Post by michaelm111 » 2017/08/22 04:44:21

I am seeing the exact same problem on my servers. Has anyone been able to find a solution other than rolling back the update?

username
Posts: 49
Joined: 2013/03/04 13:17:23

Re: httpd udpate triggers 408 errors

Post by username » 2017/08/24 07:39:54

There is a new update available maybe it solves this issue. I updated one server to see how it goes.

EDIT : It's solved, no issue so far with the new update.

michaelm111
Posts: 2
Joined: 2017/08/22 04:41:57

Re: httpd udpate triggers 408 errors

Post by michaelm111 » 2017/08/25 13:50:10

Which update did you install?
username wrote:There is a new update available maybe it solves this issue. I updated one server to see how it goes.

EDIT : It's solved, no issue so far with the new update.

ixa
Posts: 1
Joined: 2017/08/24 14:29:51

Re: httpd udpate triggers 408 errors

Post by ixa » 2017/08/28 08:40:46

Hello! We're also suffering this 408 error flood since updating httpd last week. Our httpd package is httpd-2.2.15-60.el6.centos.5.x86_64, I think that this is the last available update.

username
Posts: 49
Joined: 2013/03/04 13:17:23

Re: httpd udpate triggers 408 errors

Post by username » 2017/08/28 12:11:55

michaelm111 wrote:Which update did you install?
username wrote:There is a new update available maybe it solves this issue. I updated one server to see how it goes.

EDIT : It's solved, no issue so far with the new update.
OK my bad, I've just checked my logs and I've got a lot of 408 errors this week end. Even with the latest package.

Post Reply