libstdc++.so.6: version `GLIBCXX_3.4.15' not found

Issues related to applications and software problems
Post Reply
Yennifer
Posts: 1
Joined: 2017/08/27 10:18:21

libstdc++.so.6: version `GLIBCXX_3.4.15' not found

Post by Yennifer » 2017/08/27 10:20:42

when starting garry's mod server
Failed to open dedicated_srv.so (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by bin/dedicated_srv.so))

User avatar
TrevorH
Forum Moderator
Posts: 23876
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: libstdc++.so.6: version `GLIBCXX_3.4.15' not found

Post by TrevorH » 2017/08/27 10:31:20

You're trying to run something that was not built for your version of CentOS. The solution is to get a copy of the app that is built for your version of CentOS. If there isn't one available then you would need to install CentOS 7 which does have the right version of glibc.

You cannot update glibc on CentOS 6 to satisfy this error. Everything else will break instead so do not even attempt it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply