install printer drivers error

Issues related to applications and software problems
eric2kwok
Posts: 5
Joined: 2015/10/23 16:16:04

install printer drivers error

Postby eric2kwok » 2017/09/04 15:51:57

==================================================

Canon Inkjet Printer Driver Ver.3.30-1 for Linux
Copyright CANON INC. 2001-2010
All Rights Reserved.

==================================================
Command executed = rpm -Uvh ./packages/cnijfilter-common-3.30-1.i386.rpm
error: Failed dependencies:
libc.so.6 is needed by cnijfilter-common-3.30-1.i386
libc.so.6(GLIBC_2.0) is needed by cnijfilter-common-3.30-1.i386
libc.so.6(GLIBC_2.1) is needed by cnijfilter-common-3.30-1.i386
libc.so.6(GLIBC_2.1.3) is needed by cnijfilter-common-3.30-1.i386
libc.so.6(GLIBC_2.3) is needed by cnijfilter-common-3.30-1.i386
libcups.so.2 is needed by cnijfilter-common-3.30-1.i386
libdl.so.2 is needed by cnijfilter-common-3.30-1.i386
libdl.so.2(GLIBC_2.0) is needed by cnijfilter-common-3.30-1.i386
libdl.so.2(GLIBC_2.1) is needed by cnijfilter-common-3.30-1.i386
libpopt.so.0 is needed by cnijfilter-common-3.30-1.i386
libpthread.so.0 is needed by cnijfilter-common-3.30-1.i386
Printer: Canon MX357 CentOS 6.9 64-bit
I download driver on this page: http://support-hk.canon-asia.com/conten ... 71802.html
file name: cnijfilter-mx350series-3.30-1-i386-rpm.tar.gz

anyone can help would be great!

User avatar
avij
Forum Moderator
Posts: 2091
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: install printer drivers error

Postby avij » 2017/09/04 16:01:17

Those dependencies look like the package is for something older than CentOS 6.

User avatar
TrevorH
Forum Moderator
Posts: 20605
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: install printer drivers error

Postby TrevorH » 2017/09/04 16:33:39

Do the install with yum not rpm. It will resolve dependencies for you and offer to install the right packages. From yum provides 'libc.so.6(GLIBC_2.3)' I get glibc-2.12-1.209.el6_9.2.i686 : The GNU libc libraries
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
avij
Forum Moderator
Posts: 2091
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: install printer drivers error

Postby avij » 2017/09/04 17:01:16

Hmm, I was about to remark that no CentOS 6 package provides libc.so.6(GLIBC_2.0), but upon further examination I found that there's a difference between i386 and x86_64 packages in this regard:

$ rpm -qp i386/Packages/glibc-2.12-1.209.el6.i686.rpm --provides | grep libc.so
libc.so.6
libc.so.6(GCC_3.0)
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.1)
libc.so.6(GLIBC_2.1.2)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.10)
libc.so.6(GLIBC_2.11)
libc.so.6(GLIBC_2.12)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.1)
libc.so.6(GLIBC_2.2.2)
libc.so.6(GLIBC_2.2.3)
libc.so.6(GLIBC_2.2.4)
libc.so.6(GLIBC_2.2.6)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.2)
libc.so.6(GLIBC_2.3.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libc.so.6(GLIBC_2.5)
libc.so.6(GLIBC_2.6)
libc.so.6(GLIBC_2.7)
libc.so.6(GLIBC_2.8)
libc.so.6(GLIBC_2.9)

$ rpm -qp x86_64/Packages/glibc-2.12-1.209.el6.x86_64.rpm --provides | grep libc.so
libc.so.6()(64bit)
libc.so.6(GLIBC_2.10)(64bit)
libc.so.6(GLIBC_2.11)(64bit)
libc.so.6(GLIBC_2.12)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.2.6)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.2)(64bit)
libc.so.6(GLIBC_2.3.3)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.5)(64bit)
libc.so.6(GLIBC_2.6)(64bit)
libc.so.6(GLIBC_2.7)(64bit)
libc.so.6(GLIBC_2.8)(64bit)
libc.so.6(GLIBC_2.9)(64bit)

Oh well, live and learn. Yes, using yum is indeed a good way to resolve the dependencies. yum install ./packages/cnijfilter-common-3.30-1.i386.rpm should work.

Sarahah
Posts: 1
Joined: 2017/09/05 10:15:32
Contact:

Re: install printer drivers error

Postby Sarahah » 2017/09/05 11:10:29

TrevorH wrote:Do the install with yum not rpm. It will resolve dependencies for you and offer to install the right packages. From yum provides 'libc.so.6(GLIBC_2.3)' I get glibc-2.12-1.209.el6_9.2.i686 : The GNU libc libraries


I did exactly the same and my problem is solved. :)

eric2kwok
Posts: 5
Joined: 2015/10/23 16:16:04

Re: install printer drivers error

Postby eric2kwok » 2017/09/05 15:08:59

Thank you very much for the help! The problem solved. Thanks a lot!