yum upgrade errors

Issues related to applications and software problems
amedix
Posts: 18
Joined: 2015/10/30 05:58:13

yum upgrade errors

Postby amedix » 2017/09/21 09:07:59

Hi,

These are the last lines of an output from my "yum upgrade" command executed on a RedHat 6.4

Code: Select all

--> Processing Dependency: elfutils-libs(x86-32) = 0.152-1.el6 for package: elfutils-0.152-1.el6.i686
---> Package kernel-devel.x86_64 0:2.6.32-220.el6 will be erased
--> Finished Dependency Resolution
Error: Package: elfutils-0.152-1.el6.i686 (@RHEL6.4-updates)
           Requires: elfutils-libs(x86-32) = 0.152-1.el6
           Removing: elfutils-libs-0.152-1.el6.i686 (@EL6_U4-x86_64)
               elfutils-libs(x86-32) = 0.152-1.el6
           Updated By: elfutils-libs-0.158-3.2.el6.i686 (rhel)
               elfutils-libs(x86-32) = 0.158-3.2.el6
Error: Package: elfutils-0.152-1.el6.i686 (@RHEL6.4-updates)
           Requires: elfutils-libelf(x86-32) = 0.152-1.el6
           Removing: elfutils-libelf-0.152-1.el6.i686 (@EL6_U4-x86_64)
               elfutils-libelf(x86-32) = 0.152-1.el6
           Updated By: elfutils-libelf-0.158-3.2.el6.i686 (rhel)
               elfutils-libelf(x86-32) = 0.158-3.2.el6
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
MQSeriesServer-U200442-7.5.0-3.x86_64 has missing requires of MQSeriesServer >= ('0', '7.5.0', None)
vmware-tools-libraries-nox-8.6.5-2.x86_64 has missing requires of vmware-tools-foundation >= ('0', '8.6.5', None)
vmware-tools-libraries-x-8.6.5-2.x86_64 has missing requires of vmware-tools-foundation >= ('0', '8.6.5', None)


It's wierd that it requires these 2 packages that are already installed !

elfutils-libs(x86-32) = 0.152-1.el6
elfutils-libelf(x86-32) = 0.152-1.el6


# rpm -qa | grep elfutils
elfutils-libs-0.152-1.el6.i686
elfutils-libelf-0.152-1.el6.x86_64
elfutils-0.152-1.el6.x86_64
elfutils-libelf-devel-0.152-1.el6.i686
elfutils-devel-0.152-1.el6.x86_64
elfutils-libelf-devel-0.152-1.el6.x86_64
elfutils-devel-0.152-1.el6.i686
elfutils-0.152-1.el6.i686
elfutils-libelf-0.152-1.el6.i686
elfutils-libs-0.152-1.el6.x86_64


I've tried with "--skip-broken" option but no luck :-(

I used to fix these kinds of dependencies problems, but I'm stuck with this one.


Thanks in advance.

User avatar
TrevorH
Forum Moderator
Posts: 20596
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum upgrade errors

Postby TrevorH » 2017/09/21 13:30:28

First this appears to be RHEL not CentOS.

Second you appear to be running 6.4 which is so far out of date that it's not funny.

You need to update to 6.9 ASAP as there are numerous high severity security vulnerabilities present in older versions. since this is RHEL you will need a valid subscription to be able to update to the newer versions. Currently all elf* packages are 0.164-2.el6.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke