krb5 dependancy problem

Issues related to applications and software problems
optikab
Posts: 18
Joined: 2014/01/19 18:04:15

krb5 dependancy problem

Postby optikab » 2017/10/05 10:18:52

Is it safe to remove any of the packages involved here, I don't recognise them?

=========================================================================================================================================================================
Package Arch Version Repository Size
=========================================================================================================================================================================
Updating:
krb5-devel x86_64 1.10.3-65.el6 base 504 k
Installing for dependencies:
libkadm5 x86_64 1.10.3-65.el6 base 143 k

Transaction Summary
=========================================================================================================================================================================
Install 1 Package(s)
Upgrade 1 Package(s)

Total download size: 647 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): krb5-devel-1.10.3-65.el6.x86_64.rpm | 504 kB 00:00
(2/2): libkadm5-1.10.3-65.el6.x86_64.rpm | 143 kB 00:00
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 560 kB/s | 647 kB 00:01
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
file /usr/lib64/libkadm5clnt_mit.so.8.0 from install of libkadm5-1.10.3-65.el6.x86_64 conflicts with file from package krb5-libs-1.10.3-57.el6.x86_64
file /usr/lib64/libkadm5srv_mit.so.8.0 from install of libkadm5-1.10.3-65.el6.x86_64 conflicts with file from package krb5-libs-1.10.3-57.el6.x86_64

Error Summary

User avatar
avij
Forum Moderator
Posts: 2172
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: krb5 dependancy problem

Postby avij » 2017/10/05 10:29:20

krb5-libs should be 1.10.3-65. Try yum update krb5-libs first. If this does not work, perhaps you have excluded some packages. See grep -ir exclude /etc/yum*

optikab
Posts: 18
Joined: 2014/01/19 18:04:15

Re: krb5 dependancy problem

Postby optikab » 2017/10/05 10:51:17

No luck:


No package krb5-lib available.
No Packages marked for Update

grep -ir exclude /etc/yum*
/etc/yum/pluginconf.d/fastestmirror.conf:#exclude=.gov, facebook
/etc/yum.conf:exclude=initscripts

User avatar
avij
Forum Moderator
Posts: 2172
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: krb5 dependancy problem

Postby avij » 2017/10/05 10:55:20

krb5-libs, not krb5-lib. Why do you have initscripts excluded? What kind of repositories do you have configured? yum repolist would show you that.

optikab
Posts: 18
Joined: 2014/01/19 18:04:15

Re: krb5 dependancy problem

Postby optikab » 2017/10/05 10:59:04

package krb5-libs-1.10.3-65.el6.x86_64 is already installed

I didn't exclude any of those I'm guessing that was done by my provider on setup.

Repo list:


Loading mirror speeds from cached hostfile
* base: mirror.econdc.com
* epel: www.mirrorservice.org
* extras: centos.serverspace.co.uk
* rpmforge: ftp.nluug.nl
* updates: anorien.csc.warwick.ac.uk
repo id repo name status
base CentOS-6 - Base 6,705+1
epel Extra Packages for Enterprise Linux 6 - x86_64 12,402
extras CentOS-6 - Extras 46
rpmforge RHEL 6 - RPMforge.net - dag 11,403
updates CentOS-6 - Updates 695+2
repolist: 31,251

User avatar
avij
Forum Moderator
Posts: 2172
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: krb5 dependancy problem

Postby avij » 2017/10/05 11:25:30

Well that's odd. In your previous post yum said that there was a conflict with krb5-libs-1.10.3-57.el6.x86_64.

How about rpm -q krb5-libs ?

optikab
Posts: 18
Joined: 2014/01/19 18:04:15

Re: krb5 dependancy problem

Postby optikab » 2017/10/05 11:31:58

rpm -q krb5-libs
krb5-libs-1.10.3-57.el6.x86_64
krb5-libs-1.10.3-65.el6.x86_64

So I have two versions installed?

Could I remove the older package?

User avatar
avij
Forum Moderator
Posts: 2172
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: krb5 dependancy problem

Postby avij » 2017/10/05 12:01:04

I would actually suggest removing the entry for the newer package from the rpm database, and then running "yum update" to make sure the newer package is properly installed. See this message for details (it's for CentOS 7, but it applies to CentOS 6 as well).

Which reminds me, this was posted to the wrong subforum. I've now moved this topic to the equivalent CentOS 6 forum.

optikab
Posts: 18
Joined: 2014/01/19 18:04:15

Re: krb5 dependancy problem

Postby optikab » 2017/10/05 12:46:27

Running 'yum update' after the following said nothing to update, does that seem ok?

yum remove krb5-libs-1.10.3-57.el6.x86_64
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package krb5-libs.x86_64 0:1.10.3-57.el6 will be erased
--> Processing Dependency: libkadm5clnt_mit.so.8()(64bit) for package: krb5-devel-1.10.3-57.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8()(64bit) for package: krb5-devel-1.10.3-57.el6.x86_64
--> Processing Dependency: krb5-libs = 1.10.3-57.el6 for package: krb5-devel-1.10.3-57.el6.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.10.3-57.el6 will be erased
--> Processing Dependency: krb5-devel for package: openssl-devel-1.0.1e-57.el6.x86_64
--> Running transaction check
---> Package openssl-devel.x86_64 0:1.0.1e-57.el6 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================
Package Arch Version Repository Size
=========================================================================================================================================================================
Removing:
krb5-libs x86_64 1.10.3-57.el6 @base 2.0 M
Removing for dependencies:
krb5-devel x86_64 1.10.3-57.el6 @base 2.3 M
openssl-devel x86_64 1.0.1e-57.el6 @base 2.2 M

Transaction Summary
=========================================================================================================================================================================
Remove 3 Package(s)

Installed size: 6.6 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : openssl-devel-1.0.1e-57.el6.x86_64 1/3
Erasing : krb5-devel-1.10.3-57.el6.x86_64 2/3
Erasing : krb5-libs-1.10.3-57.el6.x86_64 3/3
Verifying : krb5-libs-1.10.3-57.el6.x86_64 1/3
Verifying : krb5-devel-1.10.3-57.el6.x86_64 2/3
Verifying : openssl-devel-1.0.1e-57.el6.x86_64 3/3

Removed:
krb5-libs.x86_64 0:1.10.3-57.el6

Dependency Removed:
krb5-devel.x86_64 0:1.10.3-57.el6 openssl-devel.x86_64 0:1.0.1e-57.el6

User avatar
avij
Forum Moderator
Posts: 2172
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: krb5 dependancy problem

Postby avij » 2017/10/05 14:13:52

The message I linked to did not say to remove the package with yum, but with rpm with some specific options so that the dependencies would not get removed and that it would not touch any of the actual files on your hard disk, some of which may be critical... hopefully your system is still functional.

I would highly recommend reinstalling krb5-libs to make sure it is installed OK, with yum reinstall krb5-libs

What does rpm -q krb5-libs krb5-devel openssl-devel say now?