Upgrading Samba 3.6 to 4.x

Issues related to applications and software problems
capricorn80
Posts: 2
Joined: 2017/11/16 18:19:58

Upgrading Samba 3.6 to 4.x

Postby capricorn80 » 2017/11/16 18:23:42

Hi!

I am running samba 3.6 on centos 6.2 and I have to upgrade it to version 4.
I dont find any documentation for that. Is it possible to do it via yum without breaking anything. The system is use with freeradius to get email information from active directory.

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 22584
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Upgrading Samba 3.6 to 4.x

Postby TrevorH » 2017/11/16 18:39:13

No-one should run CentOS 6.2 - it's horrendously out of date and absolutely riddled with high severity security vulnerabilities. It has received no updates since the release of 6.3 on 21 June 2012 so it is at least 5.5 years out of date. 6.2 itself was released in December 2011 so it might even be older than that.

The only CentOS 6 version that receives patches is the current one and that is 6.9. That is just a yum update away and you are encouraged to get up to date ASAP and before you try anything else. Even once you get to 6.9, samba packages are 3.6.23-45.el6_9 although there are samba4 packages there too at 4.2.10-11.el6_9 but depending on what you need, those might not be enough.

CentOS 7 ships samba 4 packages as the default and those are 4.6.2-11.el7_4.

No version of samba4 shipped by CentOS or RHEL can be used as an AD domain controller in case that's what you aim to do.

I'd suspect there are ways to get this info into freeradius without using samba - the AD integration in CentOS is done using sssd and perhaps that can supply the interface you need.

For info, freeradius in CentOS 6 is 2.2.6-7.el6_9, in CentOS 7 it is 3.0.13-8.el7_4.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

capricorn80
Posts: 2
Joined: 2017/11/16 18:19:58

Re: Upgrading Samba 3.6 to 4.x

Postby capricorn80 » 2017/11/17 10:26:04

Sorry its CentOS release 6.9 (Final)