Install Python 2.6 in CentOS 6.5

Issues related to applications and software problems
Post Reply
bubblegum
Posts: 2
Joined: 2018/03/26 22:13:03

Install Python 2.6 in CentOS 6.5

Post by bubblegum » 2018/03/26 22:16:20

I am a new user of Cent OS 6.5, I want to install Python and after I searched the google, for 6.5, Python 2.6 is preferable, would anyone can tell me how to install Python 2.6, really thanks!

User avatar
TrevorH
Forum Moderator
Posts: 23208
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Install Python 2.6 in CentOS 6.5

Post by TrevorH » 2018/03/26 22:27:18

Don't install 6.5 as it is 4 years old and riddled with security vulnerabilities along with dozens of other known and already fixed bugs. Use 6.9 which is the latest CentOS 6. All CentOS 6 versions include python 2.6.6 which is the system python and must not be changed as lots of utilities depend on the exact version as shipped. It's installed by default since yum is written in it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

bubblegum
Posts: 2
Joined: 2018/03/26 22:13:03

Re: Install Python 2.6 in CentOS 6.5

Post by bubblegum » 2018/03/27 00:29:22

TrevorH wrote:Don't install 6.5 as it is 4 years old and riddled with security vulnerabilities along with dozens of other known and already fixed bugs. Use 6.9 which is the latest CentOS 6. All CentOS 6 versions include python 2.6.6 which is the system python and must not be changed as lots of utilities depend on the exact version as shipped. It's installed by default since yum is written in it.

Hi, thanks very much, I have checked the version of my default Python, which is 2.7.13. I guess I may start learning that language first, up to now there is no big deal if I use the latested version of Python, right? How do you think?

User avatar
TrevorH
Forum Moderator
Posts: 23208
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Install Python 2.6 in CentOS 6.5

Post by TrevorH » 2018/03/27 06:16:32

If you have python 2.7.13 then you do not have a CentOS system.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply