Glibc 2.14 needed

Issues related to applications and software problems
User avatar
avij
Forum Moderator
Posts: 1696
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Glibc 2.14 needed

Postby avij » 2014/02/02 12:17:05

As stated above, attempts to upgrade glibc past 2.12 are not supported here and is generally a bad idea. Those packages you have do not come from CentOS, so you should seek support from wherever you got those packages (and be prepared to reinstall your system if you screw something up).

TiTex
Posts: 36
Joined: 2014/01/21 10:36:33
Location: Cluj-Napoca, Romania

Re: Glibc 2.14 needed

Postby TiTex » 2014/02/03 12:21:11

this may not be the case here , but once a friend of mine was hosting some game servers (counter-strike 1.6 to be more specific) which was updated last year and with it came a dependency of a newer glibc version that centos 5 was runing , and he asked me if i can solve his problem without having to reinstall the OS since it's not very easy to upgrade from centos5 to centos6 major releases.

i did some google-ing on this and i found somewhere an article on complilig glibc in a custon location lets say /opt/glibcnew/ and runing it from there with
/opt/glibcnew/lib/ld-linux.so.2 --library-path /opt/glibcnew/lib/:. ./your-app

tsunami_74
Posts: 4
Joined: 2014/07/22 21:34:37

Re: Glibc 2.14 needed

Postby tsunami_74 » 2014/07/31 17:22:10

TiTex wrote:this may not be the case here , but once a friend of mine was hosting some game servers (counter-strike 1.6 to be more specific) which was updated last year and with it came a dependency of a newer glibc version that centos 5 was runing , and he asked me if i can solve his problem without having to reinstall the OS since it's not very easy to upgrade from centos5 to centos6 major releases.

i did some google-ing on this and i found somewhere an article on complilig glibc in a custon location lets say /opt/glibcnew/ and runing it from there with
/opt/glibcnew/lib/ld-linux.so.2 --library-path /opt/glibcnew/lib/:. ./your-app



i have got same problem. How can i fix this ? i am using centos 5...


Return to “CentOS 6 - Software Support”

Who is online

Users browsing this forum: No registered users and 2 guests