Issue with yum installation

Issues related to applications and software problems
Post Reply
mzwetsloot
Posts: 2
Joined: 2018/08/03 08:50:54

Issue with yum installation

Post by mzwetsloot » 2018/08/03 11:14:11

Hi,
I have a CentOS installation without yum.....thying to install it following procedure on https://wiki.centos.org/TipsAndTricks/B ... 84c7ea8920.

I have following release:
[root@marco1 etc]# rpm -q centos-release
centos-release-6-9.el6.12.3.x86_64


I can't install yum release itself due to dependency on yum-plugin-fastestmirror:
[root@marco1 ssgconfig]# rpm -Uvh yum-3.2.29-81.el6.centos.noarch.rpm
error: Failed dependencies:
yum-plugin-fastestmirror is needed by yum-3.2.29-81.el6.centos.noarch


I can't install yum-plugin-fastestmirror due to yum 3.0:
[root@marco1 ssgconfig]# rpm -Uvh yum-plugin-fastestmirror-1.1.30-41.el6.noarch.rpm
error: Failed dependencies:
yum >= 3.0 is needed by yum-plugin-fastestmirror-1.1.30-41.el6.noarch


So looks like some osrt of upgrade process to me.......does anybody have an idea how to solve this ?

User avatar
TrevorH
Forum Moderator
Posts: 23482
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Issue with yum installation

Post by TrevorH » 2018/08/03 11:19:38

You install them both at the same time with the same command.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mzwetsloot
Posts: 2
Joined: 2018/08/03 08:50:54

Re: Issue with yum installation

Post by mzwetsloot » 2018/08/03 12:22:52

TrevorH wrote:
2018/08/03 11:19:38
You install them both at the same time with the same command.
Thanks trevorH....that didn't pop my mind !

Post Reply