Getting dependency error when we tried to patch the centos server

Issues related to applications and software problems
kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/22 17:10:48

Getting dependency error when we tried to patch the centos 6 server by yum update. The error says while updating the package java-1.8.0-181 which requires NSS 3.36.0 package which does not exists in yum repo's

kindly let us know what needs to be done to fix the issue. Any updates would be much appreciated

yum update
Loaded plugins: rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dhclient.x86_64 12:4.1.1-53.P1.el6.centos.4 will be updated
---> Package dhclient.x86_64 12:4.1.1-61.P1.el6.centos will be an update
---> Package dhcp-common.x86_64 12:4.1.1-53.P1.el6.centos.4 will be updated
---> Package dhcp-common.x86_64 12:4.1.1-61.P1.el6.centos will be an update
---> Package gnupg2.x86_64 0:2.0.14-8.el6 will be updated
---> Package gnupg2.x86_64 0:2.0.14-9.el6_10 will be an update
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.171-8.b10.el6_9 will be updated
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.181-3.b13.el6_10 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.171-8.b10.el6_9 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.181-3.b13.el6_10 will be an update
--> Processing Dependency: nss >= 3.36.0 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el6_10.x86_64
---> Package kernel.x86_64 0:2.6.32-754.2.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-696.30.1.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-754.2.1.el6 will be an update
---> Package kernel-headers.x86_64 0:2.6.32-696.30.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-754.2.1.el6 will be an update
---> Package kmod-vmware-tools-vmci.x86_64 0:9.8.1.0-2.6.32.71.el6.x86_64.6.el6 will be updated
---> Package kmod-vmware-tools-vmci.x86_64 0:9.8.2.0-2.6.32.71.el6.x86_64.6.el6 will be an update
---> Package vmware-tools-core.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-core.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-esx-kmods.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-esx-kmods.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-esx-nox.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-esx-nox.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-foundation.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-foundation.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-guestlib.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-guestlib.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-libraries-nox.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-libraries-nox.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-deployPkg.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-deployPkg.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-grabbitmqProxy.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-grabbitmqProxy.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-guestInfo.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-guestInfo.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-hgfsServer.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-hgfsServer.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-powerOps.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-powerOps.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-timeSync.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-timeSync.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-vix.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-vix.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-plugins-vmbackup.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-plugins-vmbackup.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-services.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-services.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-vgauth.x86_64 0:10.2.1-2.el6 will be updated
---> Package vmware-tools-vgauth.x86_64 0:10.2.5-2.el6 will be an update
---> Package vmware-tools-vmci-common.x86_64 0:10.2.1-6.el6 will be updated
---> Package vmware-tools-vmci-common.x86_64 0:10.2.5-6.el6 will be an update
---> Package vmware-tools-vmxnet-common.x86_64 0:10.2.1-6.el6 will be updated
---> Package vmware-tools-vmxnet-common.x86_64 0:10.2.5-6.el6 will be an update
---> Package vmware-tools-vsock-common.x86_64 0:10.2.1-6.el6 will be updated
---> Package vmware-tools-vsock-common.x86_64 0:10.2.5-6.el6 will be an update
--> Finished Dependency Resolution
--> Running transaction check
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.181-3.b13.el6_10 will be an update
--> Processing Dependency: nss >= 3.36.0 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el6_10.x86_64
---> Package kernel.x86_64 0:2.6.32-696.10.1.el6 will be erased
--> Finished Dependency Resolution
Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el6_10.x86_64 (centos6-x86_64-base-20180801-01)
Requires: nss >= 3.36.0[/b]
Installed: nss-3.28.4-4.el6_9.x86_64 (@centos6-x86_64-updates-20171107-01)
nss = 3.28.4-4.el6_9
Available: nss-3.15.1-15.el6.i686 (centos6-x86_64-base-20180801-01)
nss = 3.15.1-15.el6
Available: nss-3.15.3-2.el6_5.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.15.3-2.el6_5
Available: nss-3.15.3-3.el6_5.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.15.3-3.el6_5
Available: nss-3.15.3-6.el6_5.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.15.3-6.el6_5
Available: nss-3.16.1-4.el6_5.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.16.1-4.el6_5
Available: nss-3.16.1-7.el6_5.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.16.1-7.el6_5
Available: nss-3.16.1-14.el6.i686 (centos6-x86_64-base-20180801-01)
nss = 3.16.1-14.el6
Available: nss-3.16.2.3-3.el6_6.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.16.2.3-3.el6_6
Available: nss-3.18.0-5.3.el6_6.i686 (centos6-x86_64-base-20180801-01)
nss = 3.18.0-5.3.el6_6
Available: nss-3.19.1-3.el6_6.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.19.1-3.el6_6
Available: nss-3.19.1-5.el6_7.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.19.1-5.el6_7
Available: nss-3.19.1-8.el6_7.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.19.1-8.el6_7
Available: nss-3.21.0-0.3.el6_7.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.21.0-0.3.el6_7
Available: nss-3.21.0-8.el6.i686 (centos6-x86_64-base-20180801-01)
nss = 3.21.0-8.el6
Available: nss-3.21.3-2.el6_8.i686 (centos6-x86_64-updates-20180801-01)
nss = 3.21.3-2.el6_8
Available: nss-3.27.1-13.el6.i686 (centos6-x86_64-base-20180801-01)
nss = 3.27.1-13.el6
Available: nss-3.28.3-3.el6_9.i686 (centos6-x86_64-base-20180801-01)
nss = 3.28.3-3.el6_9
Available: nss-3.28.4-1.el6_9.i686 (centos6-x86_64-base-20180801-01)
nss = 3.28.4-1.el6_9
Available: nss-3.28.4-3.el6_9.i686 (centos6-x86_64-base-20180801-01)
nss = 3.28.4-3.el6_9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 24097
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/22 17:22:12

What is the output from yum repolist ?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/22 17:29:47

TrevorH wrote:
2018/08/22 17:22:12
What is the output from yum repolist ?
~# yum repolist
Loaded plugins: rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
repo id repo name status
centos6-x86_64-base-20180801-01 centos6-x86_64-base-20180801-01 15,030
centos6-x86_64-epel-20180801-01 centos6-x86_64-epel-20180801-01 40,931
centos6-x86_64-glusterfs-20180801-01 centos6-x86_64-glusterfs-20180801-01 238
centos6-x86_64-opscode_chef-20180801-01 centos6-x86_64-opscode_chef-20180801-01 461
centos6-x86_64-spacewalkclient-20180801-01 centos6-x86_64-spacewalkclient-20180801-01 127
centos6-x86_64-splunk-20180801-01 centos6-x86_64-splunk-20180801-01 10
centos6-x86_64-updates-20180801-01 centos6-x86_64-updates-20180801-01 6,383
centos6-x86_64-vmware_tools-20180801-01 centos6-x86_64-vmware_tools-20180801-01 872
repolist: 64,052

User avatar
TrevorH
Forum Moderator
Posts: 24097
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/22 22:44:14

What's the output from yum list nss\* and from grep -ir exclud /etc/yum.* ?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/23 04:31:07

pls find the output

we are using redhat satellite server 5.7

we could not the latest nss package which is 3.36.0 as per below output

yum list nss\*
Loaded plugins: rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Installed Packages
nss.x86_64 3.28.4-4.el6_9 @centos6-x86_64-updates-20171107-01
nss-softokn.x86_64 3.14.3-23.3.el6_8 @centos6-x86_64-updates-20160801-01
nss-softokn-freebl.i686 3.14.3-23.3.el6_8 @centos6-x86_64-updates-20160801-01
nss-softokn-freebl.x86_64 3.14.3-23.3.el6_8 @centos6-x86_64-updates-20160801-01
nss-sysinit.x86_64 3.28.4-4.el6_9 @centos6-x86_64-updates-20171107-01
nss-tools.x86_64 3.28.4-4.el6_9 @centos6-x86_64-updates-20171107-01
nss-util.x86_64 3.28.4-1.el6_9 @centos6-x86_64-updates-20170501-01
Available Packages
nss.i686 3.28.4-4.el6_9 centos6-x86_64-base-20180801-01
nss-devel.i686 3.28.4-4.el6_9 centos6-x86_64-base-20180801-01
nss-devel.x86_64 3.28.4-4.el6_9 centos6-x86_64-base-20180801-01
nss-gui.x86_64 0.3.10-4.el6 centos6-x86_64-epel-20180801-01
nss-mdns.i686 0.10-8.el6 centos6-x86_64-epel-20180801-01
nss-mdns.x86_64 0.10-8.el6 centos6-x86_64-epel-20180801-01
nss-pam-ldapd.i686 0.7.5-32.el6 centos6-x86_64-base-20180801-01
nss-pam-ldapd.x86_64 0.7.5-32.el6 centos6-x86_64-base-20180801-01
nss-pkcs11-devel.i686 3.28.4-4.el6_9 centos6-x86_64-base-20180801-01
nss-pkcs11-devel.x86_64 3.28.4-4.el6_9 centos6-x86_64-base-20180801-01
nss-softokn.i686 3.14.3-23.3.el6_8 centos6-x86_64-base-20180801-01
nss-softokn-devel.i686 3.14.3-23.3.el6_8 centos6-x86_64-base-20180801-01
nss-softokn-devel.x86_64 3.14.3-23.3.el6_8 centos6-x86_64-base-20180801-01
nss-softokn-freebl-devel.i686 3.14.3-23.3.el6_8 centos6-x86_64-base-20180801-01
nss-softokn-freebl-devel.x86_64 3.14.3-23.3.el6_8 centos6-x86_64-base-20180801-01
nss-util.i686 3.28.4-1.el6_9 centos6-x86_64-base-20180801-01
nss-util-devel.i686 3.28.4-1.el6_9 centos6-x86_64-base-20180801-01
nss-util-devel.x86_64 3.28.4-1.el6_9 centos6-x86_64-base-20180801-01
nss_compat_ossl.i686 0.9.6-2.el6_7 centos6-x86_64-base-20180801-01
nss_compat_ossl.x86_64 0.9.6-2.el6_7 centos6-x86_64-base-20180801-01
nss_compat_ossl-devel.i686 0.9.6-2.el6_7 centos6-x86_64-base-20180801-01
nss_compat_ossl-devel.x86_64 0.9.6-2.el6_7 centos6-x86_64-base-20180801-01
nss_db.i686 2.2.3-0.5.pre1.el6_5.1 centos6-x86_64-base-20180801-01
nss_db.x86_64 2.2.3-0.5.pre1.el6_5.1 centos6-x86_64-base-20180801-01
nss_wrapper.i686 1.0.3-2.el6 centos6-x86_64-epel-20180801-01
nss_wrapper.x86_64 1.0.3-2.el6 centos6-x86_64-epel-20180801-01
++++++++++++++++++++=

[root@mndevlfs04 /]# grep -ir exclud /etc/yum.*?
[root@mndevlfs04 /]#

there is nothing exclude in yum repo's

User avatar
TrevorH
Forum Moderator
Posts: 24097
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/23 10:27:50

Your repos are all out of date and that's a satellite problem. The current 6.10 version of the repos contains the ones you are missing so it is your own repo that's out of sync.

Code: Select all

[root@c6test ~]# yum list nss\*
Loaded plugins: priorities
275 packages excluded due to repository priority protections
Installed Packages
nss.x86_64                                             3.36.0-8.el6                                   @QA     
nss-softokn.x86_64                                     3.14.3-23.3.el6_8                              @updates
nss-softokn-freebl.x86_64                              3.14.3-23.3.el6_8                              @updates
nss-sysinit.x86_64                                     3.36.0-8.el6                                   @QA     
nss-tools.x86_64                                       3.36.0-8.el6                                   @QA     
nss-util.x86_64                                        3.36.0-1.el6                                   @QA     
Available Packages
nss.i686                                               3.36.0-8.el6                                   base    
nss-devel.i686                                         3.36.0-8.el6                                   base    
nss-devel.x86_64                                       3.36.0-8.el6                                   base    
nss-gui.x86_64                                         0.3.10-4.el6                                   epel    
nss-mdns.i686                                          0.10-8.el6                                     epel    
nss-mdns.x86_64                                        0.10-8.el6                                     epel    
nss-pam-ldapd.i686                                     0.7.5-32.el6                                   base    
nss-pam-ldapd.x86_64                                   0.7.5-32.el6                                   base    
nss-pkcs11-devel.i686                                  3.36.0-8.el6                                   base    
nss-pkcs11-devel.x86_64                                3.36.0-8.el6                                   base    
nss-softokn.i686                                       3.14.3-23.3.el6_8                              base    
nss-softokn-devel.i686                                 3.14.3-23.3.el6_8                              base    
nss-softokn-devel.x86_64                               3.14.3-23.3.el6_8                              base    
nss-softokn-freebl.i686                                3.14.3-23.3.el6_8                              base    
nss-softokn-freebl-devel.i686                          3.14.3-23.3.el6_8                              base    
nss-softokn-freebl-devel.x86_64                        3.14.3-23.3.el6_8                              base    
nss-util.i686                                          3.36.0-1.el6                                   base    
nss-util-devel.i686                                    3.36.0-1.el6                                   base    
nss-util-devel.x86_64                                  3.36.0-1.el6                                   base    
nss_compat_ossl.i686                                   0.9.6-2.el6_7                                  base    
nss_compat_ossl.x86_64                                 0.9.6-2.el6_7                                  base    
nss_compat_ossl-devel.i686                             0.9.6-2.el6_7                                  base    
nss_compat_ossl-devel.x86_64                           0.9.6-2.el6_7                                  base    
nss_db.i686                                            2.2.3-0.5.pre1.el6_5.1                         base    
nss_db.x86_64                                          2.2.3-0.5.pre1.el6_5.1                         base    
nss_wrapper.i686                                       1.0.3-2.el6                                    epel    
nss_wrapper.x86_64                                     1.0.3-2.el6                                    epel    
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/23 14:24:19

thanks for the update.

Our servers are centos 6.9 and the latest kernel version is as follows. kindly let us know what would the latest kernel version for centos 6.10
and also how to resolve the rep sync issue.

uname -r
2.6.32-754.2.1.el6.x86_64
cat /etc/redhat-release
CentOS release 6.9 (Final)

Also let us know is there any impact if we use skip-broken to exclude the dependency issue.

User avatar
TrevorH
Forum Moderator
Posts: 24097
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/23 14:33:22

Only the current point release is supported - 6.10 in this case. As soon as 6.10 came out, 6.9 became deprecated and unsupported. You're already running a 6.10 kernel though not the latest one which is 2.6.32-754.3.5. You should update to 6.10 ASAP.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/23 15:04:21

so if we update the latest kernel version to 2.6.32-754.3.5 the server will be become to centos 6.10
Please confirm

User avatar
TrevorH
Forum Moderator
Posts: 24097
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/23 17:13:37

No, CentOS 6.10 is a collection of several hundred packages not just the kernel. You're obviously already running some parts of 6.10 since you already have a 6.10 kernel running.

Your problem is that your satellite repos are not up to date so do not contain the latest packages. Apparently you've managed to get bits of 6.10 into there as the kernel has been updated but you have missed large chunks of the rest of it - as evidenced by the lack of nss 3.36.

Don't attempt to cherry pick updates. CentOS versions are tested in their entirety, there is no support for picking one package and updating that and leaving the rest of your system behind. We only test updating to the entire point release.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply