Getting dependency error when we tried to patch the centos server

Issues related to applications and software problems
kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/23 18:32:30

Are we using the correct URL to get the packages updates.


#### Channel label: centos6-x86_64-base ####
Repo URL: http://centos.mirrors.tds.net/centos/6/updates/x86_64/

#### Channel label: centos6-x86_64-updates ####
Repo URL: http://centos.mirrors.tds.net/pub/linux ... es/x86_64/

User avatar
TrevorH
Forum Moderator
Posts: 23647
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/23 19:07:19

I suspect that's not correct since you are syncing from the /6/ symlink which always points to the latest version. That means that when 6.9 changes to 6.10, your sync will then mix 6.10 into your 6.9 repos and that's not the way we recommend. I don't use satellite etc but the wiki page about setting up a local mirror has instructions on how to do it outside of those products. For information on how to go about setting up a local CentOS mirror please see https://wiki.centos.org/HowTos/CreateLocalMirror
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/24 14:17:35

Hi,

Can i use the below Repo URL for centos 6 base updates in satellite instead of old one since my centos7 repo URL's are working fine.

#### Channel label: centos6-x86_64-base ####
Repo URL: http://centos.mirrors.tds.net/pub/linux ... os/x86_64/


OLD ONE as below

#### Channel label: centos6-x86_64-base ####
http://centos.mirrors.tds.net/centos/6/updates/x86_64/


CentOS 7 Repo URL:

#### Channel label: centos7-x86_64-base ####
Repo URL: http://centos.mirrors.tds.net/pub/linux ... os/x86_64/

#### Channel label: centos7-x86_64-updates ####
Repo URL: http://centos.mirrors.tds.net/pub/linux ... es/x86_64/

User avatar
TrevorH
Forum Moderator
Posts: 23647
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/24 15:20:55

You need to sync each point release separately. For example, for 6.9 you have base and updates repos. The updates repo gets all packages that have been updated since 6.9 came out. Now when 6.10 comes along there is a new 'base' repo and that contains all 6.10 packages at release time and the updates repo is emptied and started over. If you sync 6.10 on top of 6.9 you end up with a mixture of 6.9 and 6.10 and it won't work.

The solution is to sync from the explicit release directory - i.e. /6.10/ not from /6/ and to manage the symlink '/6/' that points to the current version.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/24 17:30:25

we are using redhat satellite 5.7 and we are using below script to sync the centos 6 channels. can you plz have a look on the script and what needs to be modified to sync the current release.Thanks.

# more sync-channels-centos6.sh

#!/bin/bash

SYNC="/usr/bin/spacewalk-repo-sync"

EMAIL="kitty@xxx.com"
LOG="$(dirname $0)/logs/sync-channels-centos6.log"

ERRCOUNT=0

echo "Starting Satellite Server Sync (from CentOS)" > $LOG
echo $(date) >> $LOG

channel="centos6-x86_64-base"
url="http://centos.mirrors.tds.net/centos/6/updates/x86_64/"

${SYNC} -f -c ${channel} -u ${url} >> $LOG
ERR=$?
if [ $ERR -ne 0 ]; then
ERRCOUNT=$(expr $ERRCOUNT + 1)
fi


channel="centos6-x86_64-updates"
url="http://centos.mirrors.tds.net/pub/linux ... es/x86_64/"

${SYNC} -f -c ${channel} -u ${url} >> $LOG
ERR=$?
if [ $ERR -ne 0 ]; then
ERRCOUNT=$(expr $ERRCOUNT + 1)
fi


channel="centos6-x86_64-spacewalkclient"
url="http://yum.spacewalkproject.org/latest- ... /6/x86_64/"

${SYNC} -f -c ${channel} -u ${url} >> $LOG
ERR=$?
if [ $ERR -ne 0 ]; then
ERRCOUNT=$(expr $ERRCOUNT + 1)
fi


echo "Finished Satellite Server Sync (from CentOS)" >> $LOG
echo $(date) >> $LOG
echo "EXITCODE:$ERRCOUNT" >> $LOG

if [ ${ERRCOUNT} -gt 0 ]; then
/bin/mailx -s "Satellite Server Sync Error(s)" ${EMAIL}<<EOM
Log file is as follows:

$(cat $LOG)

EOM

User avatar
TrevorH
Forum Moderator
Posts: 23647
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/24 17:48:59

So if I say this a third time will it help? You're syncing from the /6/ symlink. Don't do that. Sync from e.g /6.10/
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/08/24 19:23:41

sorry to disturb you again

I will use the /6.10/ base repo URL to sync but I have compared the packages on both URL's , both are contain the same packages.
please confirm which base repo URL i have to use to sync properly.

http://centos.mirrors.tds.net/centos/6/updates/x86_64/

http://centos.mirrors.tds.net/centos/6.10 /updates/x86_64/ ---> Recommended by you

User avatar
TrevorH
Forum Moderator
Posts: 23647
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/08/24 19:53:10

If you're ONLY syncing updates then you are missing ALL the packages in the base repo. The base repo is entirely replaced on every point release and updates is emptied.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 25
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/01 17:34:11

we are using below repo's URL in our repo sync script for centos 6

To sync the repo can we use the below repo's URL or else please let us know is there any other way to fix the sync issue..

#### Channel label: centos6-x86_64-base ####
Repo URL: http://centos.mirrors.tds.net/centos/6. ... es/x86_64/


#### Channel label: centos6-x86_64-updates ####
Repo URL: http://centos.mirrors.tds.net/pub/linux ... es/x86_64/

stevemowbray
Posts: 392
Joined: 2012/06/26 14:20:47

Re: Getting dependency error when we tried to patch the centos server

Post by stevemowbray » 2018/09/03 08:39:04

Those URLs both point to updates. The base one should point to base not updates!

Post Reply