Can't install Proftpd

Issues related to applications and software problems
Post Reply
gil5587
Posts: 1
Joined: 2018/11/06 14:43:09

Can't install Proftpd

Post by gil5587 » 2018/11/06 14:47:42

HI guys,

I tried to install Proftpd with this command:

Code: Select all

sudo yum install -y perl-libwww-perl proftpd proftpd-utils perl-ExtUtils-MakeMaker glibc.i686 glibc libgcc_s.so.1 perl-IO-Compress-Bzip2 perl-Archive-Extract perl-Archive-Zip perl-Archive-Tar perl-Path-Class
but I get:

Code: Select all

no package proftpd available
no package proftpd-utils available
Also,
I tried to install libcripto.so.6 and libssl.so.6 but it didn't work.

How to install them properly?
ty very much!

User avatar
TrevorH
Forum Moderator
Posts: 25548
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Can't install Proftpd

Post by TrevorH » 2018/11/06 17:13:55

We do not ship proftpd. The ftp daemon that we ship is called vsftpd and is available in the base/updates repos on a normal install. Proftpd is available via a well regarded third party yum repo called EPEL but you need to install that in order to use it. You can do that by running yum --enablerepo=extras install epel-release and now you should be able to find proftpd.

As for the libraries you are trying to install, we do ship them but they are not installed by default as they are part of an ancient openssl release. You should try not to use those if at all possible as they don't support many more modern cryptographic routines. You can find those by asking yum to tell you what provides those files:

yum provides '*/libcrypto.so.6' '*/libssl.so.6'

(please note the correct spelling of crypto vs cripto).
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply