Not able to install php 5.6, mysql and apache on Centos 6 version. Following Error coming up

Issues related to applications and software problems
Post Reply
Shivani Yadav
Posts: 1
Joined: 2018/12/15 10:28:36

Not able to install php 5.6, mysql and apache on Centos 6 version. Following Error coming up

Post by Shivani Yadav » 2018/12/15 10:32:17

[root@localhost ~]# php -v
-bash: php: command not found
[root@localhost ~]# service httpd status
httpd (pid 4232) is running...
[root@localhost ~]# grep -i php
^C
[root@localhost ~]# apache2 -v
-bash: apache2: command not found
[root@localhost ~]# mysql --version
-bash: mysql: command not found
[root@localhost ~]# sudo find / -name php
/usr/share/swig/1.3.40/php
/var/lib/php
[root@localhost ~]# sudo find / -name mysql
/usr/share/preupgrade/CentOS6_7/databases/mysql
/root/preupgrade/CentOS6_7/databases/mysql
/var/lib/mysql
/var/lib/mysql/mysql
[root@localhost ~]# sudo find / -name php
/usr/share/swig/1.3.40/php
/var/lib/php
[root@localhost ~]# sudo find / -name apache
/usr/share/tomcat7.0.39/work/Catalina/localhost/zipadmin/org/apache
/usr/share/tomcat7.0.39/work/Catalina/localhost/crm/org/apache
/usr/share/tomcat7.0.39/work/Catalina/localhost/examples/org/apache
/usr/share/tomcat7.0.39/work/Catalina/localhost/manager/org/apache
/usr/share/tomcat7.0.39/work/Catalina/localhost/_/org/apache
/usr/share/tomcat7.0.39/work/Catalina/localhost/host-manager/org/apache
/usr/share/tomcat7.0.39/work/Catalina/www.meaningfulfiction.com/_/org/apache
/usr/share/tomcat7.0.39/work/Catalina/admin.ziphub.com/zipadmin/org/apache
/usr/share/tomcat7.0.39/work/Catalina/admin.ziphub.com/_/org/apache
/usr/share/tomcat7.0.39/work/Catalina/sales.ziphub.com/crm/org/apache
/usr/share/tomcat7.0.39/work/Catalina/sales.ziphub.com/_/org/apache
/usr/share/tomcat7.0.39/work/Catalina/meaningfulfiction.com/_/org/apache
/tmp/tomcat-connectors-1.2.40-src/jkstatus/test/src/share/org/apache
/tmp/tomcat-connectors-1.2.40-src/jkstatus/src/share/org/apache
[root@localhost ~]# sudo find / -name apache2
[root@localhost ~]# php v
-bash: php: command not found
[root@localhost ~]# rpm -ql php
package php is not installed
[root@localhost ~]# find / -name php.ini
[root@localhost ~]# ^C
[root@localhost ~]# ^C
[root@localhost ~]# find / -name php.ini
[root@localhost ~]# yum install php-config
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirrors.sonic.net
* epel: mirror.sfo12.us.leaseweb.net
* extras: repos.lax.quadranet.com
* remi-php56: mirrors.mediatemple.net
* remi-safe: mirrors.mediatemple.net
* updates: repos.lax.quadranet.com
passenger/signature | 836 B 00:00
Retrieving key from https://packagecloud.io/gpg.key
passenger/signature | 1.0 kB 00:00 ...
https://oss-binaries.phusionpassenger.c ... repomd.xml: [Errno -1] repomd.xml signature could not be verified for passenger
Trying other mirror.
passenger-source/signature | 836 B 00:00
Retrieving key from https://packagecloud.io/gpg.key
passenger-source/signature | 1.0 kB 00:00 ...
https://oss-binaries.phusionpassenger.c ... repomd.xml: [Errno -1] repomd.xml signature could not be verified for passenger-source
Trying other mirror.
No package php-config available.
Error: Nothing to do
[root@localhost ~]# yum install php php-mysql
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirrors.sonic.net
* epel: mirror.sfo12.us.leaseweb.net
* extras: repos.lax.quadranet.com
* remi-php56: mirrors.mediatemple.net
* remi-safe: mirrors.mediatemple.net
* updates: repos.lax.quadranet.com
passenger/signature | 836 B 00:00
Retrieving key from https://packagecloud.io/gpg.key
passenger/signature | 1.0 kB 00:00 ...
https://oss-binaries.phusionpassenger.c ... repomd.xml: [Errno -1] repomd.xml signature could not be verified for passenger
Trying other mirror.
passenger-source/signature | 836 B 00:00
Retrieving key from https://packagecloud.io/gpg.key
passenger-source/signature | 1.0 kB 00:00 ...
https://oss-binaries.phusionpassenger.c ... repomd.xml: [Errno -1] repomd.xml signature could not be verified for passenger-source
Trying other mirror.
Package php-mysql is obsoleted by php-mysqlnd, trying to install php-mysqlnd-5.6.39-1.el7.remi.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.6.39-1.el7.remi for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.39-1.el7.remi for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-5.6.39-1.el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: php-pdo(x86-64) = 5.6.39-1.el7.remi for package: php-mysqlnd-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd-5.6.39-1.el7.remi.x86_64
--> Running transaction check
---> Package php.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-5.6.39-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
---> Package php-common.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-common-5.6.39-1.el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd-5.6.39-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pdo-5.6.39-1.el7.remi.x86_64
--> Running transaction check
---> Package php.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-5.6.39-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
---> Package php-common.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-common-5.6.39-1.el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd-5.6.39-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pdo-5.6.39-1.el7.remi.x86_64
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el7.remi.5.6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pecl-jsonc-1.3.10-2.el7.remi.5.6.x86_64
---> Package php-pecl-zip.x86_64 0:1.15.4-1.el7.remi.5.6 will be installed
--> Processing Dependency: libzip5(x86-64) >= 1.5.1 for package: php-pecl-zip-1.15.4-1.el7.remi.5.6.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pecl-zip-1.15.4-1.el7.remi.5.6.x86_64
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.15.4-1.el7.remi.5.6.x86_64
--> Running transaction check
---> Package libzip5.x86_64 0:1.5.1-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libzip5-1.5.1-1.el7.remi.x86_64
---> Package php.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-5.6.39-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-cli-5.6.39-1.el7.remi.x86_64
---> Package php-common.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-common-5.6.39-1.el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: php-mysqlnd-5.6.39-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:5.6.39-1.el7.remi will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pdo-5.6.39-1.el7.remi.x86_64
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el7.remi.5.6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pecl-jsonc-1.3.10-2.el7.remi.5.6.x86_64
---> Package php-pecl-zip.x86_64 0:1.15.4-1.el7.remi.5.6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: php-pecl-zip-1.15.4-1.el7.remi.5.6.x86_64
--> Finished Dependency Resolution
Error: Package: libzip5-1.5.1-1.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-common-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-pecl-zip-1.15.4-1.el7.remi.5.6.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-mysqlnd-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libpcre.so.1()(64bit)
Error: Package: php-pdo-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libpcre.so.1()(64bit)
Error: Package: php-pecl-jsonc-1.3.10-2.el7.remi.5.6.x86_64 (remi-php56)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: httpd-mmn = 20120211x8664
Installed: httpd-2.2.15-69.el6.centos.x86_64 (@base)
httpd-mmn = 20051115
Error: Package: php-5.6.39-1.el7.remi.x86_64 (remi-php56)
Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 26295
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Not able to install php 5.6, mysql and apache on Centos 6 version. Following Error coming up

Post by TrevorH » 2018/12/15 15:30:05

You've installed the CentOS 7 version of Remi's repos on CentOS 6. First do a yum clean all then uninstall the current remi -release package, get the right one and install that. Now try again.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply