Touchdevice just move or just click but not both

Issues related to hardware problems
Post Reply
kdev86
Posts: 1
Joined: 2019/05/15 06:47:49

Touchdevice just move or just click but not both

Post by kdev86 » 2019/05/15 07:02:06

I currently have a problem with a touch (old heating control), unfortunately I can not update the Linux (Centos 6.9 2.6.32-696).

The problem is that I've tested a (or meanwhile different) touch on the Linux, they all behave differently but none right.

The devices all register as generic-usb device hidraw0 USB HID v1.11 Device (dmesg output).
Since these come as HID, I should not need a extra driver for it(so i think), unfortunately I have no further data.

If I look at the system events (the device hangs at / dev / input / event3)

Code: Select all

 input-events 3 
then I get Sinful EV_ABS (ABS_X & ABS_Y) values, EV_KEY BTN_TOUCH pressed / released depending on where I am on the touch and press it or not.
So these are absolute values that come from the touch.

Code: Select all

bits ev: EV_SYN EV_KEY EV_ABS EV_MSC

waiting for events
10:18:26.890512: EV_MSC MSC_SCAN 852034
10:18:26.890516: EV_KEY BTN_TOUCH pressed
10:18:26.890519: EV_MSC MSC_SCAN 852039  
10:18:26.890520: EV_KEY BTN_0 pressed    
10:18:26.890525: EV_ABS ABS_X 431        
10:18:26.890527: EV_ABS ABS_Y 240        
10:18:26.890530: EV_MSC MSC_SCAN 852034  
10:18:26.890531: EV_KEY BTN_TOUCH released
10:18:26.890582: EV_ABS ??? 0             
10:18:26.890589: EV_ABS ??? 0             
10:18:26.890594: EV_ABS ??? 1             
10:18:26.890596: EV_ABS ??? 55120         
10:18:26.890602: EV_SYN code=0 value=0    
xinput only shows me the device as "Mouse 0" when I look at it in xev, I see the movements and when I touche with the second finger then I get a right click (as button 3), but no left click event ,

In my X I can move the cursor but I do not get a "left click". I mean if that moves, the right click goes (which is actually only 2 "touches" .. then it must somehow go on the xorg config synonymous, that the left click or am I wrong?

Xorg.0.log just tells me:

Code: Select all

Device "/ dev / input / mice"
Mouse0: always reports core events
Option: CorePointer on
Mouse0: mouse protocol ExplorerPS / 2
Using input driver "mouse" for Mouse0
ZAxisMapping: buttons 4 and 5 (this seems strange to me)
Buttons 9 (this seems to me funny)
The next thing is curiosity, I have a second touch.
This works the left click. However, I can not move it (although the ABS_X / ABS_Y look the same) .. (if I infect both, I can drive with one and click with the other ^ ^).

it delivers me:

Code: Select all

bits ev : EV_SYN EV_KEY EV_ABS EV_MSC       

waiting for events
10:16:49.202491: EV_MSC MSC_SCAN 589825
10:16:49.202495: EV_KEY BTN_LEFT pressed
10:16:49.202501: EV_ABS ABS_HAT2X 166   
10:16:49.202503: EV_ABS ABS_HAT2Y 203   
10:16:49.205293: EV_SYN code=0 value=0  
10:16:49.292489: EV_MSC MSC_SCAN 589825 
10:16:49.292494: EV_KEY BTN_LEFT released
I hope you have an idea,
Thank you

best regards

Post Reply