Usbserial /dev/ttyUSB recognized but not working

Issues related to hardware problems
Post Reply
before4
Posts: 1
Joined: 2019/10/29 03:31:01

Usbserial /dev/ttyUSB recognized but not working

Post by before4 » 2019/10/29 03:41:50

Code: Select all

[root@LAB1 ~]# lsusb |grep -i serial                                       
Bus 004 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
from /dev directory listed as USB1 but from demsg connected to USB0

Code: Select all

[root@LAB1 ~]# ls -tlrh /dev/ttyUSB*                                       
crw-rw---- 1 root dialout 188, 0 Oct 29 10:31 /dev/ttyUSB1

[root@LAB1 ~]# dmesg |grep -i ttyUSB                                       
usb 4-12: generic converter now attached to ttyUSB0 

 
Using minicom command shown the terminal offline and not output

User avatar
TrevorH
Forum Moderator
Posts: 27147
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Usbserial /dev/ttyUSB recognized but not working

Post by TrevorH » 2019/10/29 12:24:37

Check that you are looking at the right devices. I looked at my system and the device numbers given by lsusb.py match the device number in the dmesg output like this:

Code: Select all

$ lsusb.py | grep 0582
   3-13.4.3     0582:00e6 ff  1.10   12MBit/s 480mA 3IFs (Roland UA-25EX)
$ dmesg | grep "New USB "  | grep -i 0582
[    2.598030] usb 3-13.4.3: New USB device found, idVendor=0582, idProduct=00e6, bcdDevice= 1.01
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 6 - Hardware Support”