UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Issues related to hardware problems
slamtonio
Posts: 24
Joined: 2007/07/23 18:11:20

UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by slamtonio » 2014/03/06 01:47:22

I'm getting the following message right when the Grub bootloader starts:

Detected CPU family 6 model 69
UNSUPPORTED HARDWARE DEVICE: Intel CPU model


Right after, the system loads and seems to run fine. But I have to give this laptop to a customer and I really don't like that message.

I've seen on this message board that others report similar issues, but no fixes are mentioned.

I have updated to the latest kernel ( 2.6.32-431.5.1.el6.i686 (i686). I know this is the i386 version, I also get it on the 64 bit. I wanted to see if both had the same problem and they do.

Some one did mention that is was due to the Intel 4th generation Haswell CPU and the kernel not recognizing it. Using a kernel from ElRepo fixed the issue, but that's really not an option for me.

I'm trying to find something in Grub that I can use to hide the UNSUPPORTED HARDWARE DEVICE: Intel CPU model message at boot. Does anyone know how to suppress this message?

Or when the next CentOS 6.5 kernel update will come out?

Hardware:
Dell Latitude E5540, Processor: Intel Core i7-4600U @ 2.10GHz (4 Cores), Motherboard: Dell 01389M, Chipset: Intel Haswell-ULT DRAM, Memory: 2 x 4096 MB DDR3-1600MHz, Disk: 500GB TOSHIBA MQ01ABF0, Graphics: Intel Haswell-ULT IGP, Audio: Intel Device 0a0c, Network: Intel Connection I218-LM + Qualcomm Atheros AR9485 Wireless

Software:
OS: CentOS 6.5, Kernel: 2.6.32-431.5.1.el6.i686 (i686), Desktop: GNOME, Display Driver: intel 2.21.12, Compiler: GCC 4.4. 7 20120313, File-System: ext3, Screen Resolution: 1366x768


From /var/log/messages:

Code: Select all

    Detected CPU family 6 model 69
    UNSUPPORTED HARDWARE DEVICE: Intel CPU model
    ------------[ cut here ]------------
    WARNING: at kernel/rh_taint.c:13 mark_hardware_unsupported+0x37/0x40() (Not tainted)
    Hardware name: Latitude E5540
    Your hardware is unsupported.  Please do not report bugs, panics, oopses, etc., on this hardware.
    Modules linked in:
    Pid: 0, comm: swapper Not tainted 2.6.32-431.5.1.el6.i686 #1
    Call Trace:
     [<c045b0d1>] ? warn_slowpath_common+0x81/0xc0
     [<c0486017>] ? mark_hardware_unsupported+0x37/0x40
     [<c0486017>] ? mark_hardware_unsupported+0x37/0x40
     [<c045b163>] ? warn_slowpath_fmt_taint+0x33/0x40
     [<c0486017>] ? mark_hardware_unsupported+0x37/0x40
     [<c0aed4ea>] ? setup_arch+0xc77/0xc97
     [<c0b03854>] ? cgroup_init_subsys+0xcf/0xdb
     [<c0ae7710>] ? start_kernel+0xca/0x3b5
    ---[ end trace a7919e7f17c0a725 ]---
    NR_CPUS:32 nr_cpumask_bits:32 nr_cpu_ids:4 nr_node_ids:1
I did post some of this information in others topic hoping I would get some information out there status, but I also want this to stand on it's own in case new eye are looking at this problem.

Thank you for your help.

slamtonio
Posts: 24
Joined: 2007/07/23 18:11:20

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by slamtonio » 2014/03/07 01:09:43

This is not a fix...

Removing the kernel quiet parameter in /etc/grub.conf suppresses the "UNSUPPORTED HARDWARE DEVICE: Intel CPU model" at boot. It is still in /var/log/messages, but for now I think I can live with that since the system seems pretty solid.

User avatar
avij
Retired Moderator
Posts: 3039
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by avij » 2014/03/07 10:11:16

My guess is that this will get fixed in RHEL/CentOS 6.6. When will that be released -- I don't know, and your guess about the date will be just as good as mine.

wirezfree
Posts: 7
Joined: 2014/03/15 12:47:15

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by wirezfree » 2014/03/15 22:13:03

Hello,

I'm quite new to Linux & very, very new to CentOS 6.5, installed today in Virtualbox 4.3.8 on Host = Zorin 8(Ubuntu)
I also seem to have this issue, I'm not clear(sorry) if it is Virtualbox configuration, CentOS 6.5 or is it the Host issue.?

Code: Select all

Detected CPU family 6 model 69
UNSUPPORTED HARDWARE DEVICE: Intel CPU model
------------[ cut here ]------------
WARNING: at kernel/rh_taint.c:13 mark_hardware_unsupported+0x39/0x40() (Not tainted)
Hardware name: VirtualBox
Your hardware is unsupported.  Please do not report bugs, panics, oopses, etc., on this hardware.
Modules linked in:
Pid: 0, comm: swapper Not tainted 2.6.32-431.5.1.el6.x86_64 #1
Call Trace:
 [<ffffffff81071e27>] ? warn_slowpath_common+0x87/0xc0
 [<ffffffff81071ebf>] ? warn_slowpath_fmt_taint+0x3f/0x50
 [<ffffffff810a40f9>] ? mark_hardware_unsupported+0x39/0x40
 [<ffffffff81c2cb54>] ? setup_arch+0xc30/0xc53
 [<ffffffff8152761c>] ? printk+0x41/0x45
 [<ffffffff81c26c47>] ? start_kernel+0xdc/0x430
 [<ffffffff81c2633a>] ? x86_64_start_reservations+0x125/0x129
 [<ffffffff81c26453>] ? x86_64_start_kernel+0x115/0x124
---[ end trace a7919e7f17c0a725 ]---
I have HP Laptop i5 - 4200

Code: Select all

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 440FX - 82441FX PMC [Natoma] [8086:1237] (rev 02)
00:01.0 ISA bridge [0601]: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] [8086:7000]
00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]
00:03.0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet Controller [8086:100e] (rev 02)
00:04.0 System peripheral [0880]: InnoTek Systemberatung GmbH VirtualBox Guest Service [80ee:cafe]
00:05.0 Multimedia audio controller [0401]: Intel Corporation 82801AA AC'97 Audio Controller [8086:2415] (rev 01)
00:06.0 USB controller [0c03]: Apple Inc. KeyLargo/Intrepid USB [106b:003f]
00:07.0 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 08)
00:0b.0 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller [8086:265c]
00:0d.0 SATA controller [0106]: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] [8086:2829] (rev 02)
I'm not if this is related to the same problem.??
I also have 2 other entries in dmesg log, should I make seperate thread.??

Code: Select all

APIC routing finalized to flat.
WARNING: at arch/x86/kernel/apic/apic.c:1324 setup_local_APIC+0x189/0x290() (Tainted: G           --------------- H )
and

Code: Select all

WARNING: at arch/x86/kernel/apic/apic.c:1324 setup_local_APIC+0x189/0x290() (Tainted: G        W  --------------- H )
Please let me know what else I can provide to help

Many Thanks... David

User avatar
avij
Retired Moderator
Posts: 3039
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by avij » 2014/03/19 14:10:56

Considering that yours also says "Detected CPU family 6 model 69", I would think this is a similar issue. Assuming your system actually works fine despite the warning, I'd suggest not to worry too much about this at this time. Recheck the issue with CentOS 6.6 when it is released.

wirezfree
Posts: 7
Joined: 2014/03/15 12:47:15

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by wirezfree » 2014/03/19 18:38:56

avij wrote:Considering that yours also says "Detected CPU family 6 model 69", I would think this is a similar issue. Assuming your system actually works fine despite the warning, I'd suggest not to worry too much about this at this time. Recheck the issue with CentOS 6.6 when it released.
Hello avij,

O.K, thanks...
Yes, everything seems to be working, apart from a networking config issue..
Separate thread.

Thanks... David

lecbee
Posts: 14
Joined: 2014/03/27 09:13:26

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by lecbee » 2014/03/27 09:52:41

Looking at kernel-2.6.32-431.11.2.el6 src rpm, the message come from file "arch/x86/kernel/setup.c":

Code: Select all

static void rh_check_supported(void)
{
	/* The RHEL kernel does not support this hardware.  The kernel will
	 * attempt to boot, but no support is given for this hardware */

	[...]

	/* Intel CPU family 6, model greater than 60 */
	if ((boot_cpu_data.x86_vendor == X86_VENDOR_INTEL) &&
	    ((boot_cpu_data.x86 == 6))) {
		switch (boot_cpu_data.x86_model) {
		case 77: /* Atom Avoton */
		case 70: /* Crystal Well */
		case 63: /* Grantley/Haswell EP */
		case 62: /* Ivy Town */
			break;
		default:
			if (boot_cpu_data.x86_model > 60) {
				printk(KERN_CRIT
				       "Detected CPU family %d model %d\n",
				       boot_cpu_data.x86,
				       boot_cpu_data.x86_model);
				mark_hardware_unsupported("Intel CPU model");
			}
			break;
		}
	}
}
So this is just a check from RH preventing using CPU not be fully supported by RH when RHEL was released, ie. all CPU more recent than Haswell. But the i7-4600U is quite new (released in September 2013) and use a "model 69" code so it is not explicity targeted in this check code. I don't think this CPU is so different from other Haswell so I guess it will be caught in this code in a future update. You should file a bug on the CentOS bugzilla in order to be sure RH is aware of this CPU model and fix it.

Anyway, you should also check that your BIOS is up to date. This will not fix the message but it's still a good thing to have a updated BIOS. The last update is here:
http://www.dell.com/support/drivers/fr/ ... egoryId=BI

Also, using a 32-bit OS on this kind of hardware is a very very bad idea!

lecbee
Posts: 14
Joined: 2014/03/27 09:13:26

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by lecbee » 2014/04/04 10:36:38

Bad news.
Official answer from Red Hat:
https://bugzilla.redhat.com/show_bug.cgi?id=1083384

User avatar
avij
Retired Moderator
Posts: 3039
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by avij » 2014/04/04 11:18:25

"You are not authorized to access bug #1083384"

lecbee
Posts: 14
Joined: 2014/03/27 09:13:26

Re: UNSUPPORTED HARDWARE - CentOS 6.5 - Intel Core i7-4600U

Post by lecbee » 2014/04/04 11:42:53

Ok sorry.
I submitted a bug for that and I just got a short answer from Red Hat saying:
"Unfortunately, RHEL6.5 does not currently have a certification for the Haswell ULT processor." (Closed -> NOTABUG)

Post Reply

Return to “CentOS 6 - Hardware Support”